]> git.pld-linux.org Git - packages/acroread.git/blobdiff - acroread.spec
- patches stolen from ArchLinux to fix expr syntax error on run and some GTK stuff
[packages/acroread.git] / acroread.spec
index fbdf7745f3fd818e555e8a7154ade701a7089011..8f46f43f30ff5982cd22a0de76aac48c7cef5648 100644 (file)
@@ -13,7 +13,7 @@ Name:         %{base_name}
 Name:          %{base_name}-installer
 %endif
 %define        _rel    3
-Version:       7.0.5
+Version:       7.0.8
 Release:       %{_rel}%{?with_license_agreement:wla}
 Epoch:         1
 License:       distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
@@ -22,7 +22,7 @@ License:      distribution restricted (http://www.adobe.com/products/acrobat/distribu
 # - distribution on CD requires signing Distribution Agreement (see URL above)
 Group:         X11/Applications/Graphics
 %if %{with license_agreement}
-Source0:       http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0.5/enu/AdobeReader_enu-%{version}-1.i386.tar.gz
+Source0:       http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0.8/enu/AdobeReader_enu-%{version}-1.i386.tar.gz
 %else
 Source0:       license-installer.sh
 %endif
@@ -43,7 +43,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # TODO: galeon and skipstone, konqueror, opera.
 # use macro, otherwise extra LF inserted along with the ifarch
-%define        browsers mozilla, mozilla-firefox
+%define        browsers mozilla, mozilla-firefox, seamonkey
 
 %define                platform        intellinux
 %define                tar0            ILINXR.TAR
@@ -70,19 +70,19 @@ r
 ðÒÏÇÒÁÍÁ ÄÌÑ ÞÉÔÁÎÎÑ ÄÏËÕÍÅÎԦנՠÆÏÒÍÁÔ¦ Portable Document Format
 (PDF), ÚÇÅÎÅÒÏ×ÁÎÉÈ Adobe Acrobat'ÏÍ.
 
-%package plugin
+%package -n browser-plugin-%{name}
 Summary:       PDF plugin for Mozilla compatible browsers
 Summary(pl):   Wtyczka PDF dla przegl±darek zgodnych Mozilla
 Group:         X11/Applications
 Requires:      %{base_name} = %{epoch}:%{version}-%{release}
-Requires:      browser-plugins(%{_target_cpu})
-Requires:      mozilla-embedded
+Requires:      browser-plugins(%{_target_base_arch})
+Obsoletes:     acroread-plugin
 Obsoletes:     mozilla-plugin-acroread
 
-%description plugin
+%description -n browser-plugin-%{name}
 A Mozilla plugin for displaying PDF (Portable Document Format) files.
 
-%description plugin -l pl
+%description -n browser-plugin-%{name} -l pl
 Wtyczka Mozilli do wy¶wietlania plików PDF (Portable Document Format).
 
 %prep
@@ -144,47 +144,39 @@ rm -rf $RPM_BUILD_ROOT
 
 %else
 
-%triggerin plugin -- mozilla-firefox
+%triggerin -n browser-plugin-%{name} -- mozilla-firefox
 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nppdf.so
 
-%triggerun plugin -- mozilla-firefox
+%triggerun -n browser-plugin-%{name} -- mozilla-firefox
 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nppdf.so
 
-%triggerin plugin -- mozilla
+%triggerin -n browser-plugin-%{name} -- mozilla
 %nsplugin_install -d %{_libdir}/mozilla/plugins nppdf.so
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
-fi
-
-%triggerun plugin -- mozilla
+
+%triggerun -n browser-plugin-%{name} -- mozilla
 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins nppdf.so
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
-fi
-
-# % triggerin plugin -- konqueror
+
+%triggerin -n browser-plugin-%{name} -- seamonkey
+%nsplugin_install -d %{_libdir}/seamonkey/plugins nppdf.so
+
+%triggerun -n browser-plugin-%{name} -- seamonkey
+%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nppdf.so
+
+# % triggerin -n browser-plugin-%{name} -- konqueror
 # % nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nppdf.so
 
-# % triggerun plugin -- konqueror
+# % triggerun -n browser-plugin-%{name} -- konqueror
 # % nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nppdf.so
 
-# % triggerin plugin -- opera
+# % triggerin -n browser-plugin-%{name} -- opera
 # % nsplugin_install -d %{_libdir}/opera/plugins nppdf.so
 
-# % triggerun plugin -- opera
+# % triggerun -n browser-plugin-%{name} -- opera
 # % nsplugin_uninstall -d %{_libdir}/opera/plugins nppdf.so
 
 # as rpm removes the old obsoleted package files after the triggers
 # above are ran, add another trigger to make the links there.
-%triggerpostun plugin -- mozilla-plugin-acroread
+%triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-acroread, acroread-plugin
 %nsplugin_install -f -d %{_libdir}/mozilla/plugins nppdf.so
 
 %endif
@@ -211,17 +203,19 @@ fi
 %{_libdir}/%{base_name}/Reader/WebSearch
 %dir %{_libdir}/%{base_name}/Reader/%{platform}
 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
+%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
+%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
 %{_libdir}/%{base_name}/Reader/%{platform}/res
 %{_desktopdir}/acroread.desktop
 %{_pixmapsdir}/*
 
-%files plugin
+%files -n browser-plugin-%{name}
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_plugindir}/*
 %endif
This page took 0.257212 seconds and 4 git commands to generate.