]> git.pld-linux.org Git - packages/acroread.git/blobdiff - acroread.spec
- patches stolen from ArchLinux to fix expr syntax error on run and some GTK stuff
[packages/acroread.git] / acroread.spec
index 1bcf7f2dd8ee2e9fb3dedd75645a4fd30c788f2c..8f46f43f30ff5982cd22a0de76aac48c7cef5648 100644 (file)
@@ -1,45 +1,66 @@
+#
+# Conditional build:
+%bcond_with    license_agreement       # generates package
+#
+%define                base_name       acroread
 Summary:       Acrobat Reader
 Summary(pl):   Acrobat Reader - czytnik plików PDF
 Summary(ru):   ðÒÏÇÒÁÍÍÁ ÄÌÑ ÞÔÅÎÉÑ ÄÏËÕÍÅÎÔÏ× × ÆÏÒÍÁÔÅ PDF ÏÔ Adobe
 Summary(uk):   ðÒÏÇÒÁÍÁ ÄÌÑ ÞÉÔÁÎÎÑ ÄÏËÕÍÅÎԦנՠÆÏÒÍÁÔ¦ PDF ×¦Ä Adobe
-Name:          acroread
-Version:       405
-Release:       3
-License:       distributable
+%if %{with license_agreement}
+Name:          %{base_name}
+%else
+Name:          %{base_name}-installer
+%endif
+%define        _rel    3
+Version:       7.0.8
+Release:       %{_rel}%{?with_license_agreement:wla}
+Epoch:         1
+License:       distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
+# in short:
+# - not distributable on public sites (only linking to adobe.com permitted)
+# - distribution on CD requires signing Distribution Agreement (see URL above)
 Group:         X11/Applications/Graphics
-Group(cs):     X11/Aplikace/Grafika
-Group(da):     X11/Programmer/Grafik
-Group(de):     X11/Applikationen/Grafik
-Group(es):     X11/Aplicaciones/Gráficos
-Group(fr):     X11/Applications/Graphiques
-Group(id):     X11/Aplikasi/Grafik
-Group(is):     X11/Forrit/Myndvinnsla
-Group(it):     X11/Applicazioni/Immagini
-Group(ja):     X11/¥¢¥×¥ê¥±¡¼¥·¥ç¥ó/¥°¥é¥Õ¥£¥Ã¥¯¥¹
-Group(no):     X11/Applikasjoner/Grafikk
-Group(pl):     X11/Aplikacje/Grafika
-Group(pt):     X11/Aplicações/Gráficos
-Group(ru):     X11/ðÒÉÌÏÖÅÎÉÑ/çÒÁÆÉËÁ
-Group(sl):     X11/Programi/Grafika
-Group(sv):     X11/Tillämpningar/Grafik
-Group(uk):     X11/ðÒÉËÌÁÄΦ ðÒÏÇÒÁÍÉ/çÒÁƦËÁ
-Source0:       ftp://ftp.adobe.com/pub/adobe/acrobatreader/unix/4.x/linux-ar-%{version}.tar.gz
-Patch0:                %{name}-locale.patch
-%define                platform                intellinux
-%define                sourcedir               ILINXR.install
-%define                tar0                    ILINXR.TAR
-%define                tar1                    READ.TAR
-Exclusivearch: %{ix86}
+%if %{with license_agreement}
+Source0:       http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0.8/enu/AdobeReader_enu-%{version}-1.i386.tar.gz
+%else
+Source0:       license-installer.sh
+%endif
+# please update @COPYSOURCES@ below if you add more Sources.
+Source1:       %{base_name}.desktop
+Source2:       %{base_name}.png
+URL:           http://www.adobe.com/products/acrobat/
+%if %{with license_agreement}
+BuildRequires: rpmbuild(macros) >= 1.236
+Requires:      openldap-libs >= 2.3
+%else
+Requires:      rpm-build-tools
+%endif
+ExclusiveArch: %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
+%define                _plugindir      %{_libdir}/browser-plugins
+
+# TODO: galeon and skipstone, konqueror, opera.
+# use macro, otherwise extra LF inserted along with the ifarch
+%define        browsers mozilla, mozilla-firefox, seamonkey
+
+%define                platform        intellinux
+%define                tar0            ILINXR.TAR
+%define                tar1            COMMON.TAR
+
+%define                _noautostrip    .*\.api
+%define                _noautoreq      '^lib.*\.so$' '^lib.*\(VERSION\)$'
 
 %description
-Adobe AcrobatReader - pdf browser.
+Adobe(R) Reader(R) is free software that lets you view and print PDF
+files (Portable Document Format) on a variety of hardware and
+operating system platforms.
 
 %description -l pl
-Oryginalny program firmy Adobe do przegl±dania plików .pdf.
+Adobe(R) Reader(R) jest darmowym oprogramowaniem umo¿liwiaj±cym
+ogl±danie oraz drukowanie plików PDF (Portable Document Format) na
+ró¿nych platformach sprzêtowych oraz ró¿nych systemach operacyjnych.
 
 %description -l ru
 ðÒÏÇÒÁÍÍÁ ÄÌÑ ÞÔÅÎÉÑ ÄÏËÕÍÅÎÔÏ× × ÆÏÒÍÁÔÅ Portable Document Format
@@ -49,45 +70,152 @@ Oryginalny program firmy Adobe do przegl
 ðÒÏÇÒÁÍÁ ÄÌÑ ÞÉÔÁÎÎÑ ÄÏËÕÍÅÎԦנՠÆÏÒÍÁÔ¦ Portable Document Format
 (PDF), ÚÇÅÎÅÒÏ×ÁÎÉÈ Adobe Acrobat'ÏÍ.
 
+%package -n browser-plugin-%{name}
+Summary:       PDF plugin for Mozilla compatible browsers
+Summary(pl):   Wtyczka PDF dla przegl±darek zgodnych Mozilla
+Group:         X11/Applications
+Requires:      %{base_name} = %{epoch}:%{version}-%{release}
+Requires:      browser-plugins(%{_target_base_arch})
+Obsoletes:     acroread-plugin
+Obsoletes:     mozilla-plugin-acroread
+
+%description -n browser-plugin-%{name}
+A Mozilla plugin for displaying PDF (Portable Document Format) files.
+
+%description -n browser-plugin-%{name} -l pl
+Wtyczka Mozilli do wy¶wietlania plików PDF (Portable Document Format).
+
 %prep
-%setup -q -n %{sourcedir}
-tar xfv %{tar0}
-tar xfv %{tar1}
-%patch0 -p1
+%if %{with license_agreement}
+%setup -q -c
+cd AdobeReader
+tar xf %{tar0}
+tar xf %{tar1}
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_bindir}
-install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
+%if %{without license_agreement}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
+
+sed -e '
+       s/@BASE_NAME@/%{base_name}/g
+       s/@TARGET_CPU@/%{_target_cpu}/g
+       s-@VERSION@-%{version}-g
+       s-@RELEASE@-%{release}-g
+       s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
+       s,@DATADIR@,%{_datadir}/%{base_name},g
+       s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
+' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
-cp -a Browsers Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{name}
-awk -v INSTDIR=%{_libdir}/%{name}/Reader \
-       '/^install_dir=/ {print "install_dir="INSTDIR ; next} \
-        {print}' \
-       bin/%{name}.sh > $RPM_BUILD_ROOT%{_bindir}/%{name}
+install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
-gzip -9nf LICREAD.TXT INSTGUID.TXT ReadMe
+%else
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_plugindir}} \
+       $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
+
+cd AdobeReader
+cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
+awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
+       '/^install_dir=/ {print "install_dir="INSTDIR; next} \
+       {print}' \
+       bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
+install Browser/%{platform}/* $RPM_BUILD_ROOT%{_plugindir}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
+
+rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
+
+ln -sf /usr/lib/liblber-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
+ln -sf /usr/lib/libldap-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
+ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
+
+chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{without license_agreement}
+%post
+%{_bindir}/%{base_name}.install
+
+%else
+
+%triggerin -n browser-plugin-%{name} -- mozilla-firefox
+%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nppdf.so
+
+%triggerun -n browser-plugin-%{name} -- mozilla-firefox
+%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nppdf.so
+
+%triggerin -n browser-plugin-%{name} -- mozilla
+%nsplugin_install -d %{_libdir}/mozilla/plugins nppdf.so
+
+%triggerun -n browser-plugin-%{name} -- mozilla
+%nsplugin_uninstall -d %{_libdir}/mozilla/plugins nppdf.so
+
+%triggerin -n browser-plugin-%{name} -- seamonkey
+%nsplugin_install -d %{_libdir}/seamonkey/plugins nppdf.so
+
+%triggerun -n browser-plugin-%{name} -- seamonkey
+%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nppdf.so
+
+# % triggerin -n browser-plugin-%{name} -- konqueror
+# % nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nppdf.so
+
+# % triggerun -n browser-plugin-%{name} -- konqueror
+# % nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nppdf.so
+
+# % triggerin -n browser-plugin-%{name} -- opera
+# % nsplugin_install -d %{_libdir}/opera/plugins nppdf.so
+
+# % triggerun -n browser-plugin-%{name} -- opera
+# % nsplugin_uninstall -d %{_libdir}/opera/plugins nppdf.so
+
+# as rpm removes the old obsoleted package files after the triggers
+# above are ran, add another trigger to make the links there.
+%triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-acroread, acroread-plugin
+%nsplugin_install -f -d %{_libdir}/mozilla/plugins nppdf.so
+
+%endif
+
 %files
 %defattr(644,root,root,755)
-%doc LICREAD.TXT.gz INSTGUID.TXT.gz ReadMe.gz
+%if %{without license_agreement}
+%attr(755,root,root) %{_bindir}/%{base_name}.install
+%{_datadir}/%{base_name}
+%else
+%doc AdobeReader/{LICREAD.TXT,ReadMe.htm}
 %attr(755,root,root) %{_bindir}/*
-%dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/Browsers
-%{_libdir}/%{name}/Resource
-
-%dir %{_libdir}/%{name}/Reader
-%{_libdir}/%{name}/Reader/help
-%{_libdir}/%{name}/Reader/res
-%{_libdir}/%{name}/Reader/AcroVersion
-%{_libdir}/%{name}/Reader/*.pdf
-%dir %{_libdir}/%{name}/Reader/%{platform}
-%{_libdir}/%{name}/Reader/%{platform}/app-defaults
-%{_libdir}/%{name}/Reader/%{platform}/fonts
-%{_libdir}/%{name}/Reader/%{platform}/res
-%attr(755,root,root) %{_libdir}/%{name}/Reader/%{platform}/plug_ins
-%attr(755,root,root) %{_libdir}/%{name}/Reader/%{platform}/bin
-%attr(755,root,root) %{_libdir}/%{name}/Reader/%{platform}/lib
+%dir %{_libdir}/%{base_name}
+%{_libdir}/%{base_name}/Resource
+%dir %{_libdir}/%{base_name}/Reader
+%{_libdir}/%{base_name}/Reader/help
+%{_libdir}/%{base_name}/Reader/AcroVersion
+%{_libdir}/%{base_name}/Reader/Cert
+%{_libdir}/%{base_name}/Reader/GlobalPrefs
+%{_libdir}/%{base_name}/Reader/HowTo
+%{_libdir}/%{base_name}/Reader/Legal
+%{_libdir}/%{base_name}/Reader/JavaScripts
+%{_libdir}/%{base_name}/Reader/Messages
+%{_libdir}/%{base_name}/Reader/WebSearch
+%dir %{_libdir}/%{base_name}/Reader/%{platform}
+%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
+%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
+%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
+%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
+%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
+%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
+%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
+%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
+%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
+%{_libdir}/%{base_name}/Reader/%{platform}/res
+%{_desktopdir}/acroread.desktop
+%{_pixmapsdir}/*
+
+%files -n browser-plugin-%{name}
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_plugindir}/*
+%endif
This page took 0.082774 seconds and 4 git commands to generate.