]> git.pld-linux.org Git - packages/acroread.git/blame - acroread.spec
add R: %{_libdir}/gconv for 32bit iconv on 64bit systems
[packages/acroread.git] / acroread.spec
CommitLineData
14b68627 1#
2# Conditional build:
4d433c27 3%bcond_with license_agreement # generates package
14b68627 4#
26e61bd9 5%define base_name acroread
a7c55aac 6%define rel 1
0eb57bee 7Summary: Adobe Acrobat Reader
aadbc0c6
ER
8Summary(pl.UTF-8): Adobe Acrobat Reader - czytnik plików PDF
9Summary(ru.UTF-8): Программа для чтения документов в формате PDF от Adobe
10Summary(uk.UTF-8): Програма для читання документів у форматі PDF від Adobe
14b68627 11%if %{with license_agreement}
12Name: %{base_name}
13%else
14Name: %{base_name}-installer
15%endif
4a18384d 16Version: 9.5.5
80a5eb81 17Release: %{rel}%{?with_license_agreement:wla}
81f6ad30 18Epoch: 1
ef009d9a
JB
19License: distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20# in short:
21# - not distributable on public sites (only linking to adobe.com permitted)
22# - distribution on CD requires signing Distribution Agreement (see URL above)
94abd8dc 23Group: X11/Applications/Graphics
14b68627 24%if %{with license_agreement}
cf646d82 25Source0: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr%{version}-1_i486linux_enu.tar.bz2
4a18384d 26# NoSource0-md5: 664d546fbf0ad91f20dcf3753b0a2684
ecf5969f 27NoSource: 0
e4f54b4c 28%else
0337a7fe 29Source1: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
d33fe009 30# Source1-md5: 329c25f457fea66ec502b7ef70cb9ede
14b68627 31%endif
a189ca6f 32# please update @COPYSOURCES@ below if you add more Sources or Patches.
1af9d1cc 33Source2: %{base_name}.desktop
34Source3: %{base_name}.png
14f626f0 35URL: http://www.adobe.com/products/acrobat/
976c259d 36%if %{with license_agreement}
3e94b2a4 37BuildRequires: rpmbuild(macros) >= 1.357
8e71c5a3
KK
38# to force 32bit iconv
39Requires: %{_libdir}/gconv
69e4e202 40Requires: ca-certificates >= 20080809-4
bcaf2651 41Requires: iconv
7a2c413b 42Requires: openldap-libs < 2.5
2da3bb9c 43Requires: openldap-libs >= 2.4
26e61bd9 44%else
18faefb3 45Requires: rpm-build-tools >= 4.4.37
72426ec4 46Requires: rpmbuild(macros) >= 1.544
976c259d 47%endif
14f626f0 48ExclusiveArch: %{ix86}
9947ca59 49ExcludeArch: i386
aed33851 50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
7985bc82 51
fcf3bf1c 52%define platform intellinux
22bd4e96 53%define tar0 ILINXR.TAR
fcf3bf1c 54%define tar1 COMMON.TAR
94abd8dc 55
dfbbcb35 56%define _noautostrip .*\.api
2da3bb9c 57%define _noautoprov libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
a90af9c0 58%if "%{_rpmversion}" >= "5.0"
5978523c 59%define _noautoreq %{_noautoprov} '^lib.*\.so$' '^lib.*\\(VERSION\\)$'
a90af9c0
JB
60%else
61%define _noautoreq %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
62%endif
feb5d64e 63%define no_install_post_check_so 1
f21ac523 64
7985bc82 65%description
26e61bd9
ER
66Adobe(R) Reader(R) is free software that lets you view and print PDF
67files (Portable Document Format) on a variety of hardware and
62807d83 68operating system platforms.
7985bc82 69
e013bd4f
JR
70%description -l pl.UTF-8
71Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
72oglądanie oraz drukowanie plików PDF (Portable Document Format) na
73różnych platformach sprzętowych oraz różnych systemach operacyjnych.
7985bc82 74
e013bd4f
JR
75%description -l ru.UTF-8
76Программа для чтения документов в формате Portable Document Format
77(PDF), сгенерированных Adobe Acrobat'ом.
d44545ff 78
e013bd4f
JR
79%description -l uk.UTF-8
80Програма для читання документів у форматі Portable Document Format
81(PDF), згенерованих Adobe Acrobat'ом.
d44545ff 82
f994d3ef 83%package -n browser-plugin-%{name}
ae0ad7e9 84Summary: PDF plugin for Mozilla compatible browsers
aadbc0c6 85Summary(pl.UTF-8): Wtyczka PDF dla przeglądarek zgodnych Mozilla
2e45421f 86Group: X11/Applications
26e61bd9 87Requires: %{base_name} = %{epoch}:%{version}-%{release}
3e94b2a4 88Requires: browser-plugins >= 2.0
f994d3ef 89Obsoletes: acroread-plugin
ae0ad7e9 90Obsoletes: mozilla-plugin-acroread
2e45421f 91
f994d3ef 92%description -n browser-plugin-%{name}
62807d83 93A Mozilla plugin for displaying PDF (Portable Document Format) files.
2e45421f 94
e013bd4f
JR
95%description -n browser-plugin-%{name} -l pl.UTF-8
96Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
2e45421f 97
7985bc82 98%prep
14b68627 99%if %{with license_agreement}
17a8eeab 100%setup -q -c
22bd4e96 101cd AdobeReader
ea015334
AM
102tar xf %{tar0}
103tar xf %{tar1}
14b68627 104%endif
7985bc82 105
106%install
107rm -rf $RPM_BUILD_ROOT
0eb57bee 108%if %{without license_agreement}
14b68627 109install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
110
e4f54b4c
ER
111sed -e '
112 s/@BASE_NAME@/%{base_name}/g
113 s/@TARGET_CPU@/%{_target_cpu}/g
114 s-@VERSION@-%{version}-g
115 s-@RELEASE@-%{release}-g
116 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
117 s,@DATADIR@,%{_datadir}/%{base_name},g
78a918bf 118 s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
1af9d1cc 119' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
14b68627 120
121install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 122install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
1af9d1cc 123install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 124
125%else
a0e9a49f
JB
126install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name}/bin} \
127 $RPM_BUILD_ROOT{%{_browserpluginsdir},%{_desktopdir},%{_pixmapsdir}}
7985bc82 128
6dc16e8f 129cd AdobeReader/Adobe/Reader9
a0e9a49f
JB
130cp -a Browser Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
131%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Browser/install_browser_plugin
14b68627 132awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
14f626f0
TP
133 '/^install_dir=/ {print "install_dir="INSTDIR; next} \
134 {print}' \
a0e9a49f 135 bin/%{base_name} > $RPM_BUILD_ROOT%{_libdir}/%{base_name}/bin/%{base_name}
22bd4e96 136
a0e9a49f
JB
137# IMPORTANT NOTE: Here symlinks must be used instead of moving parts of tree
138# for compatibility with other binary-only Adobe software (like AIR).
139# This one is required to find Reader tree (relative to symlink target)...
140ln -sf %{_libdir}/%{base_name}/bin/%{base_name} $RPM_BUILD_ROOT%{_bindir}/%{base_name}
141# ...and nppdf plugin is expected in Browser subdir...
142# ...so just symlink it to be used as browsers plugin.
143ln -sf %{_libdir}/%{base_name}/Browser/%{platform}/nppdf.so $RPM_BUILD_ROOT%{_browserpluginsdir}/nppdf.so
6dc16e8f 144
a0e9a49f
JB
145install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
146install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
3f07d2af 147
7a2c413b
JB
148ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
149ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
69e4e202 150ln -sf /etc/certs/ca-certificates.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
22bd4e96 151
a0e9a49f 152# don't generate dependencies for internal libs
22bd4e96 153chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
14b68627 154%endif
7985bc82 155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
0eb57bee 159%if %{without license_agreement}
5d59434a 160%post
e4f54b4c 161%{_bindir}/%{base_name}.install
3e94b2a4 162%endif
ae0ad7e9 163
3e94b2a4 164%if %{with license_agreement}
165%post -n browser-plugin-%{name}
166%update_browser_plugins
ae0ad7e9 167
3e94b2a4 168%postun -n browser-plugin-%{name}
169if [ "$1" = 0 ]; then
170 %update_browser_plugins
171fi
14b68627 172%endif
173
7985bc82 174%files
175%defattr(644,root,root,755)
0eb57bee 176%if %{without license_agreement}
14b68627 177%attr(755,root,root) %{_bindir}/%{base_name}.install
178%{_datadir}/%{base_name}
179%else
78a918bf 180%doc AdobeReader/ReadMe.htm
a0e9a49f 181%attr(755,root,root) %{_bindir}/acroread
14b68627 182%dir %{_libdir}/%{base_name}
a0e9a49f
JB
183%dir %{_libdir}/%{base_name}/Browser
184%dir %{_libdir}/%{base_name}/Browser/%{platform}
185%attr(755,root,root) %{_libdir}/%{base_name}/Browser/%{platform}/nppdf.so
186%{_libdir}/%{base_name}/Browser/HowTo
14b68627 187%dir %{_libdir}/%{base_name}/Reader
188%{_libdir}/%{base_name}/Reader/help
14b68627 189%{_libdir}/%{base_name}/Reader/AcroVersion
22bd4e96
AM
190%{_libdir}/%{base_name}/Reader/Cert
191%{_libdir}/%{base_name}/Reader/GlobalPrefs
c7dc1b0b 192%{_libdir}/%{base_name}/Reader/IDTemplates
22bd4e96 193%{_libdir}/%{base_name}/Reader/JavaScripts
c7dc1b0b
TP
194%{_libdir}/%{base_name}/Reader/Legal
195%{_libdir}/%{base_name}/Reader/Tracker
196%{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
197%{_libdir}/%{base_name}/Reader/pmd.cer
78a918bf 198%{_libdir}/%{base_name}/Reader/%{platform}/mozilla
14b68627 199%dir %{_libdir}/%{base_name}/Reader/%{platform}
714a6915 200%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
c7dc1b0b 201%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
43255eee 202%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
714a6915 203%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
14b68627 204%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
205%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
714a6915 206%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
43255eee 207%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
78a918bf 208%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
714a6915
KK
209%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
210%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
c7dc1b0b 211%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
a0e9a49f
JB
212%{_libdir}/%{base_name}/Resource
213%dir %{_libdir}/%{base_name}/bin
214%attr(755,root,root) %{_libdir}/%{base_name}/bin/acroread
a7dabf0b 215%{_desktopdir}/acroread.desktop
a0e9a49f 216%{_pixmapsdir}/acroread.png
2e45421f 217
f994d3ef 218%files -n browser-plugin-%{name}
2e45421f 219%defattr(644,root,root,755)
a0e9a49f 220%attr(755,root,root) %{_browserpluginsdir}/nppdf.so
14b68627 221%endif
This page took 0.063225 seconds and 4 git commands to generate.