]> git.pld-linux.org Git - packages/acroread.git/blame - acroread.spec
- outdated
[packages/acroread.git] / acroread.spec
CommitLineData
14b68627 1#
2# Conditional build:
3%bcond_with license_agreement # generates package
4#
26e61bd9 5%define base_name acroread
0eb57bee 6Summary: Adobe Acrobat Reader
aadbc0c6
ER
7Summary(pl.UTF-8): Adobe Acrobat Reader - czytnik plików PDF
8Summary(ru.UTF-8): Программа для чтения документов в формате PDF от Adobe
9Summary(uk.UTF-8): Програма для читання документів у форматі PDF від Adobe
14b68627 10%if %{with license_agreement}
11Name: %{base_name}
12%else
13Name: %{base_name}-installer
14%endif
0eb57bee 15%define _rel 1
c7dc1b0b 16Version: 8.1.1
5d59434a 17Release: %{_rel}%{?with_license_agreement:wla}
22bd4e96 18Epoch: 1
ef009d9a
JB
19License: distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20# in short:
21# - not distributable on public sites (only linking to adobe.com permitted)
22# - distribution on CD requires signing Distribution Agreement (see URL above)
94abd8dc 23Group: X11/Applications/Graphics
14b68627 24%if %{with license_agreement}
c7dc1b0b
TP
25Source0: http://ardownload.adobe.com/pub/adobe/reader/unix/8.x/%{version}/enu/AdobeReader_enu-%{version}-1.i486.tar.gz
26# NoSource0-md5: e7630311c597feff26024c3383eab110
ecf5969f 27NoSource: 0
e4f54b4c
ER
28%else
29Source0: license-installer.sh
14b68627 30%endif
a189ca6f 31# please update @COPYSOURCES@ below if you add more Sources or Patches.
14b68627 32Source1: %{base_name}.desktop
33Source2: %{base_name}.png
14f626f0 34URL: http://www.adobe.com/products/acrobat/
976c259d
JR
35%if %{with license_agreement}
36BuildRequires: rpmbuild(macros) >= 1.236
7a2c413b
JB
37Requires: openldap-libs >= 2.4
38Requires: openldap-libs < 2.5
26e61bd9
ER
39%else
40Requires: rpm-build-tools
976c259d 41%endif
14f626f0 42ExclusiveArch: %{ix86}
9947ca59 43ExcludeArch: i386
aed33851 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
7985bc82 45
976c259d
JR
46%define _plugindir %{_libdir}/browser-plugins
47
48# TODO: galeon and skipstone, konqueror, opera.
49# use macro, otherwise extra LF inserted along with the ifarch
765b9eea 50%define browsers mozilla, mozilla-firefox, seamonkey
976c259d 51
fcf3bf1c 52%define platform intellinux
22bd4e96 53%define tar0 ILINXR.TAR
fcf3bf1c 54%define tar1 COMMON.TAR
94abd8dc 55
dfbbcb35 56%define _noautostrip .*\.api
7a2c413b
JB
57%define _noautoprov libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
58%define _noautoreq %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
f21ac523 59
7985bc82 60%description
26e61bd9
ER
61Adobe(R) Reader(R) is free software that lets you view and print PDF
62files (Portable Document Format) on a variety of hardware and
62807d83 63operating system platforms.
7985bc82 64
e013bd4f
JR
65%description -l pl.UTF-8
66Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
67oglądanie oraz drukowanie plików PDF (Portable Document Format) na
68różnych platformach sprzętowych oraz różnych systemach operacyjnych.
7985bc82 69
e013bd4f
JR
70%description -l ru.UTF-8
71Программа для чтения документов в формате Portable Document Format
72(PDF), сгенерированных Adobe Acrobat'ом.
d44545ff 73
e013bd4f
JR
74%description -l uk.UTF-8
75Програма для читання документів у форматі Portable Document Format
76(PDF), згенерованих Adobe Acrobat'ом.
d44545ff 77
f994d3ef 78%package -n browser-plugin-%{name}
ae0ad7e9 79Summary: PDF plugin for Mozilla compatible browsers
aadbc0c6 80Summary(pl.UTF-8): Wtyczka PDF dla przeglądarek zgodnych Mozilla
2e45421f 81Group: X11/Applications
26e61bd9 82Requires: %{base_name} = %{epoch}:%{version}-%{release}
875f730f 83Requires: browser-plugins(%{_target_base_arch})
f994d3ef 84Obsoletes: acroread-plugin
ae0ad7e9 85Obsoletes: mozilla-plugin-acroread
2e45421f 86
f994d3ef 87%description -n browser-plugin-%{name}
62807d83 88A Mozilla plugin for displaying PDF (Portable Document Format) files.
2e45421f 89
e013bd4f
JR
90%description -n browser-plugin-%{name} -l pl.UTF-8
91Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
2e45421f 92
7985bc82 93%prep
14b68627 94%if %{with license_agreement}
17a8eeab 95%setup -q -c
22bd4e96 96cd AdobeReader
ea015334
AM
97tar xf %{tar0}
98tar xf %{tar1}
14b68627 99%endif
7985bc82 100
101%install
102rm -rf $RPM_BUILD_ROOT
0eb57bee 103%if %{without license_agreement}
14b68627 104install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
105
e4f54b4c
ER
106sed -e '
107 s/@BASE_NAME@/%{base_name}/g
108 s/@TARGET_CPU@/%{_target_cpu}/g
109 s-@VERSION@-%{version}-g
110 s-@RELEASE@-%{release}-g
111 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
112 s,@DATADIR@,%{_datadir}/%{base_name},g
78a918bf 113 s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
e4f54b4c 114' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
14b68627 115
116install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
117install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
118install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 119
120%else
ae0ad7e9 121install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_plugindir}} \
a7dabf0b 122 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
7985bc82 123
c7dc1b0b
TP
124# note: there're also AdobeReader/Adobe/Help{,Viewer}
125cd AdobeReader/Adobe/Reader8
14b68627 126cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
127awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
14f626f0
TP
128 '/^install_dir=/ {print "install_dir="INSTDIR; next} \
129 {print}' \
22bd4e96 130 bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
ae0ad7e9 131install Browser/%{platform}/* $RPM_BUILD_ROOT%{_plugindir}
a7dabf0b 132install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
8a44dca4 133install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
22bd4e96 134
3f07d2af 135rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
136
7a2c413b
JB
137ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
138ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
22bd4e96
AM
139ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
140
141chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
14b68627 142%endif
7985bc82 143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
0eb57bee 147%if %{without license_agreement}
5d59434a 148%post
e4f54b4c 149%{_bindir}/%{base_name}.install
ae0ad7e9
JR
150
151%else
152
f994d3ef 153%triggerin -n browser-plugin-%{name} -- mozilla-firefox
ae0ad7e9
JR
154%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nppdf.so
155
f994d3ef 156%triggerun -n browser-plugin-%{name} -- mozilla-firefox
ae0ad7e9
JR
157%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nppdf.so
158
f994d3ef 159%triggerin -n browser-plugin-%{name} -- mozilla
ae0ad7e9 160%nsplugin_install -d %{_libdir}/mozilla/plugins nppdf.so
ae0ad7e9 161
f994d3ef 162%triggerun -n browser-plugin-%{name} -- mozilla
ae0ad7e9 163%nsplugin_uninstall -d %{_libdir}/mozilla/plugins nppdf.so
ae0ad7e9 164
f994d3ef 165%triggerin -n browser-plugin-%{name} -- seamonkey
765b9eea 166%nsplugin_install -d %{_libdir}/seamonkey/plugins nppdf.so
167
f994d3ef 168%triggerun -n browser-plugin-%{name} -- seamonkey
765b9eea 169%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nppdf.so
170
f994d3ef 171# % triggerin -n browser-plugin-%{name} -- konqueror
ae0ad7e9
JR
172# % nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nppdf.so
173
f994d3ef 174# % triggerun -n browser-plugin-%{name} -- konqueror
ae0ad7e9
JR
175# % nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nppdf.so
176
f994d3ef 177# % triggerin -n browser-plugin-%{name} -- opera
ae0ad7e9
JR
178# % nsplugin_install -d %{_libdir}/opera/plugins nppdf.so
179
f994d3ef 180# % triggerun -n browser-plugin-%{name} -- opera
ae0ad7e9
JR
181# % nsplugin_uninstall -d %{_libdir}/opera/plugins nppdf.so
182
183# as rpm removes the old obsoleted package files after the triggers
184# above are ran, add another trigger to make the links there.
4424d826 185%triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-acroread, acroread-plugin
ae0ad7e9
JR
186%nsplugin_install -f -d %{_libdir}/mozilla/plugins nppdf.so
187
14b68627 188%endif
189
7985bc82 190%files
191%defattr(644,root,root,755)
0eb57bee 192%if %{without license_agreement}
14b68627 193%attr(755,root,root) %{_bindir}/%{base_name}.install
194%{_datadir}/%{base_name}
195%else
78a918bf 196%doc AdobeReader/ReadMe.htm
7985bc82 197%attr(755,root,root) %{_bindir}/*
14b68627 198%dir %{_libdir}/%{base_name}
199%{_libdir}/%{base_name}/Resource
14b68627 200%dir %{_libdir}/%{base_name}/Reader
201%{_libdir}/%{base_name}/Reader/help
14b68627 202%{_libdir}/%{base_name}/Reader/AcroVersion
c7dc1b0b 203%{_libdir}/%{base_name}/Reader/BeyondReader
22bd4e96
AM
204%{_libdir}/%{base_name}/Reader/Cert
205%{_libdir}/%{base_name}/Reader/GlobalPrefs
206%{_libdir}/%{base_name}/Reader/HowTo
c7dc1b0b 207%{_libdir}/%{base_name}/Reader/IDTemplates
22bd4e96 208%{_libdir}/%{base_name}/Reader/JavaScripts
c7dc1b0b
TP
209%{_libdir}/%{base_name}/Reader/Legal
210%{_libdir}/%{base_name}/Reader/Tracker
211%{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
212%{_libdir}/%{base_name}/Reader/pmd.cer
78a918bf 213%{_libdir}/%{base_name}/Reader/%{platform}/mozilla
14b68627 214%dir %{_libdir}/%{base_name}/Reader/%{platform}
714a6915 215%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
c7dc1b0b 216%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
43255eee 217%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
714a6915 218%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
14b68627 219%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
220%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
714a6915 221%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
43255eee 222%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
78a918bf 223%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
714a6915
KK
224%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
225%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
c7dc1b0b 226%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
a7dabf0b 227%{_desktopdir}/acroread.desktop
8a44dca4 228%{_pixmapsdir}/*
2e45421f 229
f994d3ef 230%files -n browser-plugin-%{name}
2e45421f 231%defattr(644,root,root,755)
ae0ad7e9 232%attr(755,root,root) %{_plugindir}/*
14b68627 233%endif
This page took 0.122542 seconds and 4 git commands to generate.