]> git.pld-linux.org Git - packages/acroread.git/blame - acroread.spec
- Removed non-existent patches
[packages/acroread.git] / acroread.spec
CommitLineData
14b68627 1#
2# Conditional build:
3%bcond_with license_agreement # generates package
4#
26e61bd9 5%define base_name acroread
0eb57bee 6Summary: Adobe Acrobat Reader
aadbc0c6
ER
7Summary(pl.UTF-8): Adobe Acrobat Reader - czytnik plików PDF
8Summary(ru.UTF-8): Программа для чтения документов в формате PDF от Adobe
9Summary(uk.UTF-8): Програма для читання документів у форматі PDF від Adobe
14b68627 10%if %{with license_agreement}
11Name: %{base_name}
12%else
13Name: %{base_name}-installer
14%endif
0eb57bee
ER
15%define _rel 1
16Version: 7.0.9
5d59434a 17Release: %{_rel}%{?with_license_agreement:wla}
22bd4e96 18Epoch: 1
ef009d9a
JB
19License: distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20# in short:
21# - not distributable on public sites (only linking to adobe.com permitted)
22# - distribution on CD requires signing Distribution Agreement (see URL above)
94abd8dc 23Group: X11/Applications/Graphics
14b68627 24%if %{with license_agreement}
0eb57bee 25Source0: http://ardownload.adobe.com/pub/adobe/reader/unix/7x/%{version}/enu/AdobeReader_enu-%{version}-1.i386.tar.gz
7a949005 26# NoSource0-md5: a8e79a1af58f90640cf9e7e1532a5745
e4f54b4c
ER
27%else
28Source0: license-installer.sh
14b68627 29%endif
5d59434a 30# please update @COPYSOURCES@ below if you add more Sources.
14b68627 31Source1: %{base_name}.desktop
32Source2: %{base_name}.png
daa817b9 33Patch0: %{base_name}-gtk.patch
14f626f0 34URL: http://www.adobe.com/products/acrobat/
976c259d
JR
35%if %{with license_agreement}
36BuildRequires: rpmbuild(macros) >= 1.236
3ed80526 37Requires: openldap-libs >= 2.3
26e61bd9
ER
38%else
39Requires: rpm-build-tools
976c259d 40%endif
14f626f0 41ExclusiveArch: %{ix86}
aed33851 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
7985bc82 43
976c259d
JR
44%define _plugindir %{_libdir}/browser-plugins
45
46# TODO: galeon and skipstone, konqueror, opera.
47# use macro, otherwise extra LF inserted along with the ifarch
765b9eea 48%define browsers mozilla, mozilla-firefox, seamonkey
976c259d 49
fcf3bf1c 50%define platform intellinux
22bd4e96 51%define tar0 ILINXR.TAR
fcf3bf1c 52%define tar1 COMMON.TAR
94abd8dc 53
dfbbcb35 54%define _noautostrip .*\.api
22bd4e96 55%define _noautoreq '^lib.*\.so$' '^lib.*\(VERSION\)$'
f21ac523 56
7985bc82 57%description
26e61bd9
ER
58Adobe(R) Reader(R) is free software that lets you view and print PDF
59files (Portable Document Format) on a variety of hardware and
62807d83 60operating system platforms.
7985bc82 61
e013bd4f
JR
62%description -l pl.UTF-8
63Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
64oglądanie oraz drukowanie plików PDF (Portable Document Format) na
65różnych platformach sprzętowych oraz różnych systemach operacyjnych.
7985bc82 66
e013bd4f
JR
67%description -l ru.UTF-8
68Программа для чтения документов в формате Portable Document Format
69(PDF), сгенерированных Adobe Acrobat'ом.
d44545ff 70
e013bd4f
JR
71%description -l uk.UTF-8
72Програма для читання документів у форматі Portable Document Format
73(PDF), згенерованих Adobe Acrobat'ом.
d44545ff 74
f994d3ef 75%package -n browser-plugin-%{name}
ae0ad7e9 76Summary: PDF plugin for Mozilla compatible browsers
aadbc0c6 77Summary(pl.UTF-8): Wtyczka PDF dla przeglądarek zgodnych Mozilla
2e45421f 78Group: X11/Applications
26e61bd9 79Requires: %{base_name} = %{epoch}:%{version}-%{release}
875f730f 80Requires: browser-plugins(%{_target_base_arch})
f994d3ef 81Obsoletes: acroread-plugin
ae0ad7e9 82Obsoletes: mozilla-plugin-acroread
2e45421f 83
f994d3ef 84%description -n browser-plugin-%{name}
62807d83 85A Mozilla plugin for displaying PDF (Portable Document Format) files.
2e45421f 86
e013bd4f
JR
87%description -n browser-plugin-%{name} -l pl.UTF-8
88Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
2e45421f 89
7985bc82 90%prep
14b68627 91%if %{with license_agreement}
17a8eeab 92%setup -q -c
22bd4e96 93cd AdobeReader
ea015334
AM
94tar xf %{tar0}
95tar xf %{tar1}
9aba4922 96%patch0 -p1
14b68627 97%endif
7985bc82 98
99%install
100rm -rf $RPM_BUILD_ROOT
0eb57bee 101%if %{without license_agreement}
14b68627 102install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
103
e4f54b4c
ER
104sed -e '
105 s/@BASE_NAME@/%{base_name}/g
106 s/@TARGET_CPU@/%{_target_cpu}/g
107 s-@VERSION@-%{version}-g
108 s-@RELEASE@-%{release}-g
109 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
110 s,@DATADIR@,%{_datadir}/%{base_name},g
111 s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
112' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
14b68627 113
114install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
115install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
116install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 117
118%else
ae0ad7e9 119install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_plugindir}} \
a7dabf0b 120 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
7985bc82 121
22bd4e96 122cd AdobeReader
14b68627 123cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
124awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
14f626f0
TP
125 '/^install_dir=/ {print "install_dir="INSTDIR; next} \
126 {print}' \
22bd4e96 127 bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
ae0ad7e9 128install Browser/%{platform}/* $RPM_BUILD_ROOT%{_plugindir}
a7dabf0b 129install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
8a44dca4 130install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
22bd4e96 131
3f07d2af 132rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
133
3ed80526
KK
134ln -sf /usr/lib/liblber-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
135ln -sf /usr/lib/libldap-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
22bd4e96
AM
136ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
137
138chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
14b68627 139%endif
7985bc82 140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
0eb57bee 144%if %{without license_agreement}
5d59434a 145%post
e4f54b4c 146%{_bindir}/%{base_name}.install
ae0ad7e9
JR
147
148%else
149
f994d3ef 150%triggerin -n browser-plugin-%{name} -- mozilla-firefox
ae0ad7e9
JR
151%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nppdf.so
152
f994d3ef 153%triggerun -n browser-plugin-%{name} -- mozilla-firefox
ae0ad7e9
JR
154%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nppdf.so
155
f994d3ef 156%triggerin -n browser-plugin-%{name} -- mozilla
ae0ad7e9 157%nsplugin_install -d %{_libdir}/mozilla/plugins nppdf.so
ae0ad7e9 158
f994d3ef 159%triggerun -n browser-plugin-%{name} -- mozilla
ae0ad7e9 160%nsplugin_uninstall -d %{_libdir}/mozilla/plugins nppdf.so
ae0ad7e9 161
f994d3ef 162%triggerin -n browser-plugin-%{name} -- seamonkey
765b9eea 163%nsplugin_install -d %{_libdir}/seamonkey/plugins nppdf.so
164
f994d3ef 165%triggerun -n browser-plugin-%{name} -- seamonkey
765b9eea 166%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nppdf.so
167
f994d3ef 168# % triggerin -n browser-plugin-%{name} -- konqueror
ae0ad7e9
JR
169# % nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nppdf.so
170
f994d3ef 171# % triggerun -n browser-plugin-%{name} -- konqueror
ae0ad7e9
JR
172# % nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nppdf.so
173
f994d3ef 174# % triggerin -n browser-plugin-%{name} -- opera
ae0ad7e9
JR
175# % nsplugin_install -d %{_libdir}/opera/plugins nppdf.so
176
f994d3ef 177# % triggerun -n browser-plugin-%{name} -- opera
ae0ad7e9
JR
178# % nsplugin_uninstall -d %{_libdir}/opera/plugins nppdf.so
179
180# as rpm removes the old obsoleted package files after the triggers
181# above are ran, add another trigger to make the links there.
4424d826 182%triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-acroread, acroread-plugin
ae0ad7e9
JR
183%nsplugin_install -f -d %{_libdir}/mozilla/plugins nppdf.so
184
14b68627 185%endif
186
7985bc82 187%files
188%defattr(644,root,root,755)
0eb57bee 189%if %{without license_agreement}
14b68627 190%attr(755,root,root) %{_bindir}/%{base_name}.install
191%{_datadir}/%{base_name}
192%else
3f07d2af 193%doc AdobeReader/{LICREAD.TXT,ReadMe.htm}
7985bc82 194%attr(755,root,root) %{_bindir}/*
14b68627 195%dir %{_libdir}/%{base_name}
196%{_libdir}/%{base_name}/Resource
14b68627 197%dir %{_libdir}/%{base_name}/Reader
198%{_libdir}/%{base_name}/Reader/help
14b68627 199%{_libdir}/%{base_name}/Reader/AcroVersion
22bd4e96
AM
200%{_libdir}/%{base_name}/Reader/Cert
201%{_libdir}/%{base_name}/Reader/GlobalPrefs
202%{_libdir}/%{base_name}/Reader/HowTo
203%{_libdir}/%{base_name}/Reader/Legal
204%{_libdir}/%{base_name}/Reader/JavaScripts
205%{_libdir}/%{base_name}/Reader/Messages
206%{_libdir}/%{base_name}/Reader/WebSearch
14b68627 207%dir %{_libdir}/%{base_name}/Reader/%{platform}
714a6915 208%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
43255eee 209%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
714a6915 210%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
14b68627 211%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
212%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
714a6915 213%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
43255eee 214%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
714a6915
KK
215%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
216%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
217%{_libdir}/%{base_name}/Reader/%{platform}/res
a7dabf0b 218%{_desktopdir}/acroread.desktop
8a44dca4 219%{_pixmapsdir}/*
2e45421f 220
f994d3ef 221%files -n browser-plugin-%{name}
2e45421f 222%defattr(644,root,root,755)
ae0ad7e9 223%attr(755,root,root) %{_plugindir}/*
14b68627 224%endif
This page took 0.100867 seconds and 4 git commands to generate.