]> git.pld-linux.org Git - packages/acroread.git/blame - acroread.spec
- use the weakest and the fastest avilable compression. It makes no sense to
[packages/acroread.git] / acroread.spec
CommitLineData
14b68627 1#
2# Conditional build:
3%bcond_with license_agreement # generates package
4#
26e61bd9 5%define base_name acroread
0eb57bee 6Summary: Adobe Acrobat Reader
aadbc0c6
ER
7Summary(pl.UTF-8): Adobe Acrobat Reader - czytnik plików PDF
8Summary(ru.UTF-8): Программа для чтения документов в формате PDF от Adobe
9Summary(uk.UTF-8): Програма для читання документів у форматі PDF від Adobe
14b68627 10%if %{with license_agreement}
11Name: %{base_name}
12%else
13Name: %{base_name}-installer
14%endif
093a5f67 15%define _rel 1
815aeaff 16Version: 9.1.3
5d59434a 17Release: %{_rel}%{?with_license_agreement:wla}
22bd4e96 18Epoch: 1
ef009d9a
JB
19License: distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20# in short:
21# - not distributable on public sites (only linking to adobe.com permitted)
22# - distribution on CD requires signing Distribution Agreement (see URL above)
94abd8dc 23Group: X11/Applications/Graphics
14b68627 24%if %{with license_agreement}
2185f2ce 25Source0: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr%{version}-1_i486linux_enu.tar.bz2
815aeaff 26# NoSource0-md5: fec3eed6dfc921a6dcc4deab400e207e
ecf5969f 27NoSource: 0
e4f54b4c 28%else
1af9d1cc 29Source1: license-installer.sh
14b68627 30%endif
a189ca6f 31# please update @COPYSOURCES@ below if you add more Sources or Patches.
1af9d1cc 32Source2: %{base_name}.desktop
33Source3: %{base_name}.png
14f626f0 34URL: http://www.adobe.com/products/acrobat/
976c259d 35%if %{with license_agreement}
3e94b2a4 36BuildRequires: rpmbuild(macros) >= 1.357
7a2c413b 37Requires: openldap-libs < 2.5
2da3bb9c 38Requires: openldap-libs >= 2.4
26e61bd9 39%else
1d9c4a3e 40Requires: rpm-build-tools >= 0:4.4.35
976c259d 41%endif
14f626f0 42ExclusiveArch: %{ix86}
9947ca59 43ExcludeArch: i386
aed33851 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
7985bc82 45
fcf3bf1c 46%define platform intellinux
22bd4e96 47%define tar0 ILINXR.TAR
fcf3bf1c 48%define tar1 COMMON.TAR
94abd8dc 49
dfbbcb35 50%define _noautostrip .*\.api
2da3bb9c 51%define _noautoprov libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
7a2c413b 52%define _noautoreq %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
f21ac523 53
7985bc82 54%description
26e61bd9
ER
55Adobe(R) Reader(R) is free software that lets you view and print PDF
56files (Portable Document Format) on a variety of hardware and
62807d83 57operating system platforms.
7985bc82 58
e013bd4f
JR
59%description -l pl.UTF-8
60Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
61oglądanie oraz drukowanie plików PDF (Portable Document Format) na
62różnych platformach sprzętowych oraz różnych systemach operacyjnych.
7985bc82 63
e013bd4f
JR
64%description -l ru.UTF-8
65Программа для чтения документов в формате Portable Document Format
66(PDF), сгенерированных Adobe Acrobat'ом.
d44545ff 67
e013bd4f
JR
68%description -l uk.UTF-8
69Програма для читання документів у форматі Portable Document Format
70(PDF), згенерованих Adobe Acrobat'ом.
d44545ff 71
f994d3ef 72%package -n browser-plugin-%{name}
ae0ad7e9 73Summary: PDF plugin for Mozilla compatible browsers
aadbc0c6 74Summary(pl.UTF-8): Wtyczka PDF dla przeglądarek zgodnych Mozilla
2e45421f 75Group: X11/Applications
26e61bd9 76Requires: %{base_name} = %{epoch}:%{version}-%{release}
3e94b2a4 77Requires: browser-plugins >= 2.0
f994d3ef 78Obsoletes: acroread-plugin
ae0ad7e9 79Obsoletes: mozilla-plugin-acroread
2e45421f 80
f994d3ef 81%description -n browser-plugin-%{name}
62807d83 82A Mozilla plugin for displaying PDF (Portable Document Format) files.
2e45421f 83
e013bd4f
JR
84%description -n browser-plugin-%{name} -l pl.UTF-8
85Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
2e45421f 86
7985bc82 87%prep
14b68627 88%if %{with license_agreement}
17a8eeab 89%setup -q -c
22bd4e96 90cd AdobeReader
ea015334
AM
91tar xf %{tar0}
92tar xf %{tar1}
14b68627 93%endif
7985bc82 94
95%install
96rm -rf $RPM_BUILD_ROOT
0eb57bee 97%if %{without license_agreement}
14b68627 98install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
99
e4f54b4c
ER
100sed -e '
101 s/@BASE_NAME@/%{base_name}/g
102 s/@TARGET_CPU@/%{_target_cpu}/g
103 s-@VERSION@-%{version}-g
104 s-@RELEASE@-%{release}-g
105 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
106 s,@DATADIR@,%{_datadir}/%{base_name},g
78a918bf 107 s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
1af9d1cc 108' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
14b68627 109
110install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 111install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
1af9d1cc 112install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 113
114%else
3e94b2a4 115install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_browserpluginsdir}} \
a7dabf0b 116 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
7985bc82 117
c7dc1b0b 118# note: there're also AdobeReader/Adobe/Help{,Viewer}
6dc16e8f 119cd AdobeReader/Adobe/Reader9
14b68627 120cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
121awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
14f626f0
TP
122 '/^install_dir=/ {print "install_dir="INSTDIR; next} \
123 {print}' \
22bd4e96 124 bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
3e94b2a4 125install Browser/%{platform}/* $RPM_BUILD_ROOT%{_browserpluginsdir}
1af9d1cc 126install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
127install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
22bd4e96 128
6dc16e8f 129cp -a Browser/HowTo $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/
130
3f07d2af 131rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
132
7a2c413b
JB
133ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
134ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
22bd4e96
AM
135ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
136
137chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
14b68627 138%endif
7985bc82 139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
0eb57bee 143%if %{without license_agreement}
5d59434a 144%post
e4f54b4c 145%{_bindir}/%{base_name}.install
3e94b2a4 146%endif
ae0ad7e9 147
3e94b2a4 148%if %{with license_agreement}
149%post -n browser-plugin-%{name}
150%update_browser_plugins
ae0ad7e9 151
3e94b2a4 152%postun -n browser-plugin-%{name}
153if [ "$1" = 0 ]; then
154 %update_browser_plugins
155fi
14b68627 156%endif
157
7985bc82 158%files
159%defattr(644,root,root,755)
0eb57bee 160%if %{without license_agreement}
14b68627 161%attr(755,root,root) %{_bindir}/%{base_name}.install
162%{_datadir}/%{base_name}
163%else
78a918bf 164%doc AdobeReader/ReadMe.htm
7985bc82 165%attr(755,root,root) %{_bindir}/*
14b68627 166%dir %{_libdir}/%{base_name}
167%{_libdir}/%{base_name}/Resource
14b68627 168%dir %{_libdir}/%{base_name}/Reader
169%{_libdir}/%{base_name}/Reader/help
14b68627 170%{_libdir}/%{base_name}/Reader/AcroVersion
22bd4e96
AM
171%{_libdir}/%{base_name}/Reader/Cert
172%{_libdir}/%{base_name}/Reader/GlobalPrefs
173%{_libdir}/%{base_name}/Reader/HowTo
c7dc1b0b 174%{_libdir}/%{base_name}/Reader/IDTemplates
22bd4e96 175%{_libdir}/%{base_name}/Reader/JavaScripts
c7dc1b0b
TP
176%{_libdir}/%{base_name}/Reader/Legal
177%{_libdir}/%{base_name}/Reader/Tracker
178%{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
179%{_libdir}/%{base_name}/Reader/pmd.cer
78a918bf 180%{_libdir}/%{base_name}/Reader/%{platform}/mozilla
14b68627 181%dir %{_libdir}/%{base_name}/Reader/%{platform}
714a6915 182%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
c7dc1b0b 183%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
43255eee 184%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
714a6915 185%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
14b68627 186%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
187%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
714a6915 188%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
43255eee 189%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
78a918bf 190%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
714a6915
KK
191%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
192%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
c7dc1b0b 193%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
a7dabf0b 194%{_desktopdir}/acroread.desktop
8a44dca4 195%{_pixmapsdir}/*
2e45421f 196
f994d3ef 197%files -n browser-plugin-%{name}
2e45421f 198%defattr(644,root,root,755)
3e94b2a4 199%attr(755,root,root) %{_browserpluginsdir}/*
14b68627 200%endif
This page took 0.072637 seconds and 4 git commands to generate.