]> git.pld-linux.org Git - packages/acl.git/blobdiff - acl.spec
- obsolete (merged)
[packages/acl.git] / acl.spec
index c8537e77f6da105257f4bb537f7e3c56b0e8446d..e205e5546cdf5067a432ee96685e396ed87f4704 100644 (file)
--- a/acl.spec
+++ b/acl.spec
@@ -1,35 +1,40 @@
-Summary:       Command for manipulating access control lists
-Summary(pl):   Komenda do manipulacji listami kontroli dostêpu (ACL)
+Summary:       Command and library for manipulating access control lists
+Summary(pl):   Polecenie i biblioteka do manipulacji listami kontroli dostêpu (ACL)
 Name:          acl
-Version:       2.0.15
+Version:       2.2.23
 Release:       1
-License:       GPL
+License:       GPL v2 (chacl utility), LGPL v2+ (library and the rest)
 Group:         Applications/System
 Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
+# Source0-md5: 7e13778c38addfcdabf2cef291b78bcc
+Source1:       %{name}-pl.po
 Patch0:                %{name}-miscfix.patch
 URL:           http://oss.sgi.com/projects/xfs/
+BuildRequires: attr-devel >= 2.4.15
 BuildRequires: autoconf
-BuildRequires: attr-devel >= 2.0.0
-Requires:      attr
+BuildRequires: automake
+BuildRequires: gettext-devel
+Requires:      attr >= 2.4.15
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
-%define                _libdir         /lib
-%define                _libexecdir     /usr/lib
+%define                _libdir         /%{_lib}
+%define                _libexecdir     /usr/%{_lib}
 
 %description
-A command (chacl) to manipulate POSIX access control lists under
-Linux.
+A command (chacl) and a library (libacl) to manipulate POSIX access
+control lists under Linux.
 
 %description -l pl
-Komenda (chacl) do manipulowania zgodnymi z POSIX listami kontroli
-dostêpu (ACL) pod Linuksem.
+Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
+POSIX listami kontroli dostêpu (ACL) pod Linuksem.
 
 %package devel
 Summary:       Header files for acl library
 Summary(pl):   Pliki nag³ówkowe biblioteki acl
 Group:         Development/Libraries
 Requires:      %{name} = %{version}
+Requires:      attr-devel
 
 %description devel
 Header files to develop software which manipulate access control
@@ -52,30 +57,40 @@ Static acl library.
 Statyczna biblioteka acl.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
+chmod -Rf u+w .
+
+cp %{SOURCE1} po/pl.po
+%{__perl} -pi -e 's/^(LINGUAS.*)/$1 pl/' po/Makefile
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
+rm -f aclocal.m4
+%{__aclocal} -I m4
 %{__autoconf}
-%configure
+%configure \
+       DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
+       OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_includedir}/acl
+install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
 
-DIST_ROOT="$RPM_BUILD_ROOT"
+DIST_ROOT=$RPM_BUILD_ROOT
 DIST_INSTALL=`pwd`/install.manifest
 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
-%{__make} install DIST_MANIFEST="$DIST_INSTALL"
-%{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
-%{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
 
-mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
+%{__make} install \
+       DIST_MANIFEST=$DIST_INSTALL
+%{__make} install-dev \
+       DIST_MANIFEST=$DIST_INSTALL_DEV
+%{__make} install-lib \
+       DIST_MANIFEST=$DIST_INSTALL_LIB
+
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
 echo ".so acl_copy_ext.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
@@ -85,7 +100,10 @@ echo ".so acl_from_text.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
 echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
 
 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
-ln -sf %{_libdir}/libacl.so.1.0.2 $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
+
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -93,20 +111,21 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc doc/CHANGES
+%doc README doc/{CHANGES,TODO}
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
-%{_mandir}/man1/*
+%{_mandir}/man[15]/*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libexecdir}/lib*.la
+%doc doc/{extensions.txt,libacl.txt}
 %attr(755,root,root) %{_libexecdir}/lib*.so
+%{_libexecdir}/lib*.la
 %{_includedir}/acl
 %{_includedir}/sys/*
-%{_mandir}/man[235]/*
+%{_mandir}/man[23]/*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.100912 seconds and 4 git commands to generate.