]> git.pld-linux.org Git - packages/acl.git/blobdiff - acl.spec
- pass rpmldflags
[packages/acl.git] / acl.spec
index 02355af88f15e954542b3c4e8e87d1873d559bb6..920d88cdc75cdec0fd26d49cfa257615698f9eb7 100644 (file)
--- a/acl.spec
+++ b/acl.spec
@@ -1,35 +1,43 @@
-Summary:       Command for manipulating access control lists
-Summary(pl):   Komenda do manipulacji listami kontroli dostêpu (ACL)
+Summary:       Command and library for manipulating access control lists
+Summary(pl):   Polecenie i biblioteka do manipulacji listami kontroli dostêpu (ACL)
 Name:          acl
-Version:       2.2.7
+Version:       2.2.39
 Release:       1
-License:       GPL v2 (chacl utility), LGPL v2+ (library and the rest)
+License:       LGPL v2+ (library), GPL v2 (utilities)
 Group:         Applications/System
-Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
+Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
+# Source0-md5: 4edd450bbee60d6c4b3c51ae80499b00
 Patch0:                %{name}-miscfix.patch
+Patch1:                %{name}-lt.patch
 URL:           http://oss.sgi.com/projects/xfs/
+BuildRequires: attr-devel >= 2.4.16-3
 BuildRequires: autoconf
-BuildRequires: attr-devel >= 2.4.1
-Requires:      attr
+BuildRequires: automake
+BuildRequires: gettext-devel
+BuildRequires: libtool
+BuildRequires: sed >= 4.0
+Requires:      attr >= 2.4.15
+Obsoletes:     libacl
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
-%define                _libdir         /lib
-%define                _libexecdir     /usr/lib
+%define                _libdir         /%{_lib}
+%define                _libexecdir     /usr/%{_lib}
 
 %description
-A command (chacl) to manipulate POSIX access control lists under
-Linux.
+A command (chacl) and a library (libacl) to manipulate POSIX access
+control lists under Linux.
 
 %description -l pl
-Komenda (chacl) do manipulowania zgodnymi z POSIX listami kontroli
-dostêpu (ACL) pod Linuksem.
+Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
+POSIX listami kontroli dostêpu (ACL) pod Linuksem.
 
 %package devel
 Summary:       Header files for acl library
 Summary(pl):   Pliki nag³ówkowe biblioteki acl
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      attr-devel >= 2.4.16-3
 
 %description devel
 Header files to develop software which manipulate access control
@@ -43,7 +51,7 @@ listami kontroli dost
 Summary:       Static acl library
 Summary(pl):   Statyczna biblioteka acl
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static acl library.
@@ -52,41 +60,52 @@ Static acl library.
 Statyczna biblioteka acl.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
+%patch1 -p1
+sed -e '/LTLDFLAGS/s/$/ $(LLDFLAGS)/' -i libacl/Makefile
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
+rm -f aclocal.m4
+%{__aclocal} -I m4
 %{__autoconf}
-%configure
+%configure \
+       DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
+       OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
 
-%{__make}
+%{__make} \
+       LLDFLAGS="%{rpmldflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_includedir}/acl
+install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
 
-DIST_ROOT="$RPM_BUILD_ROOT"
+DIST_ROOT=$RPM_BUILD_ROOT
 DIST_INSTALL=`pwd`/install.manifest
 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
-%{__make} install DIST_MANIFEST="$DIST_INSTALL"
-%{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
-%{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
 
-mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
+%{__make} install \
+       DIST_MANIFEST=$DIST_INSTALL
+%{__make} install-dev \
+       DIST_MANIFEST=$DIST_INSTALL_DEV
+%{__make} install-lib \
+       DIST_MANIFEST=$DIST_INSTALL_LIB
+
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
 echo ".so acl_copy_ext.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
-echo ".so acl_get_fd.3"        > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
+echo ".so acl_get_fd.3"                > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
 echo ".so acl_get_file.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
 echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
 echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
 
 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
-ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT/lib ; echo libacl.so.*.*.*) \
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
        $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
+%{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
+       $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
 
 %find_lang %{name}
 
@@ -101,7 +120,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc README doc/{CHANGES,TODO}
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
-%{_mandir}/man1/*
+%{_mandir}/man[15]/*
 
 %files devel
 %defattr(644,root,root,755)
@@ -110,7 +129,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libexecdir}/lib*.la
 %{_includedir}/acl
 %{_includedir}/sys/*
-%{_mandir}/man[235]/*
+%{_mandir}/man[23]/*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.069922 seconds and 4 git commands to generate.