]> git.pld-linux.org Git - packages/acl.git/blobdiff - acl.spec
- need export on DIST_ROOT
[packages/acl.git] / acl.spec
index 8e03c28b2a161329b16ce9e81a7c427a93a49af7..3b9a3992816bec6d10f06a840da97c7d729fe0e5 100644 (file)
--- a/acl.spec
+++ b/acl.spec
-Summary:       Command for manipulating access control lists
-Summary(pl):   Komenda do manipulacji listami kontroli dostêpu (ACL)
+Summary:       Command and library for manipulating access control lists
+Summary(pl.UTF-8):     Polecenie i biblioteka do manipulacji listami kontroli dostępu (ACL)
 Name:          acl
-Version:       2.0.18
+Version:       2.2.44
 Release:       1
-License:       GPL
+License:       LGPL v2+ (library), GPL v2 (utilities)
 Group:         Applications/System
-Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
+Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
+# Source0-md5: f92f56998a94735419ec932fb9d0118d
 Patch0:                %{name}-miscfix.patch
+Patch1:                %{name}-lt.patch
+Patch2:                %{name}-LDFLAGS.patch
 URL:           http://oss.sgi.com/projects/xfs/
+BuildRequires: attr-devel >= 2.4.16-3
 BuildRequires: autoconf
-BuildRequires: attr-devel >= 2.0.0
-Requires:      attr
+BuildRequires: automake
+BuildRequires: gettext-devel
+BuildRequires: libtool
+Requires:      attr >= 2.4.15
+Obsoletes:     libacl
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
-%define                _libdir         /lib
-%define                _libexecdir     /usr/lib
+%define                _libdir         /%{_lib}
+%define                _libexecdir     /usr/%{_lib}
 
 %description
-A command (chacl) to manipulate POSIX access control lists under
-Linux.
+A command (chacl) and a library (libacl) to manipulate POSIX access
+control lists under Linux.
 
-%description -l pl
-Komenda (chacl) do manipulowania zgodnymi z POSIX listami kontroli
-dostêpu (ACL) pod Linuksem.
+%description -l pl.UTF-8
+Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
+POSIX listami kontroli dostępu (ACL) pod Linuksem.
 
 %package devel
 Summary:       Header files for acl library
-Summary(pl):   Pliki nag³ówkowe biblioteki acl
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki acl
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      attr-devel >= 2.4.16-3
 
 %description devel
 Header files to develop software which manipulate access control
 lists.
 
-%description devel -l pl
-Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
-listami kontroli dostêpu (ACL).
+%description devel -l pl.UTF-8
+Pliki nagłówkowe potrzebne do rozwoju oprogramowania manipulującego
+listami kontroli dostępu (ACL).
 
 %package static
 Summary:       Static acl library
-Summary(pl):   Statyczna biblioteka acl
+Summary(pl.UTF-8):     Statyczna biblioteka acl
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static acl library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna biblioteka acl.
 
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
+rm -f aclocal.m4
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
+%{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
-%configure
+%configure \
+       DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
+       OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
 
-%{__make}
+%{__make} \
+       LLDFLAGS="%{rpmldflags}" \
+       top_builddir="../"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_includedir}/acl
-
-DIST_ROOT="$RPM_BUILD_ROOT"
-DIST_INSTALL=`pwd`/install.manifest
-DIST_INSTALL_DEV=`pwd`/install-dev.manifest
-DIST_INSTALL_LIB=`pwd`/install-lib.manifest
-export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
-%{__make} install DIST_MANIFEST="$DIST_INSTALL"
-%{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
-%{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
-
-mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
+install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
+
+export DIST_ROOT=$RPM_BUILD_ROOT
+P=$(pwd)
+DIST_INSTALL=$P/install.manifest
+DIST_INSTALL_DEV=$P/install-dev.manifest
+DIST_INSTALL_LIB=$P/install-lib.manifest
+
+%{__make} install \
+       DIST_MANIFEST=$DIST_INSTALL \
+       top_builddir="../"
+%{__make} install-dev \
+       DIST_MANIFEST=$DIST_INSTALL_DEV \
+       top_builddir="../"
+%{__make} install-lib \
+       DIST_MANIFEST=$DIST_INSTALL_LIB \
+       top_builddir="../"
+
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
 echo ".so acl_copy_ext.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
-echo ".so acl_get_fd.3"        > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
+echo ".so acl_get_fd.3"                > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
 echo ".so acl_get_file.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
 echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
 echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
 
 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
-ln -sf %{_libdir}/libacl.so.1.0.2 $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libacl.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
+%{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
+       $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
+
+rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
+
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -93,21 +123,22 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc doc/CHANGES
+%doc README doc/{CHANGES,TODO}
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
-%{_mandir}/man1/*
+%attr(755,root,root) %{_libdir}/libacl.so.*.*
+%{_mandir}/man[15]/*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libexecdir}/lib*.la
-%attr(755,root,root) %{_libexecdir}/lib*.so
+%doc doc/{extensions.txt,libacl.txt}
+%attr(755,root,root) %{_libexecdir}/libacl.so
+%{_libexecdir}/libacl.la
 %{_includedir}/acl
 %{_includedir}/sys/*
-%{_mandir}/man[235]/*
+%{_mandir}/man[23]/*
 
 %files static
 %defattr(644,root,root,755)
-%{_libexecdir}/lib*.a
+%{_libexecdir}/libacl.a
This page took 0.056067 seconds and 4 git commands to generate.