]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
338d0ecfa1bd440d05f81f41cbb7cd6edc01166d
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl.UTF-8):      Polecenie i biblioteka do manipulacji listami kontroli dostępu (ACL)
3 Name:           acl
4 Version:        2.2.52
5 Release:        2
6 License:        LGPL v2+ (library), GPL v2 (utilities)
7 Group:          Applications/System
8 Source0:        http://git.savannah.gnu.org/cgit/acl.git/snapshot/%{name}-%{version}.tar.gz
9 # Source0-md5:  8d720d6bf9ef41d8995f145637f48d57
10 Patch0:         %{name}-miscfix.patch
11 Patch1:         %{name}-lt.patch
12 Patch2:         %{name}-LDFLAGS.patch
13 Patch3:         %{name}-pl.po-update.patch
14 URL:            http://savannah.nongnu.org/projects/acl/
15 BuildRequires:  attr-devel >= 2.4.16-3
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gettext-tools
19 BuildRequires:  libtool
20 BuildRequires:  rpmbuild(macros) >= 1.402
21 Requires:       attr >= 2.4.15
22 Obsoletes:      libacl
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _bindir         /bin
26 %define         _libdir         /%{_lib}
27 %define         _libexecdir     /usr/%{_lib}
28
29 %description
30 A command (chacl) and a library (libacl) to manipulate POSIX access
31 control lists under Linux.
32
33 %description -l pl.UTF-8
34 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
35 POSIX listami kontroli dostępu (ACL) pod Linuksem.
36
37 %package devel
38 Summary:        Header files for acl library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki acl
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       attr-devel >= 2.4.16-3
43
44 %description devel
45 Header files to develop software which manipulate access control
46 lists.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe potrzebne do rozwoju oprogramowania manipulującego
50 listami kontroli dostępu (ACL).
51
52 %package static
53 Summary:        Static acl library
54 Summary(pl.UTF-8):      Statyczna biblioteka acl
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static acl library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka acl.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69 %patch3 -p1
70
71 %{__rm} -f aclocal.m4
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 cp -f /usr/share/automake/config.sub .
78 install include/install-sh .
79
80 %configure \
81         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
82         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
83
84 %{__make} \
85         LLDFLAGS="%{rpmldflags}" \
86         top_builddir="../"
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
91
92 export DIST_ROOT=$RPM_BUILD_ROOT
93 P=$(pwd)
94 DIST_INSTALL=$P/install.manifest
95 DIST_INSTALL_DEV=$P/install-dev.manifest
96 DIST_INSTALL_LIB=$P/install-lib.manifest
97
98 %{__make} install \
99         DIST_MANIFEST=$DIST_INSTALL \
100         top_builddir="../"
101 %{__make} install-dev \
102         DIST_MANIFEST=$DIST_INSTALL_DEV \
103         top_builddir="../"
104 %{__make} install-lib \
105         DIST_MANIFEST=$DIST_INSTALL_LIB \
106         top_builddir="../"
107
108 ln -snf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libacl.so.*.*.*) \
109         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
110 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
111         $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
112
113 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
114
115 # already in /usr
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libacl.{so,la,a}
117
118 # fix perms (needed for debuginfo and autorequires/provides)
119 chmod a+x $RPM_BUILD_ROOT%{_libdir}/libacl.so.*.*.*
120
121 %find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc README doc/{CHANGES,TODO}
132 %attr(755,root,root) %{_bindir}/chacl
133 %attr(755,root,root) %{_bindir}/getfacl
134 %attr(755,root,root) %{_bindir}/setfacl
135 %attr(755,root,root) %{_libdir}/libacl.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libacl.so.1
137 %{_mandir}/man1/chacl.1*
138 %{_mandir}/man1/getfacl.1*
139 %{_mandir}/man1/setfacl.1*
140 %{_mandir}/man5/acl.5*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc doc/{extensions.txt,libacl.txt}
145 %attr(755,root,root) %{_libexecdir}/libacl.so
146 %{_libexecdir}/libacl.la
147 %{_includedir}/acl
148 %{_includedir}/sys/acl.h
149 %{_mandir}/man3/acl_*.3*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libexecdir}/libacl.a
This page took 0.039734 seconds and 2 git commands to generate.