]> git.pld-linux.org Git - packages/ack.git/blob - ack.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/ack.git] / ack.spec
1 # TODO:
2 # - split /usr/share/perl* part into perl-ack subpackage
3 #
4 # Conditional build:
5 %bcond_without  tests           # do not perform "make test"
6 %bcond_with     pty_tests       # do not perform tests requiring a pty
7 #
8 %include        /usr/lib/rpm/macros.perl
9 %define pdir    ack
10 Summary:        grep-like text finder
11 Summary(pl.UTF-8):      produkt grepopodobny
12 Name:           ack
13 Version:        2.14
14 Release:        1
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-authors/id/P/PE/PETDANCE/%{name}-%{version}.tar.gz
18 # Source0-md5:  43cfa05123ba0440fa3958690ee03bac
19 Patch0:         %{name}-deps.patch
20 Patch1:         %{name}-interactive-tests.patch
21 URL:            http://betterthangrep.com/
22 Requires:       perl-ack = %{version}
23 %if %{with tests}
24 BuildRequires:  perl-File-Next >= 1.10
25 %{?with_pty_tests:BuildRequires:        perl-IO-Tty}
26 BuildRequires:  perl-Test-Simple >= 0.98
27 %endif
28 BuildRequires:  perl-devel >= 1:5.8.0
29 BuildRequires:  perl-perldoc
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Ack is designed as a replacement for 99% of the uses of grep.
36
37 Ack searches the named input FILEs (or standard input if no files are
38 named, or the file name - is given) for lines containing a match to
39 the given PATTERN. By default, ack prints the matching lines.
40
41 Ack can also list files that would be searched, without actually
42 searching them, to let you take advantage of ack's file-type filtering
43 capabilities.
44
45 %description -l pl.UTF-8
46 ack jest narzędziem podobnym do grepa, zaprojektowanym dla
47 programistów pracujących z dużymi drzewami różnorodnych plików.
48
49 ack jest napisany w czystym perlu i korzysta z potęgi wyrażeń
50 regularnych tego języka.
51
52 %package -n perl-ack
53 Summary:        ack perl library
54 Summary(pl.UTF-8):      biblioteka ack dla języka perl
55 Group:          Development/Languages/Perl
56
57 %description -n perl-ack
58 ack perl library.
59
60 %description -n perl-ack -l pl.UTF-8
61 ack perl library.
62
63 %prep
64 %setup -q -n %{pdir}-%{version}
65 %patch0 -p0
66 %patch1 -p0
67
68 %build
69 %{__perl} Makefile.PL \
70         INSTALLDIRS=vendor
71 %{__make} \
72         CC="%{__cc}" \
73         OPTIMIZE="%{rpmcflags}"
74
75 %{?with_tests:%{!?with_pty_tests: RUN_INTERACTIVE=0} %{__make} -j1 test}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} pure_install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes README.md
89 %attr(755,root,root) %{_bindir}/ack
90 %{_mandir}/man1/ack.1p*
91
92 %files -n perl-ack
93 %defattr(644,root,root,755)
94 %{perl_vendorlib}/App/Ack.pm
95 %{perl_vendorlib}/App/Ack
This page took 0.095234 seconds and 3 git commands to generate.