]> git.pld-linux.org Git - packages/acerhk.git/commitdiff
- added patches against newer kernels, rel. 50 master
authorTomasz Pala <gotar@pld-linux.org>
Sat, 11 Jun 2011 19:09:22 +0000 (19:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    acerhk-source_lp_bug555828-2.6.37.patch -> 1.1
    acerhk-source_lp_bug555828-2.6.38.patch -> 1.1
    acerhk.spec -> 1.67

acerhk-source_lp_bug555828-2.6.37.patch [new file with mode: 0644]
acerhk-source_lp_bug555828-2.6.38.patch [new file with mode: 0644]
acerhk.spec

diff --git a/acerhk-source_lp_bug555828-2.6.37.patch b/acerhk-source_lp_bug555828-2.6.37.patch
new file mode 100644 (file)
index 0000000..db09c26
--- /dev/null
@@ -0,0 +1,28 @@
+diff -upN acerhk.old//acerhk.c acerhk//acerhk.c
+--- acerhk.old//acerhk.c       2011-01-30 01:08:21.276542993 +0200
++++ acerhk//acerhk.c   2011-01-30 01:11:57.692542994 +0200
+@@ -2827,10 +2827,10 @@ static void acerhk_proc_cleanup(void)
+ /* {{{ file operations */
+-static int acerhk_ioctl( struct inode *inode, struct file *file,
++static long acerhk_ioctl( struct file *file,
+                          unsigned int cmd, unsigned long arg )
+ {
+-  int retval;
++  long retval;
+   switch( cmd ) {
+   case ACERHK_GET_KEYCOUNT:
+     {
+@@ -2938,7 +2938,7 @@ static int acerhk_resume(struct platform
+ static struct file_operations acerhk_fops = {
+   owner:        THIS_MODULE,
+-  ioctl:        acerhk_ioctl,
++  unlocked_ioctl:        acerhk_ioctl,
+   open:         acerhk_open,
+ #ifdef ACERDEBUG
+   write:        acerhk_write,
+Common subdirectories: acerhk.old//debian and acerhk//debian
+Common subdirectories: acerhk.old//doc and acerhk//doc
+Common subdirectories: acerhk.old//.tmp_versions and acerhk//.tmp_versions
diff --git a/acerhk-source_lp_bug555828-2.6.38.patch b/acerhk-source_lp_bug555828-2.6.38.patch
new file mode 100644 (file)
index 0000000..07fdbf9
--- /dev/null
@@ -0,0 +1,16 @@
+## Description: add some description
+## Origin/Author: add some origin or author
+## Bug: bug URL
+Index: acerhk-0.5.35/acerhk.c
+===================================================================
+--- acerhk-0.5.35.orig/acerhk.c        2011-05-16 23:39:15.000000000 +0200
++++ acerhk-0.5.35/acerhk.c     2011-05-16 23:39:10.000000000 +0200
+@@ -36,7 +36,7 @@
+  */
+ #ifndef AUTOCONF_INCLUDED
+-#include <linux/config.h>
++#include <generated/autoconf.h>
+ #endif
+ /* This driver is heavily dependent on the architecture, don't let
index f146988b11a5bdfbd216091446f6aa7204fc08cd..2633bbee68bcba20f58fe8c4e172a59353fa305a 100644 (file)
@@ -2,7 +2,7 @@
 # Conditional build:
 %bcond_without dist_kernel     # without distribution kernel
 #
-%define                rel     49
+%define                rel     50
 Summary:       Linux driver for Acer notebook special Hot Keys
 Summary(pl.UTF-8):     Sterownik dla Linuksa obsługujący specjalne klawisze w notebookach Acer
 Name:          acerhk
@@ -14,6 +14,8 @@ Source0:      http://www.cakey.de/acerhk/archives/%{name}-%{version}.tar.bz2
 # Source0-md5: 551285657c8ba338f23595af257d21df
 Patch0:                %{name}-2.6.24.patch
 Patch1:                %{name}-2.6.30.patch
+Patch2:                https://launchpadlibrarian.net/63115172/acerhk-source_lp_bug555828-2.6.37.patch
+Patch3:                https://launchpadlibrarian.net/71840570/acerhk-source_lp_bug555828-2.6.38.patch
 URL:           http://www.cakey.de/acerhk/
 BuildRequires: %{kgcc_package}
 %{?with_dist_kernel:BuildRequires:     kernel-module-build >= 3:2.6.20.2}
@@ -50,6 +52,8 @@ notebookach Acer.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 cat > Makefile << EOF
 obj-m += acerhk.o
This page took 0.086416 seconds and 4 git commands to generate.