]> git.pld-linux.org Git - packages/accelio.git/commitdiff
- adjusted fio patch for fio 2.19; release 2 auto/th/accelio-1.7-2
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 15 Apr 2017 20:15:33 +0000 (22:15 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 15 Apr 2017 20:15:33 +0000 (22:15 +0200)
accelio-fio.patch
accelio.spec

index f56f650c10153e0030afc1d676e698da35679e66..1cae6f971005a170272f612137bdb75766273329 100644 (file)
@@ -1,24 +1,3 @@
---- accelio-1.6/examples/raio/usr/fio/libraio.c.orig   2016-03-28 14:58:45.000000000 +0200
-+++ accelio-1.6/examples/raio/usr/fio/libraio.c        2016-04-10 19:16:54.244086124 +0200
-@@ -130,7 +130,7 @@
-                                unsigned int max, const struct timespec *t)
- {
-       struct libraio_data *ld = td->io_ops->data;
--      unsigned actual_min = td->o.iodepth_batch_complete == 0 ? 0 : min;
-+      unsigned actual_min = td->o.iodepth_batch_complete_min == 0 ? 0 : min;
-       int r, events = 0;
-       do {
---- accelio-1.6/examples/raio/usr/fio/Makefile.am.orig 2016-03-28 14:58:45.000000000 +0200
-+++ accelio-1.6/examples/raio/usr/fio/Makefile.am      2016-04-10 21:54:08.050356893 +0200
-@@ -30,6 +30,7 @@
- # list of sources for the 'libraio_fio' shared library\r
- libraio_fio_la_SOURCES = libraio.c\r
\r
-+libraio_fio_la_LDFLAGS = -module -avoid-version
- libraio_fio_la_LIBADD = -lraio -lxio $(libxio_rdma_ldflags) -lrt -ldl -lpthread  \\r
-                       -L$(top_builddir)/src/usr/ -L$(top_builddir)/examples/raio/\r
\r
 --- accelio-1.7/examples/raio/usr/fio/libraio.c.orig   2016-12-24 13:09:13.375548622 +0100
 +++ accelio-1.7/examples/raio/usr/fio/libraio.c        2016-12-25 00:04:40.251766246 +0100
 @@ -107,7 +107,7 @@
        struct raio_event *ev;
        struct io_u *io_u;
  
-@@ -129,7 +129,7 @@
+@@ -129,8 +129,8 @@
  static int fio_libraio_getevents(struct thread_data *td, unsigned int min,
                                 unsigned int max, const struct timespec *t)
  {
 -      struct libraio_data *ld = td->io_ops->data;
+-      unsigned actual_min = td->o.iodepth_batch_complete == 0 ? 0 : min;
 +      struct libraio_data *ld = td->io_ops_data;
-       unsigned actual_min = td->o.iodepth_batch_complete_min == 0 ? 0 : min;
++      unsigned actual_min = td->o.iodepth_batch_complete_min == 0 ? 0 : min;
        int r, events = 0;
  
+       do {
 @@ -152,7 +152,7 @@
  
  static int fio_libraio_queue(struct thread_data *td, struct io_u *io_u)
        struct libraio_engine_data *engine_data = io_u->engine_data;
  
        return raio_cancel(ld->raio_ctx, &engine_data->iocb, ld->raio_events);
+@@ -290,7 +290,7 @@
+       *_flags = -1;
+-      if (td_trim(td) && f->filetype != FIO_TYPE_BD) {
++      if (td_trim(td) && f->filetype != FIO_TYPE_BLOCK) {
+               log_err("libraio: trim only applies to block device\n");
+               return 1;
+       }
 @@ -357,7 +357,7 @@
        char                    path[256];
        char                    host[256];
        }
  }
  
+--- accelio-1.6/examples/raio/usr/fio/Makefile.am.orig 2016-03-28 14:58:45.000000000 +0200
++++ accelio-1.6/examples/raio/usr/fio/Makefile.am      2016-04-10 21:54:08.050356893 +0200
+@@ -30,6 +30,7 @@
+ # list of sources for the 'libraio_fio' shared library\r
+ libraio_fio_la_SOURCES = libraio.c\r
\r
++libraio_fio_la_LDFLAGS = -module -avoid-version
+ libraio_fio_la_LIBADD = -lraio -lxio $(libxio_rdma_ldflags) -lrt -ldl -lpthread  \\r
+                       -L$(top_builddir)/src/usr/ -L$(top_builddir)/examples/raio/\r
\r
index b93043d7e67ddccb369cbd96faa2713c430d0487..c23ae275b2c0defebbdb95e6f339d37257a236da 100644 (file)
@@ -10,7 +10,7 @@ Summary:      Open Source I/O, Message and RPC Acceleration library
 Summary(pl.UTF-8):     Mająca otwarte źródła biblioteka przyspieszająca we/wy, komunikaty i RPC
 Name:          accelio
 Version:       1.7
-Release:       1
+Release:       2
 License:       BSD
 Group:         Libraries
 #Source0Download: https://github.com/accelio/accelio/releases
@@ -21,7 +21,7 @@ Patch1:               %{name}-sse.patch
 URL:           http://www.accelio.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.11
-%{?with_fio:BuildRequires:     fio-devel >= 2.14}
+%{?with_fio:BuildRequires:     fio-devel >= 2.19}
 BuildRequires: libaio-devel
 BuildRequires: libevent-devel >= 2
 BuildRequires: libibverbs-devel
This page took 0.063893 seconds and 4 git commands to generate.