]> git.pld-linux.org Git - packages/ac3dec.git/commitdiff
92b8d3af8d0d06318bb2bb04b8093eef ac3dec-0.6.1.tar.gz - use new ac3dec from other...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 14 Mar 2001 14:27:40 +0000 (14:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ac3dec-make.patch -> 1.2

ac3dec-make.patch

index 760e5d941736490d044d9bfdf8a61bdce2e5885b..5322df0ac28017e1f2001087b9b5b23cc1383449 100644 (file)
@@ -1,64 +1,81 @@
-diff -urN ac3dec.org/Makefile.am ac3dec/Makefile.am
---- ac3dec.org/Makefile.am     Fri Feb 16 22:58:34 2001
-+++ ac3dec/Makefile.am Fri Feb 16 23:10:51 2001
-@@ -1,7 +1,7 @@
+diff -urN ac3dec-0.6.1.org/Makefile.am ac3dec-0.6.1/Makefile.am
+--- ac3dec-0.6.1.org/Makefile.am       Wed Mar 14 14:54:26 2001
++++ ac3dec-0.6.1/Makefile.am   Wed Mar 14 15:11:12 2001
+@@ -1,15 +1,15 @@
  # # Process this file with automake to produce Makefile.in.
  AUTOMAKE_OPTIONS = 1.3 foreign
  
--CFLAGS = -Wall -Werror -O3 -g -Ilibac3 -Ilibao
-+CFLAGS = -Wall -Werror -g -Ilibac3 -Ilibao
+-CFLAGS = -Wall -Werror -O3 -g
++CFLAGS = @CFLAGS@ -Wall -Werror
  
  bin_PROGRAMS = ac3dec 
  
-@@ -14,5 +14,5 @@
- EXTRA_DIST = README Changelog TODO plot_spectrum.m autogen.sh
-        
--SUBDIRS = libao libac3 tools test .
-+SUBDIRS = libao libac3 tools .
-diff -urN ac3dec.org/configure.in ac3dec/configure.in
---- ac3dec.org/configure.in    Fri Feb 16 22:58:34 2001
-+++ ac3dec/configure.in        Fri Feb 16 22:58:43 2001
-@@ -27,4 +27,4 @@
- builtin(include, libao/configure.incl)
- builtin(include, libac3/configure.incl)
--AC_OUTPUT(libao/Makefile libac3/Makefile tools/Makefile test/Makefile Makefile ) 
-+AC_OUTPUT(libao/Makefile libac3/Makefile tools/Makefile Makefile ) 
-diff -urN ac3dec.org/libac3/Makefile.am ac3dec/libac3/Makefile.am
---- ac3dec.org/libac3/Makefile.am      Fri Feb 16 22:58:34 2001
-+++ ac3dec/libac3/Makefile.am  Fri Feb 16 23:01:22 2001
-@@ -4,7 +4,7 @@
- EXTRA_DIST = configure.incl
--INCLUDES += -I$(top_srcdir)/include
-+INCLUDES += -I$(top_srcdir)/include -I$(top_srcdir)/libao
- libdir = $(PLUGIN_DIR)
- SOURCE_KNI = srfft_kni_c.c srfft_kni.S downmix_kni.S imdct512_kni.S imdct_kni.c
-diff -urN ac3dec.org/libao/Makefile.am ac3dec/libao/Makefile.am
---- ac3dec.org/libao/Makefile.am       Fri Feb 16 22:58:34 2001
-+++ ac3dec/libao/Makefile.am   Fri Feb 16 23:13:44 2001
-@@ -1,7 +1,7 @@
+-ac3dec_LDADD= -L./libac3 -lac3 -lm 
++ac3dec_LDADD= ./libac3/libac3.la -lm 
+ noinst_HEADERS = output.h
+ ac3dec_SOURCES = ac3dec.c output.c
+-ac3dec_DEPENDENCIES = libac3/libac3.a
++ac3dec_DEPENDENCIES = libac3/libac3.la
+ EXTRA_DIST = README Changelog TODO plot_spectrum.m autogen.sh\
+diff -urN ac3dec-0.6.1.org/configure.in ac3dec-0.6.1/configure.in
+--- ac3dec-0.6.1.org/configure.in      Wed Mar 14 14:54:26 2001
++++ ac3dec-0.6.1/configure.in  Wed Mar 14 15:13:23 2001
+@@ -11,7 +11,7 @@
+ AM_MAINTAINER_MODE
+ AC_PROG_CC
+ AC_PROG_GCC_TRADITIONAL
+-AC_PROG_RANLIB
++AM_PROG_LIBTOOL
+ AC_CHECK_LIB(ossaudio, _oss_ioctl, LIBS="$LIBS -lossaudio")
+diff -urN ac3dec-0.6.1.org/libac3/Makefile.am ac3dec-0.6.1/libac3/Makefile.am
+--- ac3dec-0.6.1.org/libac3/Makefile.am        Wed Mar 14 14:54:26 2001
++++ ac3dec-0.6.1/libac3/Makefile.am    Wed Mar 14 15:14:57 2001
+@@ -1,15 +1,16 @@
  # # Process this file with automake to produce Makefile.in.
  AUTOMAKE_OPTIONS = 1.3 foreign
  
--CFLAGS = -Wall -Werror -O3 -g @LIBAO_CFLAGS@
-+CFLAGS = -Wall -Werror -g @LIBAO_CFLAGS@
+-CFLAGS = -Wall -Werror -O1 -g
++CFLAGS = @CFLAGS@ -Wall -Werror
+-noinst_LIBRARIES = libac3.a
++lib_LTLIBRARIES = libac3.la
+-libac3_a_SOURCES = bitstream.c decode.c imdct.c coeff.c exponent.c stats.c\
++libac3_la_SOURCES = bitstream.c decode.c imdct.c coeff.c exponent.c stats.c\
+       bit_allocate.c  parse.c crc.c debug.c rematrix.c downmix.c dither.c \
+       sanity_check.c
+-noinst_HEADERS = ac3_internal.h bitstream.h decode.h imdct.h ac3.h stats.h coeff.h\
++ac3includedir = $(includedir)/ac3
++ac3include_HEADERS = ac3_internal.h bitstream.h decode.h imdct.h ac3.h stats.h coeff.h\
+       exponent.h bit_allocate.h parse.h crc.h debug.h rematrix.h downmix.h dither.h \
+       sanity_check.h
+diff -urN ac3dec-0.6.1.org/libac3/bitstream.c ac3dec-0.6.1/libac3/bitstream.c
+--- ac3dec-0.6.1.org/libac3/bitstream.c        Wed Mar 14 14:54:26 2001
++++ ac3dec-0.6.1/libac3/bitstream.c    Wed Mar 14 14:55:10 2001
+@@ -23,6 +23,7 @@
  
- lib_LTLIBRARIES = libao.la
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
  
-diff -urN ac3dec.org/tools/Makefile.am ac3dec/tools/Makefile.am
---- ac3dec.org/tools/Makefile.am       Fri Feb 16 22:58:34 2001
-+++ ac3dec/tools/Makefile.am   Fri Feb 16 23:11:00 2001
+ #include "ac3.h"
+ #include "ac3_internal.h"
+diff -urN ac3dec-0.6.1.org/tools/Makefile.am ac3dec-0.6.1/tools/Makefile.am
+--- ac3dec-0.6.1.org/tools/Makefile.am Wed Mar 14 14:54:26 2001
++++ ac3dec-0.6.1/tools/Makefile.am     Wed Mar 14 14:56:18 2001
 @@ -1,7 +1,7 @@
  # # Process this file with automake to produce Makefile.in.
  AUTOMAKE_OPTIONS = 1.3 foreign
  
 -CFLAGS = -Wall -Werror -O3 -g 
-+CFLAGS = -Wall -Werror -g 
++CFLAGS = @CFLAGS@ -Wall -Werror
  
  bin_PROGRAMS = extract_ac3 
  
This page took 0.077025 seconds and 4 git commands to generate.