]> git.pld-linux.org Git - packages/abseil-cpp.git/blame - abseil-cpp.spec
- updated to 20220623.1 (new sonames)
[packages/abseil-cpp.git] / abseil-cpp.spec
CommitLineData
3a728185
JB
1#
2# Conditional build:
3%bcond_without static_libs # static libraries
4#
5Summary: Abseil - C++ common libraries
6Summary(pl.UTF-8): Abseil - wspólne biblioteki C++
7Name: abseil-cpp
ad3693b7 8Version: 20220623.1
1037cd8e 9Release: 1
3a728185
JB
10License: Apache v2.0
11Group: Libraries
12#Source0Download: https://github.com/abseil/abseil-cpp/releases
43dbd51a 13Source0: https://github.com/abseil/abseil-cpp/archive/%{version}/%{name}-%{version}.tar.gz
ad3693b7 14# Source0-md5: 2aea7c1171c4c280f755de170295afd6
3a728185 15URL: https://abseil.io/
43dbd51a
JB
16BuildRequires: cmake >= 3.8
17BuildRequires: libstdc++-devel >= 6:7
3a728185
JB
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
43dbd51a
JB
20# refers to _ZN4absl12lts_2021110213cord_internal17cordz_next_sampleE non-function symb ol from libabsl_condz_functions
21%define skip_post_check_so libabsl_cord.so.*
22
3a728185
JB
23%description
24Abseil is an open-source collection of C++ library code designed to
25augment the C++ standard library. The Abseil library code is collected
26from Google's own C++ code base, has been extensively tested and used
27in production.
28
29%description -l pl.UTF-8
30Abseil to zbiór bibliotek C++ o otwartych źródłach, zaprojektowancych
31jako uzupełnienie biblioteki standardowej C++. Kod bibliotek został
32zebrany z własnego kodu C++ Google'a, obszernie przetestowany i jest
33używany produkcyjnie.
34
35%package devel
36Summary: Header files for Abseil libraries
37Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Abseil
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
43dbd51a 40Requires: libstdc++-devel >= 6:7
3a728185
JB
41
42%description devel
43Header files for Abseil libraries.
44
45%description devel -l pl.UTF-8
46Pliki nagłówkowe bibliotek Abseil.
47
48%package static
49Summary: Static Abseil libraries
50Summary(pl.UTF-8): Statyczne biblioteki Abseil
51Group: Development/Libraries
52Requires: %{name}-devel = %{version}-%{release}
53
54%description static
55Static Abseil libraries.
56
57%description static -l pl.UTF-8
58Statyczne biblioteki Abseil.
59
60%prep
61%setup -q
62
63%build
64%if %{with static_libs}
65install -d build-static
66cd build-static
67%cmake .. \
43dbd51a
JB
68 -DABSL_PROPAGATE_CXX_STD=ON \
69 -DBUILD_SHARED_LIBS=OFF \
70 -DCMAKE_CXX_STANDARD=17
3a728185
JB
71
72%{__make}
73cd ..
74%endif
75
76install -d build
77cd build
43dbd51a
JB
78%cmake .. \
79 -DABSL_PROPAGATE_CXX_STD=ON \
80 -DCMAKE_CXX_STANDARD=17
3a728185
JB
81
82%{__make}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87%if %{with static_libs}
88%{__make} -C build-static install \
89 DESTDIR=$RPM_BUILD_ROOT
90%endif
91
92%{__make} -C build install \
93 DESTDIR=$RPM_BUILD_ROOT
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post -p /sbin/ldconfig
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(644,root,root,755)
103%doc AUTHORS FAQ.md README.md
1037cd8e 104%attr(755,root,root) %{_libdir}/libabsl_*.so.*.*.*
3a728185
JB
105
106%files devel
107%defattr(644,root,root,755)
1037cd8e 108%attr(755,root,root) %{_libdir}/libabsl_*.so
3a728185
JB
109%{_includedir}/absl
110%{_libdir}/cmake/absl
1037cd8e 111%{_pkgconfigdir}/absl_*.pc
3a728185
JB
112
113%if %{with static_libs}
114%files static
115%defattr(644,root,root,755)
1037cd8e 116%{_libdir}/libabsl_*.a
3a728185 117%endif
This page took 0.101654 seconds and 4 git commands to generate.