]> git.pld-linux.org Git - packages/abrt.git/commitdiff
- updated to 2.8.2 auto/th/abrt-2.8.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 3 Aug 2016 19:39:29 +0000 (21:39 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 3 Aug 2016 19:39:29 +0000 (21:39 +0200)
- updated rpm5 patch
- removed obsolete format_security,profile.sh patches

abrt-rpm5.patch
abrt.spec
format_security.patch [deleted file]
profile.sh.patch [deleted file]

index c311fa3b3b7fad9d88fc44e257ca123a64300f4e..f68aaf2699b5d51940703654c0f77605502db4ef 100644 (file)
@@ -8,8 +8,8 @@
      $(GLIB_CFLAGS) \
      $(LIBREPORT_CFLAGS) \
      -D_GNU_SOURCE \
---- abrt-2.4.0/src/daemon/rpm.c.orig   2015-02-19 12:53:14.000000000 +0100
-+++ abrt-2.4.0/src/daemon/rpm.c        2015-02-26 16:02:37.659278317 +0100
+--- abrt-2.8.2/src/daemon/rpm.c.orig   2016-07-08 09:49:44.000000000 +0200
++++ abrt-2.8.2/src/daemon/rpm.c        2016-08-03 20:51:03.649708165 +0200
 @@ -62,7 +62,6 @@ void rpm_init()
  void rpm_destroy()
  {
@@ -18,7 +18,7 @@
      rpmFreeMacros(NULL);
      rpmFreeRpmrc();
  
-@@ -104,13 +103,20 @@ int rpm_chk_fingerprint(const char* pkg)
+@@ -119,13 +118,20 @@ char *rpm_get_fingerprint(const char *pk
      const char *errmsg = NULL;
  
      rpmts ts = rpmtsCreate();
@@ -42,7 +42,7 @@
      if (!pgpsig && errmsg)
      {
          log_notice("cannot get siggpg:pgpsig. reason: %s", errmsg);
-@@ -128,8 +134,8 @@ int rpm_chk_fingerprint(const char* pkg)
+@@ -138,8 +144,8 @@ char *rpm_get_fingerprint(const char *pk
  
  error:
      free(pgpsig);
 -    rpmtsFree(ts);
 +    iter = rpmmiFree(iter);
 +    ts = rpmtsFree(ts);
-     return ret;
+     return fingerprint;
  }
  
-@@ -146,8 +152,8 @@ bool CheckHash(const char* pPackage, con
+@@ -156,8 +162,8 @@ bool CheckHash(const char* pPackage, con
  {
      bool ret = true;
      rpmts ts = rpmtsCreate();
@@ -64,7 +64,7 @@
      if (header == NULL)
          goto error;
  
-@@ -167,13 +173,13 @@ bool CheckHash(const char* pPackage, con
+@@ -177,13 +183,13 @@ bool CheckHash(const char* pPackage, con
      }
      rpmfiFree(fi);
  error:
@@ -81,7 +81,7 @@
          const char *filename, const char *rootdir_or_NULL)
  {
      const char *queryname = filename;
-@@ -181,11 +187,7 @@ static int rpm_query_file(rpmts *ts, rpm
+@@ -191,11 +197,7 @@ static int rpm_query_file(rpmts *ts, rpm
      *ts = rpmtsCreate();
      if (rootdir_or_NULL)
      {
@@ -94,7 +94,7 @@
  
          unsigned len = strlen(rootdir_or_NULL);
          /* remove 'chroot' prefix */
-@@ -194,12 +196,12 @@ static int rpm_query_file(rpmts *ts, rpm
+@@ -204,12 +206,12 @@ static int rpm_query_file(rpmts *ts, rpm
      }
  
      *iter = rpmtsInitIterator(*ts, RPMTAG_BASENAMES, queryname, 0);
  
          return rpm_query_file(ts, iter, header, filename, NULL);
      }
-@@ -212,8 +214,8 @@ char* rpm_get_component(const char *file
+@@ -222,8 +224,8 @@ char* rpm_get_component(const char *file
      char *ret = NULL;
      char *srpm = NULL;
      rpmts ts;
  
      if (rpm_query_file(&ts, &iter, &header, filename, rootdir_or_NULL) < 0)
          return NULL;
-@@ -222,7 +224,7 @@ char* rpm_get_component(const char *file
+@@ -232,7 +234,7 @@ char* rpm_get_component(const char *file
          goto error;
  
      const char *errmsg = NULL;
      if (!srpm && errmsg)
      {
          error_msg("cannot get srpm. reason: %s", errmsg);
-@@ -233,8 +235,8 @@ char* rpm_get_component(const char *file
+@@ -243,8 +245,8 @@ char* rpm_get_component(const char *file
      free(srpm);
  
   error:
      return ret;
  }
  
-@@ -242,7 +244,7 @@ char* rpm_get_component(const char *file
+@@ -252,7 +254,7 @@ char* rpm_get_component(const char *file
      static inline int pkg_add_##name(Header header, struct pkg_envra *p) \
      {                                                                   \
          const char *errmsg = NULL;                                      \
          if (p->p_##name || !errmsg)                                     \
              return 0;                                                   \
                                                                          \
-@@ -261,8 +263,8 @@ pkg_add_id(arch);
+@@ -272,8 +274,8 @@ pkg_add_id(vendor);
  struct pkg_envra *rpm_get_package_nvr(const char *filename, const char *rootdir_or_NULL)
  {
      rpmts ts;
  
      struct pkg_envra *p = NULL;
  
-@@ -305,15 +307,15 @@ struct pkg_envra *rpm_get_package_nvr(co
+@@ -320,15 +322,15 @@ struct pkg_envra *rpm_get_package_nvr(co
  
      p->p_nvr = xasprintf("%s-%s-%s", p->p_name, p->p_version, p->p_release);
  
index 01aeed5d8f87ac2eeb342f95314a07cfc6536078..4fe690128521ad5df2d3b73120c2440821566a23 100644 (file)
--- a/abrt.spec
+++ b/abrt.spec
@@ -7,22 +7,20 @@
 # Conditional build:
 %bcond_without tests   # disable pythontests
 #
-%define                libreport_ver   2.6.0
+%define                libreport_ver   2.7.0
 Summary:       Automatic bug detection and reporting tool
 Summary(pl.UTF-8):     Narzędzie do automatycznego wykrywania i zgłaszania błędów
 Name:          abrt
-Version:       2.7.1
-Release:       2
+Version:       2.8.2
+Release:       1
 License:       GPL v2+
 Group:         Applications/System
 Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
-# Source0-md5: fee268003142e35fc72fa8a52941dd80
+# Source0-md5: 055c573c70510e3c09cb12a6cc813507
 Source1:       %{name}.init
 Patch0:                %{name}-rpm5.patch
 Patch1:                %{name}-rpm45.patch
-Patch2:                format_security.patch
-Patch3:                %{name}-link.patch
-Patch4:                profile.sh.patch
+Patch2:                %{name}-link.patch
 URL:           https://fedorahosted.org/abrt/
 BuildRequires: asciidoc
 BuildRequires: autoconf >= 2.50
@@ -490,8 +488,8 @@ się do powłoki.
 %patch1 -p1
 %endif
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
+
+%{__sed} -n -e '/^%%changelog/,$p' abrt.spec.in | tail -n +2 > changelog
 
 %build
 %{__libtoolize}
@@ -649,7 +647,7 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README
+%doc README.md changelog
 %attr(755,root,root) %{_bindir}/abrt
 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
 %attr(755,root,root) %{_bindir}/abrt-action-notify
@@ -778,7 +776,6 @@ fi
 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-alt-component
 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
-%attr(755,root,root) %{_bindir}/abrt-action-save-kernel-data
 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
 %attr(755,root,root) %{_bindir}/abrt-dump-oops
 %{_datadir}/%{name}/conf.d/plugins/oops.conf
@@ -789,7 +786,6 @@ fi
 %{systemdunitdir}/abrt-oops.service
 %{_mandir}/man1/abrt-action-analyze-oops.1*
 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
-%{_mandir}/man1/abrt-action-save-kernel-data.1*
 %{_mandir}/man1/abrt-dump-journal-oops.1*
 %{_mandir}/man1/abrt-dump-oops.1*
 %{_mandir}/man5/abrt-oops.conf.5*
diff --git a/format_security.patch b/format_security.patch
deleted file mode 100644 (file)
index 53e94c4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- abrt-2.1.3/src/plugins/abrt-retrace-client.c.orig  2013-04-02 17:15:14.012788254 +0200
-+++ abrt-2.1.3/src/plugins/abrt-retrace-client.c       2013-04-02 17:42:57.132753624 +0200
-@@ -741,7 +741,7 @@
-     if (response_code == 500 || response_code == 507)
-     {
-         alert_server_error(cfg.url);
--        error_msg_and_die(http_body);
-+        error_msg_and_die("%s", http_body);
-     }
-     else if (response_code == 403)
-     {
diff --git a/profile.sh.patch b/profile.sh.patch
deleted file mode 100644 (file)
index 735acc0..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
---- abrt-2.4.0/src/cli/abrt-console-notification.sh.orig       2015-02-26 16:03:12.122610204 +0100
-+++ abrt-2.4.0/src/cli/abrt-console-notification.sh    2015-02-26 16:10:23.795925422 +0100
-@@ -40,3 +40,5 @@
- fi
- timeout 10s abrt-cli status --since="$SINCE" 2>"$ABRT_DEBUG_LOG" || echo "'abrt-cli status' timed out"
-+
-+unset ABRT_DEBUG_LOG LPATHDIR SINCEFILE TMPPATH SINCE
This page took 0.158355 seconds and 4 git commands to generate.