]> git.pld-linux.org Git - packages/abrt.git/commitdiff
- up to 1.0.9, just keeping it updated
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 8 Apr 2010 21:15:26 +0000 (21:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    abrt-pld.patch -> 1.2
    abrt.spec -> 1.19

abrt-pld.patch
abrt.spec

index f743bed4ef882724e5309093040090fa6d98e8e2..27532f5e6e1972988a5dc2e6100186c15cea9bf1 100644 (file)
@@ -1,11 +1,10 @@
---- abrt-1.0.0/lib/Utils/DebugDump.cpp~        2009-11-22 21:50:18.000000000 +0200
-+++ abrt-1.0.0/lib/Utils/DebugDump.cpp 2010-02-03 00:20:43.878642078 +0200
-@@ -315,7 +315,7 @@
+--- abrt-1.0.9/lib/Utils/DebugDump.cpp~        2010-04-02 12:53:59.000000000 +0300
++++ abrt-1.0.9/lib/Utils/DebugDump.cpp 2010-04-08 23:04:27.265361307 +0300
+@@ -331,6 +331,7 @@
          SaveText(FILENAME_ARCHITECTURE, buf.machine);
-     }
-     std::string release;
--    LoadTextFile("/etc/redhat-release", release);
-+    LoadTextFile("/etc/pld-release", release);
-     const char *release_ptr = release.c_str();
-     unsigned len_1st_str = strchrnul(release_ptr, '\n') - release_ptr;
-     release.erase(len_1st_str); /* usually simply removes trailing '\n' */
+         std::string release;
+         LoadTextFile("/etc/redhat-release", release);
++        LoadTextFile("/etc/pld-release", release);
+         const char *release_ptr = release.c_str();
+         unsigned len_1st_str = strchrnul(release_ptr, '\n') - release_ptr;
+         release.erase(len_1st_str); /* usually simply removes trailing '\n' */
index 90a798b36a6cf99328f3e64eda78fde4d761a770..131e7883c3948dc1b8ab19ee96bd097c8bc98152 100644 (file)
--- a/abrt.spec
+++ b/abrt.spec
@@ -2,13 +2,13 @@
 # - fixes to get working with jbj rpm
 Summary:       Automatic bug detection and reporting tool
 Name:          abrt
-Version:       1.0.8
-Release:       0.8
+Version:       1.0.9
+Release:       0.3
 License:       GPL v2+
 Group:         Applications/System
 URL:           https://fedorahosted.org/abrt/
 Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
-# Source0-md5: 0e480999bb77b3babe19373c03057df4
+# Source0-md5: aaa31f787ae7c144c57837928d26fdc9
 Source1:       %{name}.init
 Patch0:                %{name}-rpm.patch
 Patch1:                %{name}-pld.patch
@@ -99,17 +99,6 @@ Requires:    yum-utils
 This package contains hook for C/C++ crashed programs and abrt's C/C++
 analyzer plugin.
 
-%package plugin-firefox
-Summary:       abrt's Firefox analyzer plugin
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      elfutils
-Requires:      gdb >= 7.0-3
-Requires:      yum-utils
-
-%description plugin-firefox
-This package contains hook for Firefox
-
 %package addon-kerneloops
 Summary:       abrt's kerneloops addon
 Group:         Libraries
@@ -124,6 +113,22 @@ This package contains plugin for collecting kernel crash information
 and reporter plugin which sends this information to specified server,
 usually to kerneloops.org.
 
+%package plugin-rhfastcheck
+Summary:       %{name}'s rhfastcheck plugin
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description plugin-rhfastcheck
+Plugin to quickly check RH support DB for known solution.
+
+%package plugin-rhticket
+Summary:       %{name}'s rhticket plugin
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description plugin-rhticket
+Plugin to report bugs into RH support system.
+
 %package plugin-logger
 Summary:       abrt's logger reporter plugin
 Group:         Libraries
@@ -300,6 +305,19 @@ if [ "$1" = "0" ]; then
        %groupremove abrt
 fi
 
+%post gui
+# update icon cache
+touch --no-create %{_datadir}/icons/hicolor || :
+if [ -x %{_bindir}/gtk-update-icon-cache ]; then
+       %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
+fi
+
+%postun gui
+touch --no-create %{_datadir}/icons/hicolor || :
+if [ -x %{_bindir}/gtk-update-icon-cache ]; then
+       %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
+fi
+
 %post  libs -p /sbin/ldconfig
 %postun        libs -p /sbin/ldconfig
 
@@ -345,10 +363,18 @@ fi
 %files gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/%{name}-gui
-%{_datadir}/%{name}
+%dir %{_datadir}/%{name}
+# all glade, gtkbuilder and py files for gui
+%{_datadir}/%{name}/*.py*
+%{_datadir}/%{name}/*.glade
 %{_desktopdir}/%{name}.desktop
-%{_pixmapsdir}/abrt.png
-%{_iconsdir}/hicolor/48x48/apps/*.png
+%{_iconsdir}/hicolor/*/apps/*
+# XXX ... should be in hicolor dir?
+%dir %{_datadir}/%{name}/icons
+%dir %{_datadir}/%{name}/icons/hicolor
+%dir %{_datadir}/%{name}/icons/hicolor/*
+%dir %{_datadir}/%{name}/icons/hicolor/*/status
+%{_datadir}/%{name}/icons/hicolor/*/status/*.png
 %attr(755,root,root) %{_bindir}/%{name}-applet
 %{_sysconfdir}/xdg/autostart/%{name}-applet.desktop
 
@@ -359,9 +385,6 @@ fi
 %attr(755,root,root) %{_libexecdir}/abrt-hook-ccpp
 %dir %{_localstatedir}/cache/%{name}-di
 
-#%files plugin-firefox
-#%{_libdir}/%{name}/libFirefox.so*
-
 %files addon-kerneloops
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/Kerneloops.conf
@@ -404,6 +427,14 @@ fi
 %{_libdir}/%{name}/Bugzilla.GTKBuilder
 %{_mandir}/man7/%{name}-Bugzilla.7*
 
+%files plugin-rhfastcheck
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/librhfastcheck.so
+
+%files plugin-rhticket
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/librhticket.so
+
 %files plugin-catcut
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/Catcut.conf
@@ -430,6 +461,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/Python.conf
 %attr(755,root,root) %{_libdir}/%{name}/libPython.so
 %{py_sitescriptdir}/*.py[co]
+%{py_sitescriptdir}/abrt.pth
 
 %files cli
 %defattr(644,root,root,755)
This page took 0.152828 seconds and 4 git commands to generate.