]> git.pld-linux.org Git - packages/aMule.git/commitdiff
- fix building with wxWidgets 3.0 auto/th/aMule-2.3.1-15
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 19 Jan 2014 13:04:55 +0000 (14:04 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 19 Jan 2014 13:04:55 +0000 (14:04 +0100)
- rel 15

aMule.spec
wxWidgets3.patch [new file with mode: 0644]

index a8e795c8ca56472d7447dfbd05432f50da4f3379..50c36eef312b42ad25f225c13d681200e5c568c7 100644 (file)
@@ -5,7 +5,7 @@ Summary:        Unix port of eMule client
 Summary(pl.UTF-8):     Uniksowy port klienta eMule
 Name:          aMule
 Version:       2.3.1
 Summary(pl.UTF-8):     Uniksowy port klienta eMule
 Name:          aMule
 Version:       2.3.1
-Release:       14
+Release:       15
 License:       GPL
 Group:         X11/Applications
 Source0:       http://downloads.sourceforge.net/amule/%{name}-%{version}.tar.bz2
 License:       GPL
 Group:         X11/Applications
 Source0:       http://downloads.sourceforge.net/amule/%{name}-%{version}.tar.bz2
@@ -14,6 +14,7 @@ Patch0:               %{name}-desktop.patch
 Patch1:                %{name}-cas-datadir.patch
 Patch2:                %{name}-ac.patch
 Patch3:                %{name}-cxx.patch
 Patch1:                %{name}-cas-datadir.patch
 Patch2:                %{name}-ac.patch
 Patch3:                %{name}-cxx.patch
+Patch4:                wxWidgets3.patch
 URL:           http://www.amule.org/
 BuildRequires: GeoIP-devel
 BuildRequires: autoconf
 URL:           http://www.amule.org/
 BuildRequires: GeoIP-devel
 BuildRequires: autoconf
@@ -88,6 +89,7 @@ Narzędzie do generownia statystyk aMule.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__aclocal} -I m4
 
 %build
 %{__aclocal} -I m4
diff --git a/wxWidgets3.patch b/wxWidgets3.patch
new file mode 100644 (file)
index 0000000..77568b1
--- /dev/null
@@ -0,0 +1,45 @@
+diff -ur aMule-2.3.1/src/amuled.cpp aMule-2.3.1.wx3/src/amuled.cpp
+--- aMule-2.3.1/src/amuled.cpp 2011-07-13 17:00:12.000000000 +0200
++++ aMule-2.3.1.wx3/src/amuled.cpp     2014-01-19 13:55:50.904800356 +0100
+@@ -423,7 +423,9 @@
+ #ifndef __WXMSW__
++/*
+ static EndProcessDataMap endProcDataMap;
++*/
+ int CDaemonAppTraits::WaitForChild(wxExecuteData &execData)
+@@ -449,6 +451,7 @@
+               wxSleep(1);
+               result = AmuleWaitPid(execData.pid, &status, WNOHANG, &msg);
+               if (result == 0) {
++              /*
+                       // Add a WxEndProcessData entry to the map, so that we can
+                       // support process termination
+                       wxEndProcessData *endProcData = new wxEndProcessData();
+@@ -456,6 +459,7 @@
+                       endProcData->process = execData.process;
+                       endProcData->tag = 0;
+                       endProcDataMap[execData.pid] = endProcData;
++              */
+                       status = execData.pid;
+               } else {
+@@ -480,6 +484,7 @@
+       msg << wxT("OnSignalChildHandler() has been called for child process with pid `") <<
+               siginfo->si_pid <<
+               wxT("'. ");
++/*
+       // Make sure we leave no zombies by calling waitpid()
+       int status = 0;
+       pid_t result = AmuleWaitPid(siginfo->si_pid, &status, WNOHANG, &msg);
+@@ -503,6 +508,7 @@
+                       msg << wxT(" Error: the child process pid is not on the pid map.");
+               }
+       }
++*/
+       // Log our passage here
+       AddDebugLogLineN(logGeneral, msg);
This page took 0.115861 seconds and 4 git commands to generate.