]> git.pld-linux.org Git - packages/aMule.git/blobdiff - aMule.spec
- rel 2; rebuild
[packages/aMule.git] / aMule.spec
index d925f6cde2f4306c745bf7808153361ab8416e9e..d5c11023e328fc190704576c6b3836e247c55b37 100644 (file)
@@ -1,23 +1,39 @@
+#
+# TODO:
+# - split into subpackages
+# - package %{_libdir}/xchat/plugins/xas.pl
+# - depends on binutils, why?
+#
 Summary:       Unix port of eMule client
 Summary(pl):   Uniksowy port klienta eMule
 Name:          aMule
-Version:       1.1.2
-Release:       1
+Version:       2.0.3
+Release:       2
 License:       GPL
 Group:         X11/Applications
-Source0:       http://dl.sourceforge.net/amule/%{name}-%{version}.tar.bz2
-# Source0-md5: 67ed6489eb405ad475d4cca769310b23
-Patch0:        %{name}-po_makefile.patch
-URL:           http://amule.sourceforge.net
+Source0:       http://download.berlios.de/amule/%{name}-%{version}.tar.bz2
+# Source0-md5: 204ca3472a773d8fa484d0a0787bf0d7
+Patch0:                %{name}-configure_in.patch
+Patch1:                %{name}-desktop.patch
+Patch2:                %{name}-cas-datadir.patch
+URL:           http://www.amule.org/
 BuildRequires: autoconf
-BuildRequires: automake >= 1.7.3
+BuildRequires: automake >= 1:1.7.3
 BuildRequires: bison
+#BuildRequires:        cryptopp-devel >= 5.1
+BuildRequires: curl-devel >= 7.9.7
 BuildRequires: expat-devel
+BuildRequires: gd-devel
 BuildRequires: gettext-devel >= 0.11.5
-BuildRequires: gtk+2-devel >= 2.2.0
+BuildRequires: gettext-autopoint
+BuildRequires: gtk+2-devel >= 2:2.2.0
+BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
-BuildRequires: wxGTK2-devel >= 2.4.0
+BuildRequires: wxBase-devel >= 2.6.0
+BuildRequires: wxGTK2-devel >= 2.6.0
 Requires:      wget
+Obsoletes:     lmule
+Obsoletes:     xmule
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -26,17 +42,70 @@ aMule is a Linux port of eMule client.
 %description -l pl
 aMule to linuksowy port klienta eMule.
 
+%package plugin-xchat
+Summary:       Xchat plugin
+Summary(pl):   Wtyczka dla xchat
+Requires:      %{name} = %{version}-%{release}
+Group:         X11/Applications
+Provides:      %{name}-plugin-xchat
+
+%description plugin-xchat
+Plugin for Xchat IRC client.
+
+%description plugin-xchat -l pl
+Wtczka dla klienta IRC xchat.
+
+%package alc
+Summary:       Ed2k link creator for aMule
+Summary(pl):   Kreator linków ed2k dla aMule
+Requires:      %{name} = %{version}-%{release}
+Group:         X11/Applications
+Provides:      alc
+
+%description alc
+Tool for creating ed2k links.
+
+%description alc -l pl
+Narzêdzie do tworzenia linków ed2k.
+
+%package cas
+Summary:       aMule online stats
+Summary(pl):   Statystyki online aMule
+Requires:      %{name} = %{version}-%{release}
+Group:         X11/Applications
+Provides:      cas
+
+%description cas
+Tool for generating aMule online stats.
+
+%description cas -l pl
+Narzêdzie do generownia statystyk aMule.
+
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
-%{__aclocal}
+%{__gettextize}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       --with-wx-config=/usr/bin/wxgtk2-2.4-config 
+       --with-wx-config=%{_bindir}/wx-gtk2-ansi-config \
+       --%{?debug:en}%{!?debug:dis}able-debug          \
+       --enable-optimise                               \
+       --enable-amule-daemon                           \
+       --enable-amulecmd                               \
+       --enable-amulecmdgui                            \
+       --enable-webserver                              \
+       --enable-webservergui                           \
+       --enable-cas                                    \
+       --enable-wxcas                                  \
+       --enable-alc                                    \
+       --enable-alcc
 
 %{__make}
 
@@ -46,6 +115,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{et_EE,et}
+mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{pt_PT,pt}
+
 %find_lang amule
 
 %clean
@@ -53,5 +125,50 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f amule.lang
 %defattr(644,root,root,755)
-%doc AUTHORS Changelog ED2K-Links.HOWTO README TODO
-%attr(755,root,root) %{_bindir}/*
+%doc docs/AUTHORS docs/README docs/Changelog docs/ED2K-Links.HOWTO docs/TODO docs/amulesig.txt
+%attr(755,root,root) %{_bindir}/amule*
+%attr(755,root,root) %{_bindir}/ed2k
+%dir %{_datadir}/amule
+%{_datadir}/amule/webserver
+%{_desktopdir}/amule.desktop
+%{_pixmapsdir}/amule.xpm
+%{_mandir}/man1/amule*
+%{_mandir}/man1/ed2k*
+%{_mandir}/man1/xas*
+%lang(de) %{_mandir}/de/man1/amule*
+%lang(de) %{_mandir}/de/man1/ed2k*
+%lang(de) %{_mandir}/de/man1/xas*
+%lang(es) %{_mandir}/es/man1/amule*
+%lang(es) %{_mandir}/es/man1/ed2k*
+%lang(es) %{_mandir}/es/man1/xas*
+%lang(fr) %{_mandir}/fr/man1/amule*
+%lang(fr) %{_mandir}/fr/man1/ed2k*
+%lang(hu) %{_mandir}/hu/man1/amule*
+%lang(hu) %{_mandir}/hu/man1/ed2k*
+%lang(hu) %{_mandir}/hu/man1/xas*
+
+%files plugin-xchat
+%defattr(644,root,root,755)
+%{_libdir}/xchat/plugins/xas.pl
+
+%files alc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/alc*
+%{_desktopdir}/alc.desktop
+%{_pixmapsdir}/alc.xpm
+%{_mandir}/man1/alc*
+%lang(de) %{_mandir}/de/man1/alc*
+%lang(es) %{_mandir}/es/man1/alc*
+%lang(fr) %{_mandir}/fr/man1/alc*
+%lang(hu) %{_mandir}/hu/man1/alc*
+
+%files cas
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/*cas
+%{_datadir}/amule/cas
+%{_desktopdir}/*cas.desktop
+%{_pixmapsdir}/wxcas.xpm
+%{_mandir}/man1/*cas*
+%lang(de) %{_mandir}/de/man1/*cas*
+%lang(es) %{_mandir}/es/man1/*cas*
+%lang(hu) %{_mandir}/hu/man1/*cas*
This page took 0.041006 seconds and 4 git commands to generate.