]> git.pld-linux.org Git - packages/aMule.git/blob - aMule.spec
f659bda6c6338d2ae8b5214d2004eb2ae460e9b1
[packages/aMule.git] / aMule.spec
1 #
2 # TODO:
3 # - split into subpackages
4 # - package %{_libdir}/xchat/plugins/xas.pl
5 # - depends on binutils, why?
6 #
7 Summary:        Unix port of eMule client
8 Summary(pl):    Uniksowy port klienta eMule
9 Name:           aMule
10 Version:        2.0.3
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications
14 Source0:        http://download.berlios.de/amule/%{name}-%{version}.tar.bz2
15 # Source0-md5:  204ca3472a773d8fa484d0a0787bf0d7
16 Patch0:         %{name}-configure_in.patch
17 Patch1:         %{name}-desktop.patch
18 Patch2:         %{name}-cas-datadir.patch
19 URL:            http://www.amule.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake >= 1:1.7.3
22 BuildRequires:  bison
23 #BuildRequires: cryptopp-devel >= 5.1
24 BuildRequires:  curl-devel >= 7.9.7
25 BuildRequires:  expat-devel
26 BuildRequires:  gd-devel
27 BuildRequires:  gettext-devel >= 0.11.5
28 BuildRequires:  gettext-autopoint
29 BuildRequires:  gtk+2-devel >= 2:2.2.0
30 BuildRequires:  libpng-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  wxBase-devel >= 2.6.0
33 BuildRequires:  wxGTK2-devel >= 2.6.0
34 Requires:       wget
35 Obsoletes:      lmule
36 Obsoletes:      xmule
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 aMule is a Linux port of eMule client.
41
42 %description -l pl
43 aMule to linuksowy port klienta eMule.
44
45 %package plugin-xchat
46 Summary:        Xchat plugin
47 Summary(pl):    Wtyczka dla xchat
48 Requires:       %{name} = %{version}-%{release}
49 Group:          X11/Applications
50 Provides:       %{name}-plugin-xchat
51
52 %description plugin-xchat
53 Plugin for Xchat IRC client.
54
55 %description plugin-xchat -l pl
56 Wtczka dla klienta IRC xchat.
57
58 %package alc
59 Summary:        Ed2k link creator for aMule
60 Summary(pl):    Kreator linków ed2k dla aMule
61 Requires:       %{name} = %{version}-%{release}
62 Group:          X11/Applications
63 Provides:       alc
64
65 %description alc
66 Tool for creating ed2k links.
67
68 %description alc -l pl
69 Narzêdzie do tworzenia linków ed2k.
70
71 %package cas
72 Summary:        aMule online stats
73 Summary(pl):    Statystyki online aMule
74 Requires:       %{name} = %{version}-%{release}
75 Group:          X11/Applications
76 Provides:       cas
77
78 %description cas
79 Tool for generating aMule online stats.
80
81 %description cas -l pl
82 Narzêdzie do generownia statystyk aMule.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 %{__gettextize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         --with-wx-config=%{_bindir}/wx-gtk2-ansi-config \
98         --%{?debug:en}%{!?debug:dis}able-debug          \
99         --enable-optimise                               \
100         --enable-amule-daemon                           \
101         --enable-amulecmd                               \
102         --enable-amulecmdgui                            \
103         --enable-webserver                              \
104         --enable-webservergui                           \
105         --enable-cas                                    \
106         --enable-wxcas                                  \
107         --enable-alc                                    \
108         --enable-alcc
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{et_EE,et}
119 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{pt_PT,pt}
120
121 %find_lang amule
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files -f amule.lang
127 %defattr(644,root,root,755)
128 %doc docs/AUTHORS docs/README docs/Changelog docs/ED2K-Links.HOWTO docs/TODO docs/amulesig.txt
129 %attr(755,root,root) %{_bindir}/amule*
130 %attr(755,root,root) %{_bindir}/ed2k
131 %dir %{_datadir}/amule
132 %{_datadir}/amule/webserver
133 %{_desktopdir}/amule.desktop
134 %{_pixmapsdir}/amule.xpm
135 %{_mandir}/man1/amule*
136 %{_mandir}/man1/ed2k*
137 %{_mandir}/man1/xas*
138 %lang(de) %{_mandir}/de/man1/amule*
139 %lang(de) %{_mandir}/de/man1/ed2k*
140 %lang(de) %{_mandir}/de/man1/xas*
141 %lang(es) %{_mandir}/es/man1/amule*
142 %lang(es) %{_mandir}/es/man1/ed2k*
143 %lang(es) %{_mandir}/es/man1/xas*
144 %lang(fr) %{_mandir}/fr/man1/amule*
145 %lang(fr) %{_mandir}/fr/man1/ed2k*
146 %lang(hu) %{_mandir}/hu/man1/amule*
147 %lang(hu) %{_mandir}/hu/man1/ed2k*
148 %lang(hu) %{_mandir}/hu/man1/xas*
149
150 %files plugin-xchat
151 %defattr(644,root,root,755)
152 %{_libdir}/xchat/plugins/xas.pl
153
154 %files alc
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/alc*
157 %{_desktopdir}/alc.desktop
158 %{_pixmapsdir}/alc.xpm
159 %{_mandir}/man1/alc*
160 %lang(de) %{_mandir}/de/man1/alc*
161 %lang(es) %{_mandir}/es/man1/alc*
162 %lang(fr) %{_mandir}/fr/man1/alc*
163 %lang(hu) %{_mandir}/hu/man1/alc*
164
165 %files cas
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/*cas
168 %{_datadir}/amule/cas
169 %{_desktopdir}/*cas.desktop
170 %{_pixmapsdir}/wxcas.xpm
171 %{_mandir}/man1/*cas*
172 %lang(de) %{_mandir}/de/man1/*cas*
173 %lang(es) %{_mandir}/es/man1/*cas*
174 %lang(hu) %{_mandir}/hu/man1/*cas*
This page took 0.050786 seconds and 2 git commands to generate.