- rel 2; rebuild
[packages/aMule.git] / aMule.spec
CommitLineData
d6768fea 1#
2# TODO:
3# - split into subpackages
4# - package %{_libdir}/xchat/plugins/xas.pl
2316daf9 5# - depends on binutils, why?
d6768fea 6#
fce15251 7Summary: Unix port of eMule client
8Summary(pl): Uniksowy port klienta eMule
9Name: aMule
62a925d0 10Version: 2.0.3
13bde40a 11Release: 2
fce15251 12License: GPL
13Group: X11/Applications
62a925d0 14Source0: http://download.berlios.de/amule/%{name}-%{version}.tar.bz2
15# Source0-md5: 204ca3472a773d8fa484d0a0787bf0d7
428d2bd5 16Patch0: %{name}-configure_in.patch
e3a76a47 17Patch1: %{name}-desktop.patch
817b67c8 18Patch2: %{name}-cas-datadir.patch
fad345eb 19URL: http://www.amule.org/
fce15251 20BuildRequires: autoconf
02b702fb 21BuildRequires: automake >= 1:1.7.3
fce15251 22BuildRequires: bison
fad345eb 23#BuildRequires: cryptopp-devel >= 5.1
f46f2e7c 24BuildRequires: curl-devel >= 7.9.7
fce15251 25BuildRequires: expat-devel
5c4f96f7 26BuildRequires: gd-devel
2ef37d7f 27BuildRequires: gettext-devel >= 0.11.5
251a1e8e 28BuildRequires: gettext-autopoint
04cb85df 29BuildRequires: gtk+2-devel >= 2:2.2.0
5c4f96f7 30BuildRequires: libpng-devel
fce15251 31BuildRequires: libstdc++-devel
788f7e2c
JB
32BuildRequires: wxBase-devel >= 2.6.0
33BuildRequires: wxGTK2-devel >= 2.6.0
fce15251 34Requires: wget
3be09a77 35Obsoletes: lmule
e3a76a47 36Obsoletes: xmule
fce15251 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
06a2ef63 40aMule is a Linux port of eMule client.
fce15251 41
42%description -l pl
06a2ef63 43aMule to linuksowy port klienta eMule.
fce15251 44
0e64ca48
RK
45%package plugin-xchat
46Summary: Xchat plugin
47Summary(pl): Wtyczka dla xchat
7966823b 48Requires: %{name} = %{version}-%{release}
0e64ca48
RK
49Group: X11/Applications
50Provides: %{name}-plugin-xchat
51
52%description plugin-xchat
53Plugin for Xchat IRC client.
54
55%description plugin-xchat -l pl
56Wtczka dla klienta IRC xchat.
57
58%package alc
59Summary: Ed2k link creator for aMule
60