]> git.pld-linux.org Git - packages/a2ps.git/commitdiff
- fix format string errors auto/th/a2ps-4.14-3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 1 Apr 2015 20:19:18 +0000 (22:19 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 1 Apr 2015 20:19:18 +0000 (22:19 +0200)
- fix building with texinfo 5
- rel 3

a2ps-info.patch
a2ps.spec
format-security.patch [new file with mode: 0644]

index 81f55815a956c0f21600caceed0482eca708f20f..ce03d639803eb423c3be5375821ee1f245e36c39 100644 (file)
@@ -1,6 +1,21 @@
 diff -Nru a2ps-4.12h/doc/a2ps.texi a2ps-4.12h.new/doc/a2ps.texi
 --- a2ps-4.12h/doc/a2ps.texi   Sat Dec 18 11:13:33 1999
 +++ a2ps-4.12h.new/doc/a2ps.texi       Sat Dec 18 11:12:41 1999
 diff -Nru a2ps-4.12h/doc/a2ps.texi a2ps-4.12h.new/doc/a2ps.texi
 --- a2ps-4.12h/doc/a2ps.texi   Sat Dec 18 11:13:33 1999
 +++ a2ps-4.12h.new/doc/a2ps.texi       Sat Dec 18 11:12:41 1999
+@@ -22,12 +22,12 @@
+ @c `a2ps'.  Avoid those quotes.
+ @iftex
+ @macro pack
+-@code{@value{PACKAGE}}@c
++@code{@value{PACKAGE}}
+ @end macro
+ @end iftex
+ @ifnottex
+ @macro pack
+-@value{PACKAGE}@c
++@value{PACKAGE}
+ @end macro
+ @end ifnottex
 @@ -59,16 +59,16 @@
  @TeX{}Script
  @end macro
 @@ -59,16 +59,16 @@
  @TeX{}Script
  @end macro
index 7e3333e35ff59420ddbbbe50b55c1b1b9f4a05db..c2565b5cda126b322ec966c6aacb4291028d3183 100644 (file)
--- a/a2ps.spec
+++ b/a2ps.spec
@@ -4,7 +4,7 @@ Summary(pl.UTF-8):      Filtr text/plain do Postscriptu
 Summary(zh_CN.UTF-8):  纯文本到Postscript转换器
 Name:          a2ps
 Version:       4.14
 Summary(zh_CN.UTF-8):  纯文本到Postscript转换器
 Name:          a2ps
 Version:       4.14
-Release:       2
+Release:       3
 License:       GPL v3+
 Group:         Applications/Text
 Source0:       http://ftp.gnu.org/gnu/a2ps/%{name}-%{version}.tar.gz
 License:       GPL v3+
 Group:         Applications/Text
 Source0:       http://ftp.gnu.org/gnu/a2ps/%{name}-%{version}.tar.gz
@@ -24,6 +24,7 @@ Patch8:               %{name}-ogonkify-xfig-fix.patch
 Patch9:                %{name}-pl.po-update.patch
 Patch10:       %{name}-locale-names.patch
 Patch11:       %{name}-atan2.patch
 Patch9:                %{name}-pl.po-update.patch
 Patch10:       %{name}-locale-names.patch
 Patch11:       %{name}-atan2.patch
+Patch12:       format-security.patch
 URL:           http://www.gnu.org/software/a2ps/
 BuildRequires: automake
 BuildRequires: flex
 URL:           http://www.gnu.org/software/a2ps/
 BuildRequires: automake
 BuildRequires: flex
@@ -93,6 +94,7 @@ Biblioteka statyczna a2ps.
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 mv -f po/{no,nb}.po
 
 
 mv -f po/{no,nb}.po
 
diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..3f8b4a6
--- /dev/null
@@ -0,0 +1,44 @@
+--- a2ps-4.14/lib/output.c~    2015-04-01 22:07:29.000000000 +0200
++++ a2ps-4.14/lib/output.c     2015-04-01 22:08:53.825344087 +0200
+@@ -525,7 +525,7 @@
+                    expand_user_string (job, FIRST_FILE (job),
+                                        (const uchar *) "Expand: requirement",
+                                        (const uchar *) token));
+-      output (dest, expansion);
++      output (dest, "%s", expansion);
+       continue;
+       }
+--- a2ps-4.14/lib/psgen.c~     2007-12-29 02:58:22.000000000 +0100
++++ a2ps-4.14/lib/psgen.c      2015-04-01 22:09:36.668677711 +0200
+@@ -232,7 +232,7 @@
+     default:
+       *buf = '\0';
+       ps_escape_char (job, cp[i], buf);
+-      output (jdiv, (char *) buf);
++      output (jdiv, "%s", (char *) buf);
+       break;
+     }
+   }
+--- a2ps-4.14/lib/parseppd.y~  2007-12-29 02:58:21.000000000 +0100
++++ a2ps-4.14/lib/parseppd.y   2015-04-01 22:12:11.502012094 +0200
+@@ -154,7 +154,7 @@
+ void
+ yyerror (const char *msg)
+ {
+-  error_at_line (1, 0, ppdfilename, ppdlineno, msg);
++  error_at_line (1, 0, ppdfilename, ppdlineno, "%s", msg);
+ }
+ /*
+--- a2ps-4.14/src/parsessh.y~  2007-12-29 02:58:35.000000000 +0100
++++ a2ps-4.14/src/parsessh.y   2015-04-01 22:12:50.782012360 +0200
+@@ -740,7 +740,7 @@
+ void
+ yyerror (const char *msg)
+ {
+-  error_at_line (1, 0, sshfilename, sshlineno, msg);
++  error_at_line (1, 0, sshfilename, sshlineno, "%s", msg);
+ }
+ /*
This page took 0.048242 seconds and 4 git commands to generate.