]> git.pld-linux.org Git - packages/Zope3.git/blob - Zope3.spec
f6cf530bc5351c0f59fe821fe29ecc236021e571
[packages/Zope3.git] / Zope3.spec
1
2 Summary:        An application server and portal toolkit for building Web sites
3 Summary(es):    Un servidor de aplicaciones y un conjunto de herramientas para la construcción de sitios Web
4 Summary(pl):    Serwer aplikacji i toolkit portalowy do tworzenia serwisów WWW
5 Summary(pt_BR): Um servidor de aplicações e um conjunto de ferramentas para construção de sites Web
6 Name:           Zope3
7 Version:        3.1.0
8 %define         sub_ver c1
9 Release:        0.%{sub_ver}.0.1
10 License:        Zope Public License (ZPL)
11 Group:          Networking/Daemons
12 Source0:        http://www.zope.org/Products/Zope3/%{version}%{sub_ver}/%{name}-%{version}%{sub_ver}.tgz
13 # Source0-md5:  66876823e53fbd0d4a8a7262d7ce251b
14 Source1:        %{name}.init
15 Source2:        %{name}.sysconfig
16 Source3:        %{name}.logrotate
17 URL:            http://dev.zope.org/Zope3
18 BuildRequires:  python-devel >= 1:2.4.1
19 BuildRequires:  perl-base
20 BuildRequires:  rpmbuild(macros) >= 1.213
21 PreReq:         rc-scripts
22 Requires(pre):  /bin/id
23 Requires(pre):  /usr/bin/getgid
24 Requires(pre):  /usr/sbin/groupadd
25 Requires(pre):  /usr/sbin/useradd
26 Requires(postun):       /usr/sbin/groupdel
27 Requires(postun):       /usr/sbin/userdel
28 Requires(post,preun):   /sbin/chkconfig
29 Requires:       expat >= 1.95.7
30 Requires:       logrotate
31 Requires:       python >= 2.4.1
32 Requires:       python-modules >= 2.4.1
33 Requires:       python-libs >= 2.4.1
34 Requires:       python-zope-interface = %{epoch}:%{version}-%{release}
35 %pyrequires_eq  python
36 Provides:       group(zope)
37 Provides:       user(zope)
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         zope_dir /usr/lib/zope3
41
42 %description
43 The Z Object Programming Environment (Zope) is a free, Open Source
44 Python-based application server for building high-performance, dynamic
45 web sites, using a powerful and simple scripting object model and
46 high-performance, integrated object database.
47
48 This project is a redesign of Zope 2 and seeks to improve the Zope development
49 experience through the use of Interfaces and Components.
50
51 %description -l es
52 Zope es una aplicación basada en Python, Open Source[tm], para la
53 construcción de sitios dinámicos, usa un modelo de escritura de
54 guiones poderoso y sencillo. Para instalar la aplicación Zope, instale
55 ese paquete y después, Zope-server, para un servidor HTTP integrado
56 simple, Zope-pcgi, para uso con el servidor Apache. Si desea instalar
57 solamente algunas partes de la aplicación Zope, están diponibles otros
58 subpaquetes, usted debe instalar éstos en vez de ese RPM.
59
60 %description -l pl
61 Zope (Z Object Programming Environment - Obiektowe ¦rodowisko
62 Programistyczne Z) jest opartym o Pythona serwerem aplikacji do
63 tworzenia wysoko wydajnych, dynamicznych serwisów WWW, przy u¿yciu
64 u¿ytecznego i prostego modelu obiektowego skryptów oraz wysoko
65 wydajnej zintegrowanej obiektowej bazy danych.
66
67 %description -l pt_BR
68 Zope é uma aplicação baseada em Python, Open Source[tm], para
69 construção de sites dinâmicos, usando um modelo de scripting poderoso
70 e simples Para instalar o Zope, instale esse pacote e depois, ou o
71 Zope-server, para um servidor HTTP integrado simples, ou Zope-pcgi,
72 para uso com o Apache. Se você quiser instalar apenas algumas partes
73 do Zope, outros sub-pacotes estão disponíveis, e você deveria instalar
74 eles ao invés desse RPM.
75
76 %package -n python-zope
77 Summary:        Python packages developed as part of the Zope 3 project.
78 Summary(pl):    Modu³y pythona rozwijane w projekcie Zope 3.
79 Group:          Development/Tools
80 Obsoletes:      ZopeInterface
81 Provides:       ZopeInterface
82 Provides:       python-zope-cachedescriptors
83 Provides:       python-zope-component
84 Provides:       python-zope-configuration
85 Provides:       python-zope-deprecation
86 Provides:       python-zope-documenttemplate
87 Provides:       python-zope-event
88 Provides:       python-zope-exceptions
89 Provides:       python-zope-hookable
90 Provides:       python-zope-i18n
91 Provides:       python-zope-i18nmessageid
92 Provides:       python-zope-index
93 Provides:       python-zope-interface
94 Provides:       python-zope-modulealias
95 Provides:       python-zope-pagetemplate
96 Provides:       python-zope-proxy
97 Provides:       python-zope-publisher
98 Provides:       python-zope-schema
99 Provides:       python-zope-security
100 Provides:       python-zope-server
101 Provides:       python-zope-structuredtext
102 Provides:       python-zope-tal
103 Provides:       python-zope-tales
104 Provides:       python-zope-testing
105 Provides:       python-zope-thread
106
107 %description -n python-zope
108 The "zope" package is a pure namespace package holding packages developed as
109 part of the Zope 3 project.
110
111 Generally, the immediate subpackages of the "zope" package should be useful and
112 usable outside of the Zope application server.  Subpackages of the "zope"
113 package should have minimal interdependencies, although most depend on
114 "zope.interface".
115
116 %prep
117 %setup -q -n Zope-%{version}%{sub_ver}
118
119 %build
120 ./configure \
121         --prefix=%{zope_dir}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_sbindir}} \
128         $RPM_BUILD_ROOT{/etc/logrotate.d,/etc/sysconfig,/etc/rc.d/init.d} \
129         $RPM_BUILD_ROOT{/var/lib/zope3/main,/var/run/zope3,/var/log/zope3/main} \
130         $RPM_BUILD_ROOT%{_sysconfdir}/zope3/main
131         
132 python install.py -q install --skip-build --home "%{zope_dir}" --root "$RPM_BUILD_ROOT"
133 mv $RPM_BUILD_ROOT%{zope_dir}/lib/python/zope  $RPM_BUILD_ROOT%{py_sitedir}
134
135 find $RPM_BUILD_ROOT%{py_sitedir}/zope -name '*.txt' -o -name '*.cfg' | xargs rm
136
137 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/zope
138 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/zope
139
140 ln -sf %{zope_dir}/bin/mkzopeinstance $RPM_BUILD_ROOT%{_sbindir}/mkzope3instance
141 for f in zconfig zconfig_schema2html zopetest ; do
142         ln -sf %{zope_dir}/bin/"$f" $RPM_BUILD_ROOT%{_sbindir}/"$f"3
143 done
144 for f in mkzeoinst runzeo zdctl zdrun zeoctl zeopasswd ; do
145         ln -sf %{zope_dir}/bin/"$f".py $RPM_BUILD_ROOT%{_sbindir}/"$f"3
146 done
147
148 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/zope3
149 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/zope3
150 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/zope3
151
152 touch $RPM_BUILD_ROOT/var/log/zope3/main/event.log
153 touch $RPM_BUILD_ROOT/var/log/zope3/main/Z2.log
154
155
156 #install -d $RPM_BUILD_ROOT{/var/lib/zope/main,/var/run/zope,/var/log/zope/main} \
157 #       $RPM_BUILD_ROOT{/etc/logrotate.d,/etc/sysconfig,/etc/rc.d/init.d} \
158 #       $RPM_BUILD_ROOT{%{_sysconfdir}/zope/main,%{_sbindir}} \
159 #       $RPM_BUILD_ROOT%{zope_dir}/bin
160 #
161 #ln -sfn /usr/bin/python $RPM_BUILD_ROOT%{zope_dir}/bin/python
162 #
163 #%{__make} install \
164 #       INSTALL_FLAGS="--root $RPM_BUILD_ROOT"
165 #
166 #mv $RPM_BUILD_ROOT%{zope_dir}/bin/zpasswd.py $RPM_BUILD_ROOT%{_sbindir}/zpasswd
167 #mv $RPM_BUILD_ROOT%{zope_dir}/skel $RPM_BUILD_ROOT%{_sysconfdir}/zope
168 #mv $RPM_BUILD_ROOT{%{zope_dir}/import/*,%{_sysconfdir}/zope/skel/import}
169 #
170 #rm -rf $RPM_BUILD_ROOT%{zope_dir}/doc
171 #rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/zope/skel/log
172 #rm -f $RPM_BUILD_ROOT%{_sysconfdir}/zope/skel/bin/{runzope.bat,zopeservice.py}.in
173 #
174 #install %{SOURCE4} $RPM_BUILD_ROOT%{_sbindir}/mkzopeinstance
175 #install %{SOURCE5} $RPM_BUILD_ROOT%{_sbindir}/mkzeoinstance
176 #install %{SOURCE6} $RPM_BUILD_ROOT%{_sbindir}/runzope
177 #install %{SOURCE7} $RPM_BUILD_ROOT%{_sbindir}/zopectl
178 #install %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}/installzopeproduct
179 #
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %pre
185 %groupadd -g 112 zope
186 %useradd -u 112 -d /var/lib/zope/main -s /bin/false -c "Zope User" -g zope zope
187
188 %post
189 /sbin/chkconfig --add zope
190 if [ ! -f /etc/zope/main/zope.conf ] ; then
191         echo "Creating initial 'main' instance..."
192         /usr/sbin/mkzope3instance main zope:zope
193         echo "Instance created. Listening on 127.0.0.1:8080, initial user: 'zope' with password: 'zope'"
194 fi
195
196 %preun
197 if [ "$1" = "0" ]; then
198         if [ -f /var/lock/subsys/zope ]; then
199                 /etc/rc.d/init.d/zope stop
200         fi
201         /sbin/chkconfig --del zope
202 fi
203
204 %postun
205 if [ "$1" = "0" ] ; then
206         %userremove zope
207         %groupremove zope
208 fi
209
210 %files
211 %defattr(644,root,root,755)
212 %doc Zope/doc/*
213 %attr(754,root,root) /etc/rc.d/init.d/zope3
214 %attr(755,root,root) %{_sbindir}/*
215 %dir %{zope_dir}
216 %dir %{zope_dir}/bin
217 %attr(755,root,root) %{zope_dir}/bin/*
218 %{zope_dir}/include
219 %{zope_dir}/lib
220 %dir %{zope_dir}/zopeskel
221 %dir %{zope_dir}/zopeskel/bin
222 %attr(755,root,root) %{zope_dir}/zopeskel/bin/*
223 %{zope_dir}/zopeskel/etc
224 %{zope_dir}/zopeskel/lib
225 %{zope_dir}/zopeskel/log
226 %{zope_dir}/zopeskel/var
227 %{zope_dir}/zopeskel/README.txt
228 %{py_sitedir}/zope/app
229 %attr(775,zope,zope) %dir /var/run/zope3
230 %attr(775,zope,zope) %dir /var/lib/zope3
231 %attr(775,zope,zope) %dir /var/lib/zope3/main
232 %attr(775,zope,zope) %dir /var/log/zope3
233 %attr(775,zope,zope) %dir /var/log/zope3/main
234 %attr(640,root,root) %dir /etc/zope3
235 %attr(640,root,root) %dir /etc/zope3/main
236 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/zope3
237 %attr(640,root,root) /etc/sysconfig/zope3
238 %ghost /var/log/zope3/main/event.log
239 %ghost /var/log/zope3/main/Z2.log
240
241 %files -n python-zope
242 %defattr(644,root,root,755)
243 %{py_sitedir}/zope
244 %exclude %{py_sitedir}/zope/app
This page took 0.073114 seconds and 2 git commands to generate.