]> git.pld-linux.org Git - packages/Zope-zopeedit.git/blob - Zope-zopeedit.spec
- remove req.
[packages/Zope-zopeedit.git] / Zope-zopeedit.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    zopeedit
3 Summary:        Client-side helper application for ExternalEditor Zope product
4 Summary(pl):    Aplikacja pomocnicza dla ExternalEditor, produktu Zope
5 Name:           Zope-%{zope_subname}
6 Version:        0.7
7 Release:        2
8 License:        ZPL 2.0
9 Group:          Development/Tools
10 Source0:        http://zope.org/Members/Caseman/ExternalEditor/%{version}/%{zope_subname}-%{version}-src.tgz
11 # Source0-md5:  87fe890a7f7c2506db16142bc4789b38
12 URL:            http://zope.org/Members/Caseman/ExternalEditor/
13 BuildRequires:  python >= 2.2
14 %pyrequires_eq  python-modules
15 Requires:       python-tkinter
16 Requires:       Zope
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Client-side helper application for ExternalEditor Zope product
22
23 %description -l pl
24 Aplikacja pomocnicza dla ExternalEditor, produktu Zope
25
26 %prep
27 %setup -q -n %{zope_subname}-%{version}-src
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT{%{_datadir}/%{zope_subname},%{_mandir}/man1,%{_bindir}}
32
33 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
34 cp -af {Plugins,%{zope_subname}.py} $RPM_BUILD_ROOT%{_datadir}/%{zope_subname}
35
36 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{zope_subname}
37 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{zope_subname}
38
39 cat >$RPM_BUILD_ROOT%{_bindir}/%{zope_subname} <<EOF
40 #!/bin/sh
41
42 exec %{_bindir}/python %{_datadir}/%{zope_subname}/%{zope_subname}.pyo \$*
43 EOF
44
45 # sometimes .py needed
46 # rm -f $RPM_BUILD_ROOT%{_datadir}/%{zope_subname}/*.py
47 # rm -f $RPM_BUILD_ROOT%{_datadir}/%{zope_subname}/Plugins/*.py
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 if ! grep -q zopeedit /etc/mailcap ; then
54         echo "application/x-zope-edit; /usr/bin/zopeedit %%s ; test=test -x /usr/bin/zopeedit" >> /etc/mailcap
55 fi
56
57 %postun
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES.txt INSTALL-UNIX.txt LICENSE.txt README.txt
62 %attr(755,root,root) %{_bindir}/%{zope_subname}
63 %{_datadir}/%{zope_subname}
64 %{_mandir}/man1/*
This page took 0.069353 seconds and 3 git commands to generate.