]> git.pld-linux.org Git - packages/Zope-iHotfix.git/blob - Zope-iHotfix.spec
- upgraded to version 0.6.0
[packages/Zope-iHotfix.git] / Zope-iHotfix.spec
1
2 %define         zope_subname    iHotfix
3 Summary:        Dynamically applying several patches to Zope
4 Summary(pl):    Dodatek aplikuj±cy wiele poprawek dla Zope
5 Name:           Zope-%{zope_subname}
6 Version:        0.6.0
7 Release:        1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://www.ikaaro.org/download/ihotfix/%{zope_subname}-%{version}.tar.gz
11 # Source0-md5:  7c25676bcc2b24d595a5e74dd08bf03c
12 URL:            http://www.ikaaro.org/
13 Requires(post,postun):  /usr/sbin/installzopeproduct
14 Requires:       Zope >= 2.6
15 Requires:       python-itools >= 0.9.0
16 BuildRequires:  python
17 %pyrequires_eq  python-modules
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 It dynamically applies several patches to Zope.
23
24 %description -l pl
25 Dodatek aplikuj±cy wiele poprawek dla Zope.
26
27 %prep
28 %setup -q -n %{zope_subname}-%{version}
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
33
34 # should tests be included or not?
35 cp -af *.py version.txt $RPM_BUILD_ROOT%{_datadir}/%{name}
36
37 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
38 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
39
40 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
47 if [ -f /var/lock/subsys/zope ]; then
48         /etc/rc.d/init.d/zope restart >&2
49 fi
50
51 %postun
52 if [ "$1" = "0" ]; then
53         /usr/sbin/installzopeproduct -d %{zope_subname}
54         if [ -f /var/lock/subsys/zope ]; then
55                 /etc/rc.d/init.d/zope restart >&2
56         fi
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES.txt README.txt Changelog
62 %{_datadir}/%{name}
This page took 0.111401 seconds and 3 git commands to generate.