]> git.pld-linux.org Git - packages/Zope-iHotfix.git/blob - Zope-iHotfix.spec
- updated Source0 URL
[packages/Zope-iHotfix.git] / Zope-iHotfix.spec
1
2 %define         zope_subname    iHotfix
3 Summary:        Dynamically applying several patches to Zope
4 Summary(pl):    Dodatek aplikuj±cy wiele poprawek dla Zope
5 Name:           Zope-%{zope_subname}
6 Version:        0.7.0
7 Release:        1
8 License:        GPL
9 Group:          Development/Tools
10 Source0:        http://download.ikaaro.org/ihotfix/%{zope_subname}-%{version}.tar.gz
11 # Source0-md5:  07a438b14e550e6e37271f34e098bbd6
12 URL:            http://www.ikaaro.org/
13 BuildRequires:  python
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 Requires(post,postun):  /usr/sbin/installzopeproduct
16 Requires:       Zope >= 2.6
17 Requires:       python-itools >= 0.9.0
18 %pyrequires_eq  python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 It dynamically applies several patches to Zope.
24
25 %description -l pl
26 Dodatek aplikuj±cy wiele poprawek dla Zope.
27
28 %prep
29 %setup -q -n %{zope_subname}-%{version}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
34
35 # should tests be included or not?
36 cp -af *.py version.txt $RPM_BUILD_ROOT%{_datadir}/%{name}
37
38 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
39 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
40
41 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
48 %service -q zope restart
49
50 %postun
51 if [ "$1" = "0" ]; then
52         /usr/sbin/installzopeproduct -d %{zope_subname}
53         %service -q zope restart
54 fi
55
56 %files
57 %defattr(644,root,root,755)
58 %doc CHANGES.txt README.txt Changelog
59 %{_datadir}/%{name}
This page took 0.048102 seconds and 3 git commands to generate.