]> git.pld-linux.org Git - packages/Zope-iHotfix.git/blob - Zope-iHotfix.spec
048ee8491bcd514622eb919e1c6d8ba32eddf82d
[packages/Zope-iHotfix.git] / Zope-iHotfix.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         zope_subname    iHotfix
4 Summary:        Dynamically applying several patches to Zope
5 Summary(pl):    Dodatek aplikuj±cy wiele poprawek dla Zope
6 Name:           Zope-%{zope_subname}
7 Version:        0.3.0
8 Release:        2
9 License:        GPL
10 Group:          Development/Tools
11 Source0:        http://dl.sourceforge.net/lleu/%{zope_subname}-%{version}.tgz
12 # Source0-md5:  b058f9ee29b759ecddd06d481ab7731d
13 Patch0:         %{name}-loop.patch
14 URL:            http://sourceforge.net/projects/lleu/
15 BuildRequires:  python >= 2.2
16 Requires(post,postun):  /usr/sbin/installzopeproduct
17 %pyrequires_eq  python-modules
18 Requires:       Zope >= 2.6
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 It dynamically applies several patches to Zope.
24
25 %description -l pl
26 Dodatek aplikuj±cy wiele poprawek dla Zope.
27
28 %prep
29 %setup -q -n %{zope_subname}
30 %patch0 -p1
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
35
36 # should tests be included or not?
37 cp -af *.py $RPM_BUILD_ROOT%{_datadir}/%{name}
38
39 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
40 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
41
42 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
49 if [ -f /var/lock/subsys/zope ]; then
50         /etc/rc.d/init.d/zope restart >&2
51 fi
52
53 %postun
54 if [ "$1" = "0" ]; then
55         /usr/sbin/installzopeproduct -d %{zope_subname}
56         if [ -f /var/lock/subsys/zope ]; then
57                 /etc/rc.d/init.d/zope restart >&2
58         fi
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc TODO.txt
64 %{_datadir}/%{name}
This page took 0.054679 seconds and 2 git commands to generate.