]> git.pld-linux.org Git - packages/Zope-iHotfix.git/blame_incremental - Zope-iHotfix.spec
- tabs in preamble
[packages/Zope-iHotfix.git] / Zope-iHotfix.spec
... / ...
CommitLineData
1
2%define zope_subname iHotfix
3Summary: Dynamically applying several patches to Zope
4Summary(pl.UTF-8): Dodatek aplikujÄ…cy wiele poprawek dla Zope
5Name: Zope-%{zope_subname}
6Version: 0.7.0
7Release: 1
8License: GPL
9Group: Development/Tools
10Source0: http://download.ikaaro.org/ihotfix/%{zope_subname}-%{version}.tar.gz
11# Source0-md5: 07a438b14e550e6e37271f34e098bbd6
12URL: http://www.ikaaro.org/
13BuildRequires: python
14BuildRequires: rpmbuild(macros) >= 1.268
15Requires(post,postun): /usr/sbin/installzopeproduct
16Requires: Zope >= 2.6
17Requires: python-itools >= 0.9.0
18%pyrequires_eq python-modules
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23It dynamically applies several patches to Zope.
24
25%description -l pl.UTF-8
26Dodatek aplikujÄ…cy wiele poprawek dla Zope.
27
28%prep
29%setup -q -n %{zope_subname}-%{version}
30
31%install
32rm -rf $RPM_BUILD_ROOT
33install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
34
35# should tests be included or not?
36cp -af *.py version.txt $RPM_BUILD_ROOT%{_datadir}/%{name}
37
38%py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
39%py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
40
41# find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%post
47/usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
48%service -q zope restart
49
50%postun
51if [ "$1" = "0" ]; then
52 /usr/sbin/installzopeproduct -d %{zope_subname}
53 %service -q zope restart
54fi
55
56%files
57%defattr(644,root,root,755)
58%doc CHANGES.txt README.txt Changelog
59%{_datadir}/%{name}
This page took 0.063163 seconds and 4 git commands to generate.