]> git.pld-linux.org Git - packages/Zope-epoz.git/blob - Zope-epoz.spec
09eb24a1f7b50a48024cfa65aed8b708afea41a9
[packages/Zope-epoz.git] / Zope-epoz.spec
1 #
2 # TODO: 
3 #  - Please test in stable version of Zope
4 #  - On Zope 2.7.0beta3 this version make "connection refused" error
5 #
6 %include        /usr/lib/rpm/macros.python
7 %define         zope_subname    epoz
8 Summary:        epoz allows you to edit Zope or Plone-objects with a wysiwyg-editor
9 Summary(pl):    Dodatek do Zope lub Plone umo¿liwiaj±cy manipulacje na obiektach w trybie WYSIWYG
10 Name:           Zope-%{zope_subname}
11 Version:        1.0
12 Release:        1
13 License:        ZPL 2.0
14 Group:          Development/Tools
15 Source0:        http://dl.sourceforge.net/%{zope_subname}/%{zope_subname}-%{version}.tgz
16 # Source0-md5:  573fef5d349ea5cd54105f8dad8eee5d
17 URL:            http://sourceforge.net/projects/epoz/
18 %pyrequires_eq  python-modules
19 Requires:       Zope
20 Requires(post,postun):  /usr/sbin/installzopeproduct
21 Obsoletes:      Zope-Epoz
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 epoz allows you to edit Zope or Plone-objects with a wysiwyg-editor.
27
28 %description -l pl
29 Dodatek do Zope lub Plone umo¿liwiaj±cy manipulacje na obiektach w
30 trybie WYSIWYG.
31
32 %prep
33 %setup -q -n %{zope_subname}
34
35 %build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
40 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
41
42 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
43 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
44
45 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
46 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
53 if [ -f /var/lock/subsys/zope ]; then
54         /etc/rc.d/init.d/zope restart >&2
55 fi
56
57 %postun
58 if [ "$1" = "0" ]; then
59         /usr/sbin/installzopeproduct -d %{zope_subname}
60         if [ -f /var/lock/subsys/zope ]; then
61                 /etc/rc.d/init.d/zope restart >&2
62         fi
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc doc
68 %{_datadir}/%{name}
This page took 0.062278 seconds and 2 git commands to generate.