]> git.pld-linux.org Git - packages/Zope-ZMySQLDA.git/blob - Zope-ZMySQLDA.spec
- pl translations, simplified %%prep
[packages/Zope-ZMySQLDA.git] / Zope-ZMySQLDA.spec
1
2 %define prod_name ZMySQLDA
3
4 Summary:        Zope MySQL database adapter
5 Summary(pl):    Interfejs bazy danych MySQL do Zope
6 Name:           Zope-%{prod_name}
7 Version:        2.0.8
8 Release:        1
9 License:        ZPL
10 Source0:        http://www.zope.org/Members/adustman/Products/%{prod_name}/%{prod_name}-%{version}.tar.gz
11 URL:            http://www.zope.org/Members/adustman/Products/%{prod_name}
12 Group:          Development/Languages/Python
13 Group(de):      Entwicklung/Sprachen/Python
14 Group(pl):      Programowanie/Jêzyki/Python
15 Requires:       Zope
16 Requires:       python-MySQLdb
17 BuildRequires:  python-MySQLdb
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
22 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
23
24 %define zope_dir           %{_libdir}/zope
25 %define zope_productsdir   %{zope_dir}/Products         
26
27 %description
28 Zope MySQL database adapter. 
29
30 %description -l pl
31 Interfejs bazy danych MySQL do Zope.
32
33 %prep
34 %setup -q -c
35 mv -f lib/python/Products/%{prod_name}/* .
36 rm -rf lib
37
38 %build
39 %{python_compile}
40 %{python_compile_opt}
41
42 find . -name \*.py | xargs -r rm -f
43 gzip -9nf *.txt
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
48
49 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
50 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc *.gz 
58 %{zope_productsdir}/%{prod_name}
This page took 0.049891 seconds and 3 git commands to generate.