]> git.pld-linux.org Git - packages/Zope-ZMySQLDA.git/blob - Zope-ZMySQLDA.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/Zope-ZMySQLDA.git] / Zope-ZMySQLDA.spec
1
2 %define prod_name ZMySQLDA
3
4 Summary:        Zope MySQL database adapter
5 Summary(pl):    Interfejs bazy danych MySQL do Zope
6 Name:           Zope-%{prod_name}
7 Version:        2.0.8
8 Release:        1
9 License:        ZPL
10 Source0:        http://www.zope.org/Members/adustman/Products/%{prod_name}/%{prod_name}-%{version}.tar.gz
11 URL:            http://www.zope.org/Members/adustman/Products/%{prod_name}
12 Group:          Development/Languages/Python
13 Requires:       Zope
14 Requires:       python-MySQLdb
15 BuildRequires:  python-MySQLdb
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
20 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
21
22 %define zope_dir           %{_libdir}/zope
23 %define zope_productsdir   %{zope_dir}/Products         
24
25 %description
26 Zope MySQL database adapter. 
27
28 %description -l pl
29 Interfejs bazy danych MySQL do Zope.
30
31 %prep
32 %setup -q -c
33 mv -f lib/python/Products/%{prod_name}/* .
34 rm -rf lib
35
36 %build
37 %{python_compile}
38 %{python_compile_opt}
39
40 find . -name \*.py | xargs -r rm -f
41 gzip -9nf *.txt
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
46
47 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
48 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc *.gz 
56 %{zope_productsdir}/%{prod_name}
This page took 0.054404 seconds and 3 git commands to generate.