]> git.pld-linux.org Git - packages/Zope-ZMySQLDA.git/blob - Zope-ZMySQLDA.spec
91b8aed2ae915fc3a520d48eaa539652033f4aaf
[packages/Zope-ZMySQLDA.git] / Zope-ZMySQLDA.spec
1
2 %define prod_name ZMySQLDA
3
4 Summary:        Zope MySQL database adapter
5 Summary(pl):    Interfejs bazy danych MySQL do Zope
6 Name:           Zope-%{prod_name}
7 Version:        2.0.8
8 Release:        1
9 License:        ZPL
10 Source0:        http://www.zope.org/Members/adustman/Products/ZMySQLDA/%{prod_name}-%{version}.tar.gz
11 # Source0-md5:  74332272e53b13c6b19d3185d575699c
12 URL:            http://www.zope.org/Members/adustman/Products/ZMySQLDA/
13 Group:          Development/Languages/Python
14 Requires:       Zope
15 Requires:       python-MySQLdb
16 BuildRequires:  python-MySQLdb
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
21 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
22
23 %define zope_dir           %{_libdir}/zope
24 %define zope_productsdir   %{zope_dir}/Products
25
26 %description
27 Zope MySQL database adapter.
28
29 %description -l pl
30 Interfejs bazy danych MySQL do Zope.
31
32 %prep
33 %setup -q -c
34 mv -f lib/python/Products/%{prod_name}/* .
35 rm -rf lib
36
37 %build
38 %{python_compile}
39 %{python_compile_opt}
40
41 find . -name \*.py | xargs -r rm -f
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
46
47 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
48 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc *.txt
56 %{zope_productsdir}/%{prod_name}
This page took 0.043305 seconds and 2 git commands to generate.