]> git.pld-linux.org Git - packages/Zope-ZMySQLDA.git/blob - Zope-ZMySQLDA.spec
- new from scratch
[packages/Zope-ZMySQLDA.git] / Zope-ZMySQLDA.spec
1
2 %define prod_name ZMySQLDA
3
4 Summary:        Zope MySQL database adapter. 
5 Name:           Zope-%{prod_name}
6 Version:        2.0.8
7 Release:        1
8 License:        ZPL
9 Source0:        http://www.zope.org/Members/adustman/Products/%{prod_name}/%{prod_name}-%{version}.tar.gz
10 URL:            http://www.zope.org/Members/adustman/Products/%{prod_name}
11 Group:          Development/Languages/Python
12 Group(de):      Entwicklung/Sprachen/Python
13 Group(pl):      Programowanie/Jêzyki/Python
14 Requires:       Zope
15 Requires:       python-MySQLdb
16 BuildRequires:  python-MySQLdb
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
21 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
22
23 %define zope_dir           %{_libdir}/zope
24 %define zope_productsdir   %{zope_dir}/Products         
25
26 %description
27 Zope MySQL database adapter. 
28
29 %prep
30 %setup -q -c -a 0 -n %{name}-%{version}
31 mv lib/python/Products/%{prod_name}/* .
32 rm -rf lib
33
34 %build
35 %{python_compile}
36 %{python_compile_opt}
37
38 find . -name \*.py | xargs -r rm -f
39 gzip -9nf *.txt
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
44
45 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
46 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc *.gz 
54 %{zope_productsdir}/%{prod_name}
This page took 0.057151 seconds and 3 git commands to generate.