]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- tabs in preamble
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1
2 %define         zope_subname    CMFPlone
3 Summary:        Free and open source Content Management System based on Zope and CMF
4 Summary(pl.UTF-8):      Darmowy i otwarty system zarządzania treścią oparty na Zope i CMF
5 Name:           Zope-%{zope_subname}
6 Version:        2.1.2
7 Release:        1
8 License:        Zope Public License (ZPL), GPL
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/plone/Plone-%{version}.tar.gz
11 # Source0-md5:  72989893b6cd012a5d26eccc5aa2576b
12 URL:            http://www.plone.org/
13 BuildRequires:  python
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 %pyrequires_eq  python-modules
16 Requires(post,postun):  /usr/sbin/installzopeproduct
17 Requires:       Zope >= 2.7.7
18 Requires:       Zope-BTreeFolder2 >= 1.0.2
19 Requires:       Zope-CMF >= 1:1.5.5
20 Requires:       Zope-CMFQuickInstallerTool >= 1.5.7
21 Requires:       Zope-ExternalEditor >= 0.9.1
22 Requires:       Zope-Formulator >= 1.6.2
23 Requires:       Zope-GroupUserFolder >= 1:3.5
24 Requires:       Zope-PlacelessTranslationService >= 1.2.1
25 Requires:       Zope-PloneLanguageTool >= 0.9
26 Requires:       Zope-archetypes >= 1.3.7
27 Requires:       Zope-kupu >= 1.3.3
28 Requires:       i18ndude
29 Requires:       python-Imaging
30 Obsoletes:      Plone
31 Obsoletes:      Zope-PortalTransforms
32 Conflicts:      CMF
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Plone is a free, open source Content Management System. The focus of
38 Plone is to provide value at every level of an organization. It comes
39 with a workflow engine, pre-configured security and roles, a set of
40 content types and multi-lingual support. There are many developers,
41 writers and testers from all over the world, contributing to Plone
42 everyday. Plone is based on the Content Management Framework.
43
44 %description -l pl.UTF-8
45 Plone jest darmowym systemem zarządzania informacją z otwartym kodem
46 źródłowym. Głównym celem Plone jest możliwość dzielenia się informacją
47 na każdym poziomie dostępu. Jest to "silnik" serwisu umożliwiający
48 pracę z wieloma językami, z wstępną konfiguracją uwzględniającą
49 zabezpieczenia serwisu. Plone działa w zestawie z CMF, Zope i
50 Pythonem.
51
52 %prep
53 %setup -q -n Plone-%{version}
54 # remove dirs - additional packages!
55 # ExternalEditor
56 rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder,Archetypes,generator,validation}
57 rm -rf {PloneLanguageTool,kupu,MimetypesRegistry}
58 rm -rf {CMFActionIcons,CMFSetup,CMFUid}
59 rm -rf {CMFCalendar,CMFCore,CMFDefault,CMFTopic,DCWorkflow,PortalTransforms,Epoz}
60 rm -rf {ExternalEditor,PlacelessTranslationService}
61 find . -type d -name debian | xargs rm -rf
62
63 %build
64 mkdir docs docs/CMFPlone docs/CMFFormController docs/PloneErrorReporting
65 mv -f CMFPlone/{CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,UPGRADE.txt,LICENSE.txt} docs/CMFPlone
66 rm -rf CMFPlone/LICENSE.GPL
67 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
68 rm -rf CMFPlone/docs
69 mv -f PloneErrorReporting/{ChangeLog,README.txt} docs/PloneErrorReporting
70 rm -rf PloneErrorReporting/LICENSE.txt
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
75 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
76
77 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
78 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
79
80 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post
86 for p in ATContentTypes ATReferenceBrowserWidget CMFDynamicViewFTI CMFFormController CMFPlone ExtendedPathIndex; do
87         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
88 done
89 for p in PloneErrorReporting PloneTranslations ResourceRegistries SecureMailHost; do
90         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
91 done
92 %service -q zope restart
93
94 %postun
95 if [ "$1" = "0" ]; then
96         for p in ATContentTypes ATReferenceBrowserWidget CMFDynamicViewFTI CMFFormController CMFPlone ExtendedPathIndex; do
97                 /usr/sbin/installzopeproduct -d $p
98         done
99         for p in PloneErrorReporting PloneTranslations ResourceRegistries SecureMailHost; do
100                 /usr/sbin/installzopeproduct -d $p
101         done
102         %service -q zope restart
103 fi
104
105 %files
106 %defattr(644,root,root,755)
107 %doc docs/*
108 %{_datadir}/%{name}
This page took 0.113147 seconds and 3 git commands to generate.