]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blame - Zope-CMFPlone.spec
- tabs in preamble
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
CommitLineData
4c279d0a 1
d853f52e 2%define zope_subname CMFPlone
dc339433 3Summary: Free and open source Content Management System based on Zope and CMF
4b64f9bc 4Summary(pl.UTF-8): Darmowy i otwarty system zarządzania treścią oparty na Zope i CMF
d853f52e 5Name: Zope-%{zope_subname}
4dfafc67 6Version: 2.1.2
7Release: 1
b3adcd95 8License: Zope Public License (ZPL), GPL
9Group: Networking/Daemons
66f8793c 10Source0: http://dl.sourceforge.net/plone/Plone-%{version}.tar.gz
4dfafc67 11# Source0-md5: 72989893b6cd012a5d26eccc5aa2576b
b3adcd95 12URL: http://www.plone.org/
e088e47b 13BuildRequires: python
66f8793c 14BuildRequires: rpmbuild(macros) >= 1.268
b3adcd95 15%pyrequires_eq python-modules
66f8793c 16Requires(post,postun): /usr/sbin/installzopeproduct
f8421eaf 17Requires: Zope >= 2.7.7
18Requires: Zope-BTreeFolder2 >= 1.0.2
66f8793c 19Requires: Zope-CMF >= 1:1.5.5
4dfafc67 20Requires: Zope-CMFQuickInstallerTool >= 1.5.7
f8421eaf 21Requires: Zope-ExternalEditor >= 0.9.1
65499ef4 22Requires: Zope-Formulator >= 1.6.2
4dfafc67 23Requires: Zope-GroupUserFolder >= 1:3.5
f8421eaf 24Requires: Zope-PlacelessTranslationService >= 1.2.1
4dfafc67 25Requires: Zope-PloneLanguageTool >= 0.9
66f8793c
ER
26Requires: Zope-archetypes >= 1.3.7
27Requires: Zope-kupu >= 1.3.3
28Requires: i18ndude
29Requires: python-Imaging
d853f52e 30Obsoletes: Plone
f35e1478 31Obsoletes: Zope-PortalTransforms
260eb64a 32Conflicts: CMF
66f8793c
ER
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
b3adcd95 35
36%description
37Plone is a free, open source Content Management System. The focus of
38Plone is to provide value at every level of an organization. It comes
39with a workflow engine, pre-configured security and roles, a set of
40content types and multi-lingual support. There are many developers,
41writers and testers from all over the world, contributing to Plone
42everyday. Plone is based on the Content Management Framework.
43
5bcc339e
JR
44%description -l pl.UTF-8
45Plone jest darmowym systemem zarządzania informacją z otwartym kodem
46źródłowym. Głównym celem Plone jest możliwość dzielenia się informacją
47na każdym poziomie dostępu. Jest to "silnik" serwisu umożliwiający
48pracę z wieloma językami, z wstępną konfiguracją uwzględniającą
49zabezpieczenia serwisu. Plone działa w zestawie z CMF, Zope i
b3adcd95 50Pythonem.
51
52%prep
17676b50 53%setup -q -n Plone-%{version}
b3adcd95 54# remove dirs - additional packages!
fee346e3 55# ExternalEditor
7c6b2880 56rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder,Archetypes,generator,validation}
f8421eaf 57rm -rf {PloneLanguageTool,kupu,MimetypesRegistry}
58rm -rf {CMFActionIcons,CMFSetup,CMFUid}
8a5d046f 59rm -rf {CMFCalendar,CMFCore,CMFDefault,CMFTopic,DCWorkflow,PortalTransforms,Epoz}
8cf314b8 60rm -rf {ExternalEditor,PlacelessTranslationService}
151dc08c 61find . -type d -name debian | xargs rm -rf
b3adcd95 62
151dc08c 63%build
8cf314b8 64mkdir docs docs/CMFPlone docs/CMFFormController docs/PloneErrorReporting
151dc08c 65mv -f CMFPlone/{CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,UPGRADE.txt,LICENSE.txt} docs/CMFPlone
151dc08c 66rm -rf CMFPlone/LICENSE.GPL
b3adcd95 67mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
68rm -rf CMFPlone/docs
7c6b2880 69mv -f PloneErrorReporting/{ChangeLog,README.txt} docs/PloneErrorReporting
70rm -rf PloneErrorReporting/LICENSE.txt
b3adcd95 71
72%install
73rm -rf $RPM_BUILD_ROOT
d853f52e
JK
74install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
75cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
b3adcd95 76
d853f52e
JK
77%py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
78%py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
b3adcd95 79
d853f52e 80rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
b3adcd95 81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
094c5548 86for p in ATContentTypes ATReferenceBrowserWidget CMFDynamicViewFTI CMFFormController CMFPlone ExtendedPathIndex; do
d853f52e
JK
87 /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
88done
094c5548 89for p in PloneErrorReporting PloneTranslations ResourceRegistries SecureMailHost; do
f8421eaf 90 /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
66f8793c
ER
91done
92%service -q zope restart
b3adcd95 93
94%postun
d853f52e 95if [ "$1" = "0" ]; then
094c5548 96 for p in ATContentTypes ATReferenceBrowserWidget CMFDynamicViewFTI CMFFormController CMFPlone ExtendedPathIndex; do
f8421eaf 97 /usr/sbin/installzopeproduct -d $p
98 done
094c5548 99 for p in PloneErrorReporting PloneTranslations ResourceRegistries SecureMailHost; do
d853f52e
JK
100 /usr/sbin/installzopeproduct -d $p
101 done
66f8793c 102 %service -q zope restart
b3adcd95 103fi
104
105%files
106%defattr(644,root,root,755)
107%doc docs/*
d853f52e 108%{_datadir}/%{name}
This page took 0.138156 seconds and 4 git commands to generate.