]> git.pld-linux.org Git - packages/ZoneAdmin.git/blame_incremental - ZoneAdmin.spec
- updated to 0.2-beta1
[packages/ZoneAdmin.git] / ZoneAdmin.spec
... / ...
CommitLineData
1Summary: A Web-based administration interface for powerDNS
2Name: ZoneAdmin
3Version: 0.2
4Release: 0.1
5License: GPL
6Group: Applications/WWW
7Source0: http://dl.sourceforge.net/zoneadmin/%{name}-%{version}-beta1.tar.gz
8# Source0-md5: a848e14d947d41734d8a23d72d0196da
9URL: http://open.megabit.net/index.php?section=pro_home&project=ZoneAdmin
10BuildRequires: rpmbuild(macros) >= 1.268
11Requires: Smarty >= 2.6.18-2
12Requires: webapps
13Requires: webserver(php)
14%if %{with trigger}
15Requires(triggerpostun): sed >= 4.0
16%endif
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define _webapps /etc/webapps
21%define _webapp %{name}
22%define _smartyplugindir /usr/share/php/Smarty/plugins
23%define _sysconfdir %{_webapps}/%{_webapp}
24%define _appdir %{_datadir}/%{_webapp}
25
26%description
27ZoneAdmin is a Web interface for the powerDNS name server using the
28MySQL backend. It allows you to manage existing zones and add, remove,
29and alter new ones, supports on-the-fly input validation, and allows
30comments per zone and per record. Furthermore, it keeps a detailed
31history of changes and allows you to temporary enable or disable zones
32without having to remove them completely. New zones can use templates
33that contain predefined records. It is designed to be used with one of
34Apache's authentication methods.
35
36%prep
37%setup -q -n %{name}-%{version}-beta1
38
39mkdir smarty-plugins
40mv \
41lib/Smarty/plugins/block.t.php \
42lib/Smarty/plugins/function.{bankaccount,handle,number,size,sum,tip}.php \
43lib/Smarty/plugins/modifier.{money_format,striphtml,to_words}.php \
44 smarty-plugins
45rm -rf lib/Smarty
46
47cat > apache.conf <<'EOF'
48Alias /%{name} %{_appdir}
49<Directory %{_appdir}>
50 Allow from all
51</Directory>
52EOF
53
54rm -rf $RPM_BUILD_ROOT
55install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
56
57install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
58install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
59install *.php $RPM_BUILD_ROOT%{_appdir}
60cp -a {contrib,img,includes,lang,templates_c,tpl} $RPM_BUILD_ROOT%{_appdir}
61mv $RPM_BUILD_ROOT%{_appdir}/includes/config.php.dist $RPM_BUILD_ROOT%{_sysconfdir}/config.php
62ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/includes/config.php
63
64%triggerin -- apache1 < 1.3.37-3, apache1-base
65%webapp_register apache %{_webapp}
66
67%triggerun -- apache1 < 1.3.37-3, apache1-base
68%webapp_unregister apache %{_webapp}
69
70%triggerin -- apache < 2.2.0, apache-base
71%webapp_register httpd %{_webapp}
72
73%triggerun -- apache < 2.2.0, apache-base
74%webapp_unregister httpd %{_webapp}
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
81%dir %attr(750,root,http) %{_sysconfdir}
82%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
83%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
84%attr(660,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
85%{_appdir}/*.php
86%dir %{_appdir}/contrib
87%{_appdir}/contrib/*.php
88%{_appdir}/contrib/*.sql
89%dir %{_appdir}/img
90%{_appdir}/img/*.gif
91%{_appdir}/img/*.png
92%dir %{_appdir}/includes
93%{_appdir}/includes/*.php
94%dir %{_appdir}/includes/smarty/libs/
95%{_appdir}/includes/smarty/libs/*.php
96%{_appdir}/includes/smarty/libs/*.tpl
97%dir %{_appdir}/includes/smarty/libs/internals
98%{_appdir}/includes/smarty/libs/internals/*.php
99%dir %{_appdir}/includes/smarty/libs/plugins
100%{_appdir}/includes/smarty/libs/plugins/*.php
101%dir %{_appdir}/includes/smarty_plugins
102%{_appdir}/includes/smarty_plugins/*.php
103%dir %{_appdir}/lang
104%{_appdir}/lang/*.conf
105%dir %{_appdir}/templates_c
106%dir %{_appdir}/tpl/Boxes
107%{_appdir}/tpl/Boxes/*.css
108%{_appdir}/tpl/Boxes/*.js
109%{_appdir}/tpl/Boxes/*.tpl
110%dir %{_appdir}/tpl/Boxes/img
111%{_appdir}/tpl/Boxes/img/*.jpg
112%{_appdir}/tpl/Boxes/img/*.gif
113%dir %attr(770,root,http) %{_appdir}/templates_c
This page took 0.065843 seconds and 4 git commands to generate.