]> git.pld-linux.org Git - packages/ZendStudioServer.git/blob - ZendStudioServer.spec
- drop no_install_post_strip (not reasoned)
[packages/ZendStudioServer.git] / ZendStudioServer.spec
1 Summary:        ZendStudioServer - server management tools for PHP based Web servers
2 Summary(pl.UTF-8):      ZendStudioServer - narzędzia zarządzające dla serwerów WWW opartych na PHP
3 Name:           ZendStudioServer
4 Version:        5.1.0a
5 Release:        0.1
6 Epoch:          0
7 License:        Zend Studio License
8 Group:          Applications
9 Source0:        http://downloads.zend.com/studio/5.1.0/%{name}-%{version}-linux-glibc21-i386.tar.gz
10 # NoSource0-md5:        99672eec3502fb0aa6d779cc66333772
11 NoSource:       0
12 Source1:        http://downloads.zend.com/studio/5.1.0/%{name}-%{version}-linux-glibc23-x86_64.tar.gz
13 # NoSource1-md5:        a7ddb3b964fe0c1746b0f7b8a5093423
14 NoSource:       1
15 URL:            http://downloads.zend.com/studio/5.1.0/
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 BuildRequires:  tar >= 1:1.15.1
18 # circular dependency, so ones upgraded are forced to choose php and
19 # ones that want to install specific for specific version need not to
20 # install ZendStudioServer separately
21 Requires:       %{name}(php) = %{version}-%{release}
22 ExclusiveArch:  %{ix86} %{x8664}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _datadir        %{_prefix}/share/Zend
26
27 %description
28 Includes server management tools that manage PHP based Web servers.
29 This module makes installation and integration seamless while
30 simplifying PHP and remote debugging configurations and security
31 maintenance.
32
33 %description -l pl.UTF-8
34 Ten pakiet zawiera narzędzia zarządzające serwerem dla serwerów WWW
35 opartych na PHP. Ten moduł pozwala na przezroczystą instalację i
36 integrację jednocześnie upraszczając konfiguracje PHP ze zdalną
37 diagnostyką oraz zarządzanie bezpieczeństwem.
38
39 %package -n php4-%{name}
40 Summary:        ZendStudioServer for PHP 4.x
41 Summary(pl.UTF-8):      ZendStudioServer dla PHP 4.x
42 Group:          Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       php4-ZendOptimizer
45 Provides:       %{name}(php) = %{version}-%{release}
46
47 %description -n php4-%{name}
48 ZendStudioServer for PHP 4.x.
49
50 %description -n php4-%{name} -l pl.UTF-8
51 ZendStudioServer dla PHP 4.x.
52
53 %package -n php-%{name}
54 Summary:        ZendStudioServer for PHP 5.x
55 Summary(pl.UTF-8):      ZendStudioServer dla PHP 5.x
56 Group:          Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       php-ZendOptimizer
59 Provides:       %{name}(php) = %{version}-%{release}
60
61 %description -n php-%{name}
62 ZendStudioServer for PHP 5.x.
63
64 %description -n php-%{name} -l pl.UTF-8
65 ZendStudioServer dla PHP 5.x.
66
67 %prep
68 %setup -qcT
69 %ifarch %{x8664}
70 tar --strip-components=1 -xzf %{SOURCE1}
71 %else
72 tar --strip-components=1 -xzf %{SOURCE0}
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/Zend/lib/tools,%{_datadir}/htdocs}
78
79 cd data
80 install dummy.php $RPM_BUILD_ROOT%{_datadir}/htdocs
81 cp -a gui/* $RPM_BUILD_ROOT%{_datadir}/htdocs
82 install runas $RPM_BUILD_ROOT%{_bindir}
83 install ini_modifier  $RPM_BUILD_ROOT%{_sbindir}
84
85 install change_gui_password.php $RPM_BUILD_ROOT%{_libdir}/Zend/lib/tools
86 cp -a phplib $RPM_BUILD_ROOT%{_libdir}/Zend/lib/tools
87
88 for a in *_comp; do
89         d=$(basename $a _comp | tr _ .)
90         install -D $a/ZendDebugger.so $RPM_BUILD_ROOT%{_libdir}/Zend/lib/Debugger-%{version}/php-$d/ZendDebugger.so
91 done
92 for a in *_comp/TS; do
93         d=$(basename $(dirname $a) _comp | tr _ .)
94         install -D $a/ZendDebugger.so $RPM_BUILD_ROOT%{_libdir}/Zend/lib/Debugger_TS-%{version}/php-$d/ZendDebugger.so
95 done
96
97 cat > zend.ini <<EOF
98 [Zend]
99 studio.install_dir=%{_datadir}
100 zend_debugger.expose_remotely=allowed_hosts
101 zend_debugger.httpd_uid=51
102 zend_gui_password=69fb46f4c18463dd25002aeffc0257d1
103 zend_gui.ini_modifier=%{_sbindir}/ini_modifier
104 zend_debugger.allow_hosts=127.0.0.1/32,192.168.2.0/24
105 zend_debugger.allow_tunnel=127.0.0.1/32
106 zend_debugger.deny_hosts=
107 zend_root_dir=%{_datadir}
108 EOF
109
110 cat <<'EOF' > pack.ini
111 ; ZendStudioServer package settings. Overwritten with each upgrade.
112 ; if you need to add options, edit %{name}.ini instead
113 [Zend]
114 zend_extension_manager.debug_server=%{_libdir}/Zend/lib/Debugger-%{version}
115 zend_extension_manager.debug_server_ts=%{_libdir}/Zend/lib/Debugger_TS-%{version}
116 EOF
117
118 install -d $RPM_BUILD_ROOT%{_sysconfdir}/php{,4}/conf.d
119 install zend.ini $RPM_BUILD_ROOT/etc/php4/conf.d/%{name}.ini
120 install zend.ini $RPM_BUILD_ROOT/etc/php/conf.d/%{name}.ini
121 install pack.ini $RPM_BUILD_ROOT/etc/php4/conf.d/%{name}_pack.ini
122 install pack.ini $RPM_BUILD_ROOT/etc/php/conf.d/%{name}_pack.ini
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %preun -n php4-%{name}
128 if [ "$1" = "0" ]; then
129         %php4_webserver_restart
130 fi
131
132 %post -n php4-%{name}
133 %php4_webserver_restart
134
135 %preun -n php-%{name}
136 if [ "$1" = "0" ]; then
137         %php_webserver_restart
138 fi
139
140 %post -n php-%{name}
141 %php_webserver_restart
142
143 %files
144 %defattr(644,root,root,755)
145 %doc README* LICENSE LICENSE-PHP
146 %attr(755,root,root) %{_bindir}/*
147 %attr(755,root,root) %{_sbindir}/*
148
149 %dir %{_libdir}/Zend/lib/Debugger-%{version}
150 %dir %{_libdir}/Zend/lib/Debugger-%{version}/php-*
151 %dir %{_libdir}/Zend/lib/Debugger_TS-%{version}
152 %dir %{_libdir}/Zend/lib/Debugger_TS-%{version}/php-*
153 %attr(755,root,root) %{_libdir}/Zend/lib/Debugger-%{version}/php-*/ZendDebugger.so
154 %attr(755,root,root) %{_libdir}/Zend/lib/Debugger_TS-%{version}/php-*/ZendDebugger.so
155 %{_libdir}/Zend/lib/tools
156
157 # html documents
158 %{_datadir}
159
160 %files -n php4-%{name}
161 %defattr(644,root,root,755)
162 %config(noreplace) %verify(not md5 mtime size) /etc/php4/conf.d/%{name}.ini
163 %config %verify(not md5 mtime size) /etc/php4/conf.d/%{name}_pack.ini
164
165 %files -n php-%{name}
166 %defattr(644,root,root,755)
167 %config(noreplace) %verify(not md5 mtime size) /etc/php/conf.d/%{name}.ini
168 %config %verify(not md5 mtime size) /etc/php/conf.d/%{name}_pack.ini
This page took 0.072714 seconds and 3 git commands to generate.