]> git.pld-linux.org Git - packages/ZendStudioServer.git/blob - ZendStudioServer.spec
5562945a5a9f41a965579c788bf4f04a0b7ed0c3
[packages/ZendStudioServer.git] / ZendStudioServer.spec
1 Summary:        ZendStudioServer - server management tools for PHP based Web servers
2 Summary(pl):    ZendStudioServer - narzêdzia zarz±dzaj±ce dla serwerów WWW opartych na PHP
3 Name:           ZendStudioServer
4 Version:        5.1.0a
5 Release:        0.1
6 Epoch:          0
7 License:        Zend Studio License
8 Group:          Applications
9 Source0:        http://downloads.zend.com/studio/5.1.0/%{name}-%{version}-linux-glibc21-i386.tar.gz
10 # NoSource0-md5:        99672eec3502fb0aa6d779cc66333772
11 NoSource:       0
12 Source1:        http://downloads.zend.com/studio/5.1.0/%{name}-%{version}-linux-glibc23-x86_64.tar.gz
13 # NoSource1-md5:        a7ddb3b964fe0c1746b0f7b8a5093423
14 NoSource:       1
15 URL:            http://downloads.zend.com/studio/5.1.0/
16 BuildRequires:  tar >= 1:1.15.1
17 # circular dependency, so ones upgraded are forced to choose php and
18 # ones that want to install specific for specific version need not to
19 # install ZendStudioServer separately
20 Requires:       %{name}(php) = %{version}-%{release}
21 ExclusiveArch:  %{ix86} %{x8664}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _datadir        %{_prefix}/share/Zend
25 %define         no_install_post_strip           1
26 %define         no_install_post_chrpath         1
27
28 %description
29 Includes server management tools that manage PHP based Web servers.
30 This module makes installation and integration seamless while
31 simplifying PHP and remote debugging configurations and security
32 maintenance.
33
34 %description -l pl
35 Ten pakiet zawiera narzêdzia zarz±dzaj±ce serwerem dla serwerów WWW
36 opartych na PHP. Ten modu³ pozwala na przezroczyst± instalacjê i
37 integracjê jednocze¶nie upraszczaj±c konfiguracje PHP ze zdaln±
38 diagnostyk± oraz zarz±dzanie bezpieczeñstwem.
39
40 %package -n php4-%{name}
41 Summary:        ZendStudioServer for PHP 4.x
42 Summary(pl):    ZendStudioServer dla PHP 4.x
43 Group:          Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       php4-ZendOptimizer
46 Provides:       %{name}(php) = %{version}-%{release}
47
48 %description -n php4-%{name}
49 ZendStudioServer for PHP 4.x.
50
51 %description -n php4-%{name} -l pl
52 ZendStudioServer dla PHP 4.x.
53
54 %package -n php-%{name}
55 Summary:        ZendStudioServer for PHP 5.x
56 Summary(pl):    ZendStudioServer dla PHP 5.x
57 Group:          Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       php-ZendOptimizer
60 Provides:       %{name}(php) = %{version}-%{release}
61
62 %description -n php-%{name}
63 ZendStudioServer for PHP 5.x.
64
65 %description -n php-%{name} -l pl
66 ZendStudioServer dla PHP 5.x.
67
68 %prep
69 %setup -qcT
70 %ifarch %{x8664}
71 tar --strip-components=1 -xzf %{SOURCE1}
72 %else
73 tar --strip-components=1 -xzf %{SOURCE0}
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/Zend/lib/tools,%{_datadir}/htdocs}
79
80 cd data
81 install dummy.php $RPM_BUILD_ROOT%{_datadir}/htdocs
82 cp -a gui/* $RPM_BUILD_ROOT%{_datadir}/htdocs
83 install runas $RPM_BUILD_ROOT%{_bindir}
84 install ini_modifier  $RPM_BUILD_ROOT%{_sbindir}
85
86 install change_gui_password.php $RPM_BUILD_ROOT%{_libdir}/Zend/lib/tools
87 cp -a phplib $RPM_BUILD_ROOT%{_libdir}/Zend/lib/tools
88
89 for a in *_comp; do
90         d=$(basename $a _comp | tr _ .)
91         install -D $a/ZendDebugger.so $RPM_BUILD_ROOT%{_libdir}/Zend/lib/Debugger-%{version}/php-$d/ZendDebugger.so
92 done
93 for a in *_comp/TS; do
94         d=$(basename $(dirname $a) _comp | tr _ .)
95         install -D $a/ZendDebugger.so $RPM_BUILD_ROOT%{_libdir}/Zend/lib/Debugger_TS-%{version}/php-$d/ZendDebugger.so
96 done
97
98 cat > zend.ini <<EOF
99 [Zend]
100 studio.install_dir=%{_datadir}
101 zend_debugger.expose_remotely=allowed_hosts
102 zend_debugger.httpd_uid=51
103 zend_gui_password=69fb46f4c18463dd25002aeffc0257d1
104 zend_gui.ini_modifier=%{_sbindir}/ini_modifier
105 zend_debugger.allow_hosts=127.0.0.1/32,192.168.2.0/24
106 zend_debugger.allow_tunnel=127.0.0.1/32
107 zend_debugger.deny_hosts=
108 zend_root_dir=%{_datadir}
109 EOF
110
111 cat <<'EOF' > pack.ini
112 ; ZendStudioServer package settings. Overwritten with each upgrade.
113 ; if you need to add options, edit %{name}.ini instead
114 [Zend]
115 zend_extension_manager.debug_server=%{_libdir}/Zend/lib/Debugger-%{version}
116 zend_extension_manager.debug_server_ts=%{_libdir}/Zend/lib/Debugger_TS-%{version}
117 EOF
118
119 install -d $RPM_BUILD_ROOT%{_sysconfdir}/php{,4}/conf.d
120 install zend.ini $RPM_BUILD_ROOT/etc/php4/conf.d/%{name}.ini
121 install zend.ini $RPM_BUILD_ROOT/etc/php/conf.d/%{name}.ini
122 install pack.ini $RPM_BUILD_ROOT/etc/php4/conf.d/%{name}_pack.ini
123 install pack.ini $RPM_BUILD_ROOT/etc/php/conf.d/%{name}_pack.ini
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %preun -n php4-%{name}
129 if [ "$1" = "0" ]; then
130         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
131         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
132 fi
133
134 %post -n php4-%{name}
135 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
136 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
137
138
139 %preun -n php-%{name}
140 if [ "$1" = "0" ]; then
141         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
142         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
143 fi
144
145 %post -n php-%{name}
146 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
147 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
148
149 %files
150 %defattr(644,root,root,755)
151 %doc README* LICENSE LICENSE-PHP
152 %attr(755,root,root) %{_bindir}/*
153 %attr(755,root,root) %{_sbindir}/*
154
155 %dir %{_libdir}/Zend/lib/Debugger-%{version}
156 %dir %{_libdir}/Zend/lib/Debugger-%{version}/php-*
157 %dir %{_libdir}/Zend/lib/Debugger_TS-%{version}
158 %dir %{_libdir}/Zend/lib/Debugger_TS-%{version}/php-*
159 %attr(755,root,root) %{_libdir}/Zend/lib/Debugger-%{version}/php-*/ZendDebugger.so
160 %attr(755,root,root) %{_libdir}/Zend/lib/Debugger_TS-%{version}/php-*/ZendDebugger.so
161 %{_libdir}/Zend/lib/tools
162
163 # html documents
164 %{_datadir}
165
166 %files -n php4-%{name}
167 %defattr(644,root,root,755)
168 %config(noreplace) %verify(not md5 mtime size) /etc/php4/conf.d/%{name}.ini
169 %config %verify(not md5 mtime size) /etc/php4/conf.d/%{name}_pack.ini
170
171 %files -n php-%{name}
172 %defattr(644,root,root,755)
173 %config(noreplace) %verify(not md5 mtime size) /etc/php/conf.d/%{name}.ini
174 %config %verify(not md5 mtime size) /etc/php/conf.d/%{name}_pack.ini
This page took 0.061113 seconds and 2 git commands to generate.