]> git.pld-linux.org Git - packages/ZendStudioServer.git/blob - ZendStudioServer.spec
- finish .ini files
[packages/ZendStudioServer.git] / ZendStudioServer.spec
1 Summary:        ZendStudioServer - server management tools for PHP based Web servers
2 Summary(pl):    ZendStudioServer - narzêdzia zarz±dzaj±ce dla serwerów WWW opartych na PHP
3 Name:           ZendStudioServer
4 Version:        5.0.0
5 Release:        0.3
6 Epoch:          0
7 License:        Zend Studio License
8 Group:          Applications
9 Source0:        http://downloads.zend.com/studio/5.0.0/%{name}-%{version}-linux-glibc21-i386.tar.gz
10 # NoSource0-md5:        c55d9bbde4ec1eceba1b6a06e6ead9c3
11 NoSource:       0
12 Source1:        http://downloads.zend.com/studio/5.0.0/%{name}-%{version}-linux-glibc23-x86_64.tar.gz
13 # NoSource1-md5:        dbb459de43cf1492404b140b9f33e0a4
14 NoSource:       1
15 BuildRequires:  tar >= 1:1.15.1
16 # circular dependency, so ones upgraded are forced to choose php and
17 # ones that want to install specific for specific version need not to
18 # install ZendStudioServer separately
19 Requires:       %{name}(php) = %{version}-%{release}
20 ExclusiveArch:  %{ix86} %{x8664}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _datadir        %{_prefix}/share/Zend
24 %define         no_install_post_strip           1
25 %define         no_install_post_chrpath         1
26
27 %description
28 Includes server management tools that manage PHP based Web servers.
29 This module makes installation and integration seamless while
30 simplifying PHP and remote debugging configurations and security
31 maintenance.
32
33 %description -l pl
34 Ten pakiet zawiera narzêdzia zarz±dzaj±ce serwerem dla serwerów WWW
35 opartych na PHP. Ten modu³ pozwala na przezroczyst± instalacjê i
36 integracjê jednocze¶nie upraszczaj±c konfiguracje PHP ze zdaln±
37 diagnostyk± oraz zarz±dzanie bezpieczeñstwem.
38
39 %package -n php4-%{name}
40 Summary:        ZendStudioServer for PHP 4.x
41 Summary(pl):    ZendStudioServer dla PHP 4.x
42 Group:          Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       php4-ZendOptimizer
45 Provides:       %{name}(php) = %{version}-%{release}
46
47 %description -n php4-%{name}
48 ZendStudioServer for PHP 4.x.
49
50 %description -n php4-%{name} -l pl
51 ZendStudioServer dla PHP 4.x.
52
53 %package -n php-%{name}
54 Summary:        ZendStudioServer for PHP 5.x
55 Summary(pl):    ZendStudioServer dla PHP 5.x
56 Group:          Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       php-ZendOptimizer
59 Provides:       %{name}(php) = %{version}-%{release}
60
61 %description -n php-%{name}
62 ZendStudioServer for PHP 5.x.
63
64 %description -n php-%{name} -l pl
65 ZendStudioServer dla PHP 5.x.
66
67 %prep
68 %setup -qcT
69 %ifarch %{x8664}
70 tar --strip-components=1 -xzf %{SOURCE1}
71 %else
72 tar --strip-components=1 -xzf %{SOURCE0}
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/Zend/lib/tools,%{_datadir}/htdocs}
78
79 cd data
80 install dummy.php $RPM_BUILD_ROOT%{_datadir}/htdocs
81 cp -a gui/* $RPM_BUILD_ROOT%{_datadir}/htdocs
82 install runas $RPM_BUILD_ROOT%{_bindir}
83 install ini_modifier  $RPM_BUILD_ROOT%{_sbindir}
84
85 install change_gui_password.php $RPM_BUILD_ROOT%{_libdir}/Zend/lib/tools
86 cp -a phplib $RPM_BUILD_ROOT%{_libdir}/Zend/lib/tools
87
88 for a in *_comp; do
89         d=$(basename $a _comp | tr _ .)
90         install -D $a/ZendDebugger.so $RPM_BUILD_ROOT%{_libdir}/Zend/lib/Debugger-%{version}/php-$d/ZendDebugger.so
91 done
92 for a in *_comp/TS; do
93         d=$(basename $(dirname $a) _comp | tr _ .)
94         install -D $a/ZendDebugger.so $RPM_BUILD_ROOT%{_libdir}/Zend/lib/Debugger_TS-%{version}/php-$d/ZendDebugger.so
95 done
96
97 cat > zend.ini <<EOF
98 [Zend]
99 studio.install_dir=%{_datadir}
100 zend_debugger.expose_remotely=allowed_hosts
101 zend_debugger.httpd_uid=51
102 zend_gui_password=69fb46f4c18463dd25002aeffc0257d1
103 zend_gui.ini_modifier=%{_sbindir}/ini_modifier
104 zend_debugger.allow_hosts=127.0.0.1/32,192.168.2.0/24
105 zend_debugger.allow_tunnel=127.0.0.1/32
106 zend_debugger.deny_hosts=
107 zend_root_dir=%{_datadir}
108 EOF
109
110 cat <<'EOF' > pack.ini
111 ; ZendStudioServer package settings. Overwritten with each upgrade.
112 ; if you need to add options, edit %{name}.ini instead
113 [Zend]
114 zend_extension_manager.debug_server=%{_libdir}/Zend/lib/Debugger-%{version}
115 zend_extension_manager.debug_server_ts=%{_libdir}/Zend/lib/Debugger_TS-%{version}
116 EOF
117
118 install -d $RPM_BUILD_ROOT%{_sysconfdir}/php{,4}/conf.d
119 install zend.ini $RPM_BUILD_ROOT/etc/php4/conf.d/%{name}.ini
120 install zend.ini $RPM_BUILD_ROOT/etc/php/conf.d/%{name}.ini
121 install pack.ini $RPM_BUILD_ROOT/etc/php4/conf.d/%{name}_pack.ini
122 install pack.ini $RPM_BUILD_ROOT/etc/php/conf.d/%{name}_pack.ini
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %preun -n php4-%{name}
128 if [ "$1" = "0" ]; then
129         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
130         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
131 fi
132
133 %post -n php4-%{name}
134 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
135 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
136
137
138 %preun -n php-%{name}
139 if [ "$1" = "0" ]; then
140         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
141         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
142 fi
143
144 %post -n php-%{name}
145 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
146 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
147
148 %files
149 %defattr(644,root,root,755)
150 %doc README LICENSE LICENSE-PHP
151 %attr(755,root,root) %{_bindir}/*
152 %attr(755,root,root) %{_sbindir}/*
153
154 %dir %{_libdir}/Zend/lib/Debugger-%{version}
155 %dir %{_libdir}/Zend/lib/Debugger-%{version}/php-*
156 %dir %{_libdir}/Zend/lib/Debugger_TS-%{version}
157 %dir %{_libdir}/Zend/lib/Debugger_TS-%{version}/php-*
158 %attr(755,root,root) %{_libdir}/Zend/lib/Debugger-%{version}/php-*/ZendDebugger.so
159 %attr(755,root,root) %{_libdir}/Zend/lib/Debugger_TS-%{version}/php-*/ZendDebugger.so
160 %{_libdir}/Zend/lib/tools
161
162 # html documents
163 %{_datadir}
164
165 %files -n php4-%{name}
166 %defattr(644,root,root,755)
167 %config(noreplace) %verify(not md5 mtime size) /etc/php4/conf.d/%{name}.ini
168 %config %verify(not md5 mtime size) /etc/php4/conf.d/%{name}_pack.ini
169
170 %files -n php-%{name}
171 %defattr(644,root,root,755)
172 %config(noreplace) %verify(not md5 mtime size) /etc/php/conf.d/%{name}.ini
173 %config %verify(not md5 mtime size) /etc/php/conf.d/%{name}_pack.ini
This page took 0.08461 seconds and 3 git commands to generate.