]> git.pld-linux.org Git - packages/ZendGuardLoader.git/blob - ZendGuardLoader.spec
- almost raw, unfinished
[packages/ZendGuardLoader.git] / ZendGuardLoader.spec
1 # DO NOT MODIFY CONTENTS OF PACKAGE - AGAINST LICENSE AND MAKES IT UNDISTRIBUTABLE
2 # AND ALSO IT IS ALREADY STRIPPED.
3
4 %define         no_install_post_strip           1
5 %define         no_install_post_compress_docs   1
6 %define         no_install_post_chrpath         1
7 Summary:        Zend Guard - PHP code guard
8 Summary(pl.UTF-8):      Zend Guard - optymalizator kodu PHP
9 Name:           ZendGuardLoader
10 Version:        5.5.0
11 Release:        0.1
12 License:        Zend License, distributable only if unmodified and for free (see LICENSE)
13 Group:          Libraries
14 Source0:        http://downloads.zend.com/guard/5.5.0/%{name}-php-5.3-linux-glibc23-i386.tar.gz
15 # Source0-md5:  f53e51ecb59e390be5551ff7cc8576b0
16 Source1:        http://downloads.zend.com/guard/5.5.0/%{name}-php-5.3-linux-glibc23-x86_64.tar.gz
17 # Source1-md5:  9408297e9e38d5ce2cca92c619b5ad50
18 URL:            http://www.zend.com/products/zend_guard
19 BuildRequires:  rpmbuild(macros) >= 1.344
20 BuildRequires:  tar >= 1:1.15.1
21 Requires(triggerpostun):        sed >= 4.0
22 ExclusiveArch:  %{ix86} %{x8664}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Zend Guard - PHP code guard.
27
28 %description -l pl.UTF-8
29 Zend Guard - optymalizator kodu PHP.
30
31 %package -n php-%{name}
32 Summary:        Zend Guard for PHP 5.x
33 Summary(pl.UTF-8):      Zend Guard dla PHP 5.x
34 Group:          Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       php-common >= 4:5.3
37
38 %description -n php-%{name}
39 Zend Guard for PHP 5.x.
40
41 %description -n php-%{name} -l pl.UTF-8
42 Zend Guard dla PHP 5.x.
43
44 %prep
45 %setup -q -c
46
47 %ifarch %{ix86}
48 %{__tar} --strip-components=1 -zxf %{SOURCE0}
49 %endif
50 %ifarch %{x8664}
51 %{__tar} --strip-components=1 -zxf %{SOURCE1}
52 %endif
53
54 cat <<'EOF' > zendguard.ini
55 ; ZendGuard user settings.
56 [Zend]
57 zend_guard.optimization_level=15
58 EOF
59
60 cat <<'EOF' > pack.ini
61 ; ZendGuard package settings. Overwritten with each upgrade.
62 ; if you need to add options, edit %{name}.ini instead
63 [Zend]
64 zend_guard.version=%{version}
65 zend_extension_manager.guard=%{_libdir}/Zend/lib/Guard-%{version}
66 zend_extension_manager.guard_ts=%{_libdir}/Zend/lib/Guard_TS-%{version}
67 zend_extension=%{_libdir}/Zend/lib/ZendExtensionManager.so
68 zend_extension_ts=%{_libdir}/Zend/lib/ZendExtensionManager_TS.so
69 EOF
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/php}
74
75 install -D php-*/ZendGuardLoader.so $RPM_BUILD_ROOT%{_libdir}/Zend/lib/Guard-%{version}/php-$d/ZendGuardLoader.so
76
77 ln -s %{_sysconfdir}/php $RPM_BUILD_ROOT%{_libdir}/Zend%{_sysconfdir}
78 ln -s %{_bindir} $RPM_BUILD_ROOT%{_libdir}/Zend/bin
79
80 install -d $RPM_BUILD_ROOT%{_sysconfdir}/php/conf.d
81 install zendguard.ini $RPM_BUILD_ROOT%{_sysconfdir}/php/conf.d/zendguard.ini
82 install pack.ini $RPM_BUILD_ROOT%{_sysconfdir}/php/conf.d/zendguard_pack.ini
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %preun -n php-%{name}
88 if [ "$1" = "0" ]; then
89         %php_webserver_restart
90 fi
91
92 %post -n php-%{name}
93 # let %{_prefix}/lib/Zend%{_sysconfdir} point to php's config dir. php which installed first wins.
94 # not sure how critical is existence of this etc link at all.
95 if [ ! -L %{_libdir}/Zend%{_sysconfdir} ]; then
96 ln -snf %{_sysconfdir}/php %{_libdir}/Zend%{_sysconfdir}
97 fi
98 %php_webserver_restart
99
100 %post
101 if [ "$1" = 1 ]; then
102 %banner -e %{name} <<EOF
103 Remember to read %{_docdir}/%{name}-%{version}/LICENSE.gz!
104 EOF
105 fi
106
107 %triggerpostun -- %{name} < 2.5.10a-0.20
108 if [ -f /etc/php/php.ini ]; then
109         cp -f /etc/php/conf.d/ZendGuard.ini{,.rpmnew}
110         sed -ne '/^\(zend_\|\[Zend\]\)/{/^zend_extension\(_manager\.guard\)\?\(_ts\)\?=/d;p}' /etc/php/php.ini > /etc/php/conf.d/ZendGuard.ini
111         cp -f /etc/php/php.ini{,.rpmsave}
112         sed -i -e '/^\(zend_\|\[Zend\]\)/d' /etc/php/php.ini
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc data/doc/* LICENSE
118 %attr(755,root,root) %{_bindir}/zendid
119 %dir %{_libdir}/Zend
120 %dir %{_libdir}/Zend/lib
121 %dir %{_libdir}/Zend/lib/Guard-%{version}
122 %dir %{_libdir}/Zend/lib/Guard-%{version}/php-*
123 %dir %{_libdir}/Zend/lib/Guard_TS-%{version}
124 %dir %{_libdir}/Zend/lib/Guard_TS-%{version}/php-*
125 %attr(755,root,root) %{_libdir}/Zend/lib/Guard-%{version}/php-*/ZendGuard.so
126 %attr(755,root,root) %{_libdir}/Zend/lib/Guard_TS-%{version}/php-*/ZendGuard.so
127 %attr(755,root,root) %{_libdir}/Zend/lib/ZendExtensionManager.so
128 %attr(755,root,root) %{_libdir}/Zend/lib/ZendExtensionManager_TS.so
129 %{_libdir}/Zend/bin
130 %ghost %{_libdir}/Zend%{_sysconfdir}
131
132 %files -n php-%{name}
133 %defattr(644,root,root,755)
134 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php/conf.d/zendguard.ini
135 %config %verify(not md5 mtime size) %{_sysconfdir}/php/conf.d/zendguard_pack.ini
136 %{_sysconfdir}/php/poweredbyguard.gif
This page took 0.03967 seconds and 3 git commands to generate.