]> git.pld-linux.org Git - packages/ZendFramework.git/commitdiff
- ZendFramework-db_charset.patch was cause of syntax errors auto/ac/ZendFramework-1_8_2-2 auto/th/ZendFramework-1_8_2-2
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 2 Jun 2009 10:12:32 +0000 (10:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- ZF-1541 was fixed in 1.8.0; rel 2

Changed files:
    ZendFramework-db_charset.patch -> 1.2
    ZendFramework.spec -> 1.61

ZendFramework-db_charset.patch [deleted file]
ZendFramework.spec

diff --git a/ZendFramework-db_charset.patch b/ZendFramework-db_charset.patch
deleted file mode 100644 (file)
index 049ee22..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-Index: Zend/Db/Adapter/Mysqli.php
-===================================================================
---- Zend/Db/Adapter/Mysqli.php (revision 11422)
-+++ Zend/Db/Adapter/Mysqli.php (working copy)
-@@ -313,6 +313,10 @@
-             require_once 'Zend/Db/Adapter/Mysqli/Exception.php';
-             throw new Zend_Db_Adapter_Mysqli_Exception(mysqli_connect_error());
-         }
-+        
-+        if(array_key_exists('charset', $this->_config)) {
-+            $this->_connection->set_charset($this->_config['charset']);
-+        }
-     }
-     /**
-Index: Zend/Db/Adapter/Pdo/Mysql.php
-===================================================================
---- Zend/Db/Adapter/Pdo/Mysql.php      (revision 11422)
-+++ Zend/Db/Adapter/Pdo/Mysql.php      (working copy)
-@@ -93,6 +93,20 @@
-     {
-         return $this->fetchCol('SHOW TABLES');
-     }
-+    
-+    /**
-+     * @return void
-+     */
-+    protected function _connect()
-+    {
-+        if ($this->_connection) {
-+            return;
-+        }
-+        parent::_connect();
-+        if (array_key_exists('charset', $this->_config)) {
-+            $this->_connection->exec('SET NAMES ' . $this->_quote($this->_config['charset']));
-+        }
-+    }
-     /**
-      * Returns the column descriptions for a table.
-Index: Zend/Db/Adapter/Pdo/Pgsql.php
-===================================================================
---- Zend/Db/Adapter/Pdo/Pgsql.php      (revision 11422)
-+++ Zend/Db/Adapter/Pdo/Pgsql.php      (working copy)
-@@ -71,6 +71,20 @@
-         'NUMERIC'            => Zend_Db::FLOAT_TYPE,
-         'REAL'               => Zend_Db::FLOAT_TYPE
-     );
-+    
-+    /**
-+     * @return void
-+     */
-+    protected function _connect()
-+    {
-+        if ($this->_connection) {
-+            return;
-+        }
-+        parent::_connect();
-+        if (array_key_exists('charset', $this->_config)) {
-+            $this->_connection->exec('SET NAMES ' . $this->_quote($this->_config['charset']));
-+        }
-+    }
-     /**
-      * Returns a list of the tables in the database.
index f68ced884933b96f9f0c0c654e84ad81ec87ecce..01b2e0dcb792dfc3b6f24040d52895bf8ccb844c 100644 (file)
@@ -1,12 +1,9 @@
-# PHP Fatal error:  Cannot redeclare Zend_Db_Adapter_Pdo_Mysql::_connect() in library/Zend/Db/Adapter/Pdo/Mysql.php on line 120
-#   Errors parsing library/Zend/Db/Adapter/Pdo/Mysql.php
-#   upstream bug: http://framework.zend.com/issues/browse/ZF-6881
 %include       /usr/lib/rpm/macros.php
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
 Version:       1.8.2
-Release:       0.1
+Release:       2
 License:       New BSD License
 Group:         Development/Languages/PHP
 Source0:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}.tar.gz
@@ -15,9 +12,8 @@ Source1:      http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version
 # Source1-md5: 993547c3d128cde28197bb013024d945
 Source2:       %{name}-find-lang.sh
 Patch0:                %{name}-additional-locales.patch
-Patch1:                %{name}-db_charset.patch
-Patch2:                %{name}-deps.patch
-Patch3:                %{name}-bug6499.patch
+Patch1:                %{name}-deps.patch
+Patch2:                %{name}-bug6499.patch
 URL:           http://framework.zend.com/
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: sed >= 4.0
@@ -1265,14 +1261,14 @@ Podręcznik do Zend Framework w języku angielskim.
 mv %{name}-%{version}/documentation .
 find '(' -name '*.php' -o -name '*.xml' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
 %patch0 -p1
-cd library
-%patch1 -p0
-cd -
-%patch2 -p1
-%patch3 -p0
+%patch1 -p1
+%patch2 -p0
 
 install %{SOURCE2} find-lang.sh
 
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
 %build
 # check *.php files syntax using runkit extension
 lint_php() {
This page took 0.113122 seconds and 4 git commands to generate.