]> git.pld-linux.org Git - packages/ZendFramework.git/blobdiff - ZendFramework.spec
- requires php 5.2.4
[packages/ZendFramework.git] / ZendFramework.spec
index 69cabeeb2dc7ba0fbb7eb2f77a8e628dfe46b468..85d34b3d1530c08984873e3a49b53696adea8209 100644 (file)
@@ -1,33 +1,49 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
+# TODO
+# - check Zend/Pdf/FileParser/Image/Jpeg.php and Zend/Pdf/FileParser/Image/Tiff.php
+#   presence in Zend/Pdf/Image.php after update [not implemented in 1.10.2)
 %include       /usr/lib/rpm/macros.php
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
-Version:       1.8.4PL1
-Release:       2
+Version:       1.11.4
+Release:       1
 License:       New BSD License
 Group:         Development/Languages/PHP
 Source0:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d7374bf9b1741e2f925e8d2443475f9d
+# Source0-md5: 844b533ba963639d80b6ae8af1b25947
 Source1:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}-manual-en.tar.gz
-# Source1-md5: 91c3e781895d07ad3b22e37dbcad7585
+# Source1-md5: 66d60e6c3b99d51ee24b912cd8df1d2d
 Source2:       %{name}-find-lang.sh
 Patch0:                %{name}-additional-locales.patch
 Patch1:                %{name}-deps.patch
-Patch2:                %{name}-bug6499.patch
-Patch3:                ZF-5750-pjpeg.patch
 URL:           http://framework.zend.com/
-BuildRequires: php-pecl-runkit
+BuildRequires: /usr/bin/php
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: sed >= 4.0
-Requires:      php-common >= 4:5.1.4
+Requires:      php-common >= 4:5.2.4
 Requires:      php-pear
-Requires:      rpm-whiteout >= 1.12
+Requires:      rpm-whiteout >= 1.32
 Obsoletes:     ZendFramework-doc
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# exclude optional dependencies
-%define                _noautoreq      'php(oci8)' 'php(bitset)' 'pear(../application/bootstrap.php)'
+# bad depsolver
+%define                _noautopear     pear(../application/bootstrap.php)
+
+# bad code
+%define                _bad_deps_1_10 pear(Zend/Pdf/FileParser/Image/Jpeg.php) pear(Zend/Pdf/FileParser/Image/Tiff.php)
+%define                _bad_deps_1_10_2 pear(Zend/Serializer/Excception.php) pear(Zend/Services/DeveloperGarden/Response/Exception.php)
+%define                _noautodeps     %{?_bad_deps_1_10} %{?_bad_deps_1_10_2}
+
+# exclude optional php dependencies
+%define                _noautophp      php-oci8 php-bitset
+
+# put it together for rpmbuild
+%define                _noautoreq      %{?_noautophp} %{?_noautopear} %{?_noautodeps}
 
 %description
 Zend Framework is a high quality and open source framework for
@@ -114,6 +130,26 @@ authentication adapters for common use case scenarios.
 Zend_Auth udostępnia API do uwierzytelniania i zawiera właściwe
 adaptery do uwierzytelniania w popularnych przypadkach użycia.
 
+%package Zend_Barcode
+Summary:       Zend_Barcode - barcode generator
+Summary(pl.UTF-8):     Zend_Barcode - generator kodów kreskowych
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.barcode.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Barcode
+Zend_Barcode provides a generic way to generate barcodes. The
+Zend_Barcode component is divided into two subcomponents: barcode
+objects and renderers. Objects allow you to create barcodes
+independently of the renderer. Renderer allow you to draw barcodes
+based on the support required.
+
+%description Zend_Barcode -l pl.UTF-8
+Zend_Barcode udostępnia funkcjonalność generowania kodów kreskowych.
+Komponent Zend_Barcode podzielony jest na dwa podkomponenty: obiekty i
+renderery. Obiekty pozwalają na tworzenie kodów niezależnie od
+renderera, renderer na rysowanie kodów na podstawie obiektu.
+
 %package Zend_Cache
 Summary:       Zend_Cache - data caching
 Summary(pl.UTF-8):     Zend_Cache - pamięć podręczna dla danych
@@ -160,6 +196,15 @@ fontów lub obrazków z pytaniem o ich powiązania. Klasa Zend_Captcha
 udostępnia różne backendy. Może być używana zarówno samodzielnie, jak
 i w połączeniu z Zend_Form.
 
+%package Zend_Cloud
+Summary:       Zend_Cloud - SimpleCloud API
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.cloud.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Cloud
+SimpleCloud API
+
 %package Zend_CodeGenerator
 Summary:       Zend_CodeGenerator - generate arbitrary code using OO interface
 Group:         Development/Languages/PHP
@@ -597,6 +642,24 @@ text and MIME-compliant multipart e-mail messages. Mail can be sent
 with Zend_Mail via the default Zend_Mail_Transport_Sendmail transport
 or via Zend_Mail_Transport_Smtp.
 
+%package Zend_Markup
+Summary:       Zend_Markup
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.markup.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Markup
+The Zend_Markup component provides an extensible way for parsing text
+and rendering lightweight markup languages like BBcode and Textile. It
+is available as of Zend Framework version 1.10.
+
+Zend_Markup uses a factory method to instantiate an instance of a
+renderer that extends Zend_Markup_Renderer_Abstract. The factory
+method accepts three arguments. The first one is the parser used to
+tokenize the text (e.g. BbCode). The second (optional) parameter is
+the renderer to use, Html by default. Thirdly an array with options to
+use for the renderer can be specified.
+
 %package Zend_Measure
 Summary:       Zend_Measure
 Group:         Development/Languages/PHP
@@ -649,11 +712,33 @@ pages. Simply put: It can be used for creating menus, breadcrumbs,
 links, and sitemaps, or serve as a model for other navigation related
 purposes.
 
+%package Zend_Oauth
+Summary:       Zend_Oauth
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.oauth.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Oauth
+OAuth allows you to approve access by any application to your private
+data stored a website without being forced to disclose your username
+or password. If you think about it, the practice of handing over your
+username and password for sites like Yahoo Mail or Twitter has been
+endemic for quite a while. This has raised some serious concerns
+because there's nothing to prevent other applications from misusing
+this data. Yes, some services may appear trustworthy but that is never
+guaranteed. OAuth resolves this problem by eliminating the need for
+any username and password sharing, replacing it with a user controlled
+authorization process
+
 %package Zend_OpenId
 Summary:       Zend_OpenId
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.openid.html
 Requires:      %{name} = %{version}-%{release}
+# needed for dh keys: any of these tree can do for
+Suggests:      php-bcmath
+Suggests:      php-gmp
+Suggests:      php-openssl
 
 %description Zend_OpenId
 Zend_OpenId is a Zend Framework component that provides a simple API
@@ -724,6 +809,20 @@ takes an absolute value and optionally a status message, and then
 calls the adapter with some precalculated values like percentage and
 estimated time left.
 
+%package Zend_Queue
+Summary:       Zend_Queue
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.progressbar.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Queue
+Zend_Queue is a standardized interface for dealing with a variety of
+queuing systems. Proposed systems include: simple array access,
+Zend_Cache, Zend Platform Job Queue, Amazon's Simple Queue Service
+(SQS). It should support creating queues, determining the number of
+messages in a queue, retrieving messages from a queue (all or specific
+number), submitting messages to a queue, and removing queues.
+
 %package Zend_Reflection
 Summary:       Zend_Reflection
 Group:         Development/Languages/PHP
@@ -800,6 +899,28 @@ Zend_Search_Lucene supports the following features:
   proximity queries, range queries and more
 - Search by specific field (e.g., title, author, contents)
 
+%package Zend_Serializer
+Summary:       Zend_Serializer
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.serializer.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Serializer
+Zend_Serializer provides an adapter based interface to simply generate
+storable representation of php types by different facilities, and
+recover.
+
+%package Zend_Server
+Summary:       Zend_Server
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.server.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Server
+The Zend_Server family of classes provides functionality for the
+various server classes, including Zend_XmlRpc_Server,
+Zend_Rest_Server, Zend_Json_Server and Zend_Soap_Wsdl.
+
 %package Zend_Server_Reflection
 Summary:       Zend_Server_Reflection
 Group:         Development/Languages/PHP
@@ -814,6 +935,16 @@ retrieving parameter and return value types and descriptions, a full
 list of function and method prototypes (i.e., all possible valid
 calling combinations), and function/method descriptions.
 
+%package Zend_Service
+Summary:       Zend_Service
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service
+Zend_Service is an abstract class which serves as a foundation for web
+service implementations, such as SOAP or REST.
+
 %package Zend_Service_Akismet
 Summary:       Zend_Service_Akismet
 Group:         Development/Languages/PHP
@@ -881,6 +1012,34 @@ JSON web services. This component gives you read-write access to posts
 at del.icio.us if you provide credentials. It also allows read-only
 access to public data of all users.
 
+%package Zend_Service_DeveloperGarden
+Summary:       Zend_Service_DeveloperGarden
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.developergarden.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_DeveloperGarden
+DeveloperGarden is the name for the "Open Development services" of the
+German Telekom. The "Open Development services" are a set of SOAP API
+Services.
+
+The family of Zend_Service_DeveloperGarden components provides a clean
+and simple interface to the DeveloperGarden API and additionally
+offers functionality to improve handling and performance
+
+%package Zend_Service_Ebay
+Summary:       Zend_Service_Ebay is a simple group of APIs for using eBay web services
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.ebay.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_Ebay
+Zend_Service_Ebay is a simple group of APIs for using eBay web
+services.
+
+Zend_Service_Ebay implements the eBay APIs:
+- Finding
+
 %package Zend_Service_Flickr
 Summary:       Zend_Service_Flickr
 Group:         Development/Languages/PHP
@@ -895,6 +1054,23 @@ Service. In order to use the Flickr web services, you must have an API
 key. To obtain a key, visit the Flickr API Documentation
 <http://www.flickr.com/services/api/>.
 
+%package Zend_Service_LiveDocx
+Summary:       Zend_Service_LiveDocx
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.livedocx.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_LiveDocx
+LiveDocx is a SOAP service that allows developers to generate word
+processing documents by combining structured data from PHP with a
+template, created in a word processor. The resulting document can be
+saved as a PDF, DOCX, DOC, HTML or RTF file. LiveDocx implements
+mail-merge in PHP.
+
+The family of Zend_Service_LiveDocx components provides a clean and
+simple interface to the LiveDocx API and additionally offers
+functionality to improve network performance.
+
 %package Zend_Service_Nirvanix
 Summary:       Zend_Service_Nirvanix
 Group:         Development/Languages/PHP
@@ -941,6 +1117,21 @@ account (http://recaptcha.net/whyrecaptcha.html) and register one or
 more domains with the service in order to generate public and private
 keys.
 
+%package Zend_Service_ShortUrl
+Summary:       Zend_Service_ShortUrl
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.short-url.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_ShortUrl
+URL shorteners have exploded in popularity in the last several years,
+in large part due to the social nature of the web and the desire to
+share links.
+
+Zend_Service_ShortUrl provides an API for accessing a number of
+different URL shortener services, with the ability to both create
+short URLs as well as retrieve the original URL.
+
 %package Zend_Service_Simpy
 Summary:       Zend_Service_Simpy
 Group:         Development/Languages/PHP
@@ -1033,6 +1224,20 @@ if you provide a username and password for Twitter it will allow you
 to get and update your status, reply to friends, direct message
 friends, mark tweets as favorite and much more.
 
+%package Zend_Service_WindowsAzure
+Summary:       Zend_Service_WindowsAzure
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.windowsazure.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_WindowsAzure
+Windows Azure is the name for Microsoft’s Software + Services
+platform, an operating system in the cloud providing services for
+hosting, management, scalable storage with support for simple blobs,
+tables, and queues, as well as a management infrastructure for
+provisioning and geo-distribution of cloud-based services, and a
+development platform for the Azure Services layer.
+
 %package Zend_Service_Yahoo
 Summary:       Zend_Service_Yahoo
 Group:         Development/Languages/PHP
@@ -1102,12 +1307,23 @@ Summary:        Zend_Test
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.test.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-PHPUnit
 
 %description Zend_Test
 Zend_Test provides tools to facilitate unit testing of your Zend
 Framework applications.
 
+%package Zend_TimeSync
+Summary:       Zend_TimeSync
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.timesync.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_TimeSync
+Zend_TimeSync is able to receive internet or network time from a time
+server using the NTP or SNTP protocol. With Zend_TimeSync, Zend
+Framework is able to act independently from the time settings of the
+server where it is running.
+
 %package Zend_Tool
 Summary:       Zend_Tool
 Group:         Development/Languages/PHP
@@ -1264,33 +1480,23 @@ mv %{name}-%{version}/documentation .
 find '(' -name '*.php' -o -name '*.xml' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
 %patch0 -p1
 %patch1 -p1
-%patch2 -p0
-%patch3 -p0
 
-install %{SOURCE2} find-lang.sh
+install -p %{SOURCE2} find-lang.sh
+
+sed -i -e 's,Zend/Serializer/Excception.php,Zend/Serializer/Exception.php,' library/Zend/Serializer/Adapter/PythonPickle.php
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
 %build
-# check *.php files syntax using runkit extension
+%if %{with tests}
 lint_php() {
-       php -r '
-               $errors = 0;
-               array_shift($argv);
-               echo "Checking syntax of ", count($argv), " PHP files";
-               foreach ($argv as $file) {
-                       echo ".";
-                       if (!runkit_lint_file($file)) {
-                               echo "PHP Lint: $file\n";
-                               $errors++;
-                       }
-               }
-               echo "\nDONE!\n";
-               exit($errors ? 1 : 0);
-       ' $(find library -name '*.php')
+       for a in $(find library -name '*.php'); do
+               php -l $a
+       done
 }
 lint_php
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -1308,7 +1514,7 @@ cp -a bin/zf.php $RPM_BUILD_ROOT%{php_pear_dir}/bin
 cat >> $RPM_BUILD_ROOT%{_bindir}/zf <<-'EOF'
 #!/bin/sh
 cd %{php_pear_dir}/bin
-exec /usr/bin/php -d Safe_mode=off zf.php ${1:+"$@"}
+exec %{_bindir}/php -d safe_mode=off zf.php ${1:+"$@"}
 EOF
 
 ./find-lang.sh %{name}.lang
@@ -1324,26 +1530,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc LICENSE.txt README.txt
 %dir %{php_pear_dir}/Zend
-%dir %{php_pear_dir}/Zend/Console
-%dir %{php_pear_dir}/Zend/Search
-
-%dir %{php_pear_dir}/Zend/Server
-%{php_pear_dir}/Zend/Server/Abstract.php
-%{php_pear_dir}/Zend/Server/Exception.php
-%{php_pear_dir}/Zend/Server/Interface.php
-%{php_pear_dir}/Zend/Server/Definition.php
-%dir %{php_pear_dir}/Zend/Server/Method
-%{php_pear_dir}/Zend/Server/Method/Callback.php
-%{php_pear_dir}/Zend/Server/Method/Definition.php
-%{php_pear_dir}/Zend/Server/Method/Parameter.php
-%{php_pear_dir}/Zend/Server/Method/Prototype.php
-
-%dir %{php_pear_dir}/Zend/Service
-%{php_pear_dir}/Zend/Service/Abstract.php
-%{php_pear_dir}/Zend/Service/Exception.php
-
-%{php_pear_dir}/Zend/TimeSync
-%{php_pear_dir}/Zend/TimeSync.php
 
 %files Zend_Acl
 %defattr(644,root,root,755)
@@ -1369,6 +1555,11 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Auth
 %{php_pear_dir}/Zend/Auth.php
 
+%files Zend_Barcode
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Barcode
+%{php_pear_dir}/Zend/Barcode.php
+
 %files Zend_Cache
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Cache
@@ -1381,6 +1572,18 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Captcha
 
+%files Zend_Cloud
+%defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Cloud
+%{php_pear_dir}/Zend/Cloud/AbstractFactory.php
+%{php_pear_dir}/Zend/Cloud/Exception.php
+%{php_pear_dir}/Zend/Cloud/OperationNotAvailableException.php
+
+# subpackages?
+%{php_pear_dir}/Zend/Cloud/DocumentService
+%{php_pear_dir}/Zend/Cloud/QueueService
+%{php_pear_dir}/Zend/Cloud/StorageService
+
 %files Zend_CodeGenerator
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/CodeGenerator
@@ -1392,6 +1595,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files Zend_Console_Getopt
 %defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Console
 %{php_pear_dir}/Zend/Console/Getopt
 %{php_pear_dir}/Zend/Console/Getopt.php
 
@@ -1507,7 +1711,10 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{php_pear_dir}/Zend/Locale/Data
 %{php_pear_dir}/Zend/Locale/Data/Translation.php
 %{php_pear_dir}/Zend/Locale/Data/characters.xml
-%{php_pear_dir}/Zend/Locale/Data/plurals.xml
+%{php_pear_dir}/Zend/Locale/Data/likelySubtags.xml
+%{php_pear_dir}/Zend/Locale/Data/metazoneInfo.xml
+%{php_pear_dir}/Zend/Locale/Data/numberingSystems.xml
+%{php_pear_dir}/Zend/Locale/Data/postalCodeData.xml
 %{php_pear_dir}/Zend/Locale/Data/root.xml
 %{php_pear_dir}/Zend/Locale/Data/supplementalData.xml
 %{php_pear_dir}/Zend/Locale/Data/telephoneCodeData.xml
@@ -1522,6 +1729,11 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Mail
 %{php_pear_dir}/Zend/Mail.php
 
+%files Zend_Markup
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Markup
+%{php_pear_dir}/Zend/Markup.php
+
 %files Zend_Measure
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Measure
@@ -1541,6 +1753,11 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Navigation
 %{php_pear_dir}/Zend/Navigation.php
 
+%files Zend_Oauth
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Oauth
+%{php_pear_dir}/Zend/Oauth.php
+
 %files Zend_OpenId
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/OpenId
@@ -1556,6 +1773,11 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Pdf
 %{php_pear_dir}/Zend/Pdf.php
 
+%files Zend_Queue
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Queue
+%{php_pear_dir}/Zend/Queue.php
+
 %files Zend_Reflection
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Reflection
@@ -1570,15 +1792,40 @@ rm -rf $RPM_BUILD_ROOT
 
 %files Zend_Search_Lucene
 %defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Search
 %{php_pear_dir}/Zend/Search/Exception.php
 %{php_pear_dir}/Zend/Search/Lucene
 %{php_pear_dir}/Zend/Search/Lucene.php
 
+%files Zend_Serializer
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Serializer
+%{php_pear_dir}/Zend/Serializer.php
+
+%files Zend_Server
+%defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Server
+%{php_pear_dir}/Zend/Server/Abstract.php
+%{php_pear_dir}/Zend/Server/Exception.php
+%{php_pear_dir}/Zend/Server/Interface.php
+%{php_pear_dir}/Zend/Server/Definition.php
+%dir %{php_pear_dir}/Zend/Server/Method
+%{php_pear_dir}/Zend/Server/Method/Callback.php
+%{php_pear_dir}/Zend/Server/Method/Definition.php
+%{php_pear_dir}/Zend/Server/Method/Parameter.php
+%{php_pear_dir}/Zend/Server/Method/Prototype.php
+
 %files Zend_Server_Reflection
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Server/Reflection
 %{php_pear_dir}/Zend/Server/Reflection.php
 
+%files Zend_Service
+%defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Service
+%{php_pear_dir}/Zend/Service/Abstract.php
+%{php_pear_dir}/Zend/Service/Exception.php
+
 %files Zend_Service_Akismet
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Akismet.php
@@ -1598,11 +1845,24 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/Delicious
 %{php_pear_dir}/Zend/Service/Delicious.php
 
+%files Zend_Service_DeveloperGarden
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/DeveloperGarden
+
+%files Zend_Service_Ebay
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/Ebay
+
 %files Zend_Service_Flickr
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Flickr
 %{php_pear_dir}/Zend/Service/Flickr.php
 
+%files Zend_Service_LiveDocx
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/LiveDocx
+%{php_pear_dir}/Zend/Service/LiveDocx.php
+
 %files Zend_Service_Nirvanix
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Nirvanix
@@ -1613,6 +1873,10 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/ReCaptcha
 %{php_pear_dir}/Zend/Service/ReCaptcha.php
 
+%files Zend_Service_ShortUrl
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/ShortUrl
+
 %files Zend_Service_Simpy
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Simpy
@@ -1638,6 +1902,10 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/Twitter
 %{php_pear_dir}/Zend/Service/Twitter.php
 
+%files Zend_Service_WindowsAzure
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/WindowsAzure
+
 %files Zend_Service_Yahoo
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Yahoo
@@ -1664,6 +1932,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Test
 
+%files Zend_TimeSync
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/TimeSync
+%{php_pear_dir}/Zend/TimeSync.php
+
 %files Zend_Tool
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/zf
This page took 0.10504 seconds and 4 git commands to generate.