]> git.pld-linux.org Git - packages/ZendFramework.git/blobdiff - ZendFramework.spec
- requires php 5.2.4
[packages/ZendFramework.git] / ZendFramework.spec
index 47a5d14737351d1ef68bb43e5b8eefc2032060e0..85d34b3d1530c08984873e3a49b53696adea8209 100644 (file)
@@ -9,23 +9,22 @@
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
-Version:       1.10.6
+Version:       1.11.4
 Release:       1
 License:       New BSD License
 Group:         Development/Languages/PHP
 Source0:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 094999cd940bcc643563bca0cf1817e0
+# Source0-md5: 844b533ba963639d80b6ae8af1b25947
 Source1:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}-manual-en.tar.gz
-# Source1-md5: 80e49fbf66667ae65c8cfade0d2c8436
+# Source1-md5: 66d60e6c3b99d51ee24b912cd8df1d2d
 Source2:       %{name}-find-lang.sh
 Patch0:                %{name}-additional-locales.patch
 Patch1:                %{name}-deps.patch
 URL:           http://framework.zend.com/
 BuildRequires: /usr/bin/php
-%{?with_tests:BuildRequires:   php-pecl-runkit}
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: sed >= 4.0
-Requires:      php-common >= 4:5.1.4
+Requires:      php-common >= 4:5.2.4
 Requires:      php-pear
 Requires:      rpm-whiteout >= 1.32
 Obsoletes:     ZendFramework-doc
@@ -133,7 +132,7 @@ adaptery do uwierzytelniania w popularnych przypadkach użycia.
 
 %package Zend_Barcode
 Summary:       Zend_Barcode - barcode generator
-Summary(pl.UTF_8):     Zend_Barcode - generator kodów kreskowych
+Summary(pl.UTF-8):     Zend_Barcode - generator kodów kreskowych
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.barcode.html
 Requires:      %{name} = %{version}-%{release}
@@ -197,6 +196,15 @@ fontów lub obrazków z pytaniem o ich powiązania. Klasa Zend_Captcha
 udostępnia różne backendy. Może być używana zarówno samodzielnie, jak
 i w połączeniu z Zend_Form.
 
+%package Zend_Cloud
+Summary:       Zend_Cloud - SimpleCloud API
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.cloud.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Cloud
+SimpleCloud API
+
 %package Zend_CodeGenerator
 Summary:       Zend_CodeGenerator - generate arbitrary code using OO interface
 Group:         Development/Languages/PHP
@@ -1019,6 +1027,19 @@ The family of Zend_Service_DeveloperGarden components provides a clean
 and simple interface to the DeveloperGarden API and additionally
 offers functionality to improve handling and performance
 
+%package Zend_Service_Ebay
+Summary:       Zend_Service_Ebay is a simple group of APIs for using eBay web services
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.ebay.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_Ebay
+Zend_Service_Ebay is a simple group of APIs for using eBay web
+services.
+
+Zend_Service_Ebay implements the eBay APIs:
+- Finding
+
 %package Zend_Service_Flickr
 Summary:       Zend_Service_Flickr
 Group:         Development/Languages/PHP
@@ -1096,6 +1117,21 @@ account (http://recaptcha.net/whyrecaptcha.html) and register one or
 more domains with the service in order to generate public and private
 keys.
 
+%package Zend_Service_ShortUrl
+Summary:       Zend_Service_ShortUrl
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.short-url.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_ShortUrl
+URL shorteners have exploded in popularity in the last several years,
+in large part due to the social nature of the web and the desire to
+share links.
+
+Zend_Service_ShortUrl provides an API for accessing a number of
+different URL shortener services, with the ability to both create
+short URLs as well as retrieve the original URL.
+
 %package Zend_Service_Simpy
 Summary:       Zend_Service_Simpy
 Group:         Development/Languages/PHP
@@ -1271,7 +1307,6 @@ Summary:  Zend_Test
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.test.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-PHPUnit
 
 %description Zend_Test
 Zend_Test provides tools to facilitate unit testing of your Zend
@@ -1455,22 +1490,10 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
 %build
 %if %{with tests}
-# check *.php files syntax using runkit extension
 lint_php() {
-       php -r '
-               $errors = 0;
-               array_shift($argv);
-               echo "Checking syntax of ", count($argv), " PHP files";
-               foreach ($argv as $file) {
-                       echo ".";
-                       if (!runkit_lint_file($file)) {
-                               echo "PHP Lint: $file\n";
-                               $errors++;
-                       }
-               }
-               echo "\nDONE!\n";
-               exit($errors ? 1 : 0);
-       ' $(find library -name '*.php')
+       for a in $(find library -name '*.php'); do
+               php -l $a
+       done
 }
 lint_php
 %endif
@@ -1549,6 +1572,18 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Captcha
 
+%files Zend_Cloud
+%defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Cloud
+%{php_pear_dir}/Zend/Cloud/AbstractFactory.php
+%{php_pear_dir}/Zend/Cloud/Exception.php
+%{php_pear_dir}/Zend/Cloud/OperationNotAvailableException.php
+
+# subpackages?
+%{php_pear_dir}/Zend/Cloud/DocumentService
+%{php_pear_dir}/Zend/Cloud/QueueService
+%{php_pear_dir}/Zend/Cloud/StorageService
+
 %files Zend_CodeGenerator
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/CodeGenerator
@@ -1814,6 +1849,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/DeveloperGarden
 
+%files Zend_Service_Ebay
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/Ebay
+
 %files Zend_Service_Flickr
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Flickr
@@ -1834,6 +1873,10 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/ReCaptcha
 %{php_pear_dir}/Zend/Service/ReCaptcha.php
 
+%files Zend_Service_ShortUrl
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/ShortUrl
+
 %files Zend_Service_Simpy
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Simpy
This page took 0.081663 seconds and 4 git commands to generate.