]> git.pld-linux.org Git - packages/Xnee.git/blob - Xnee.spec
- up to 3.19
[packages/Xnee.git] / Xnee.spec
1 # TODO:
2 # - package libxnee if needed for anything (it's noinst now)
3 # - generate docs - (some files are missing)
4 #
5 # Conditional build:
6 %bcond_with     doc     # documentation (broken, missing files)
7 %bcond_with     gnome   # GNOME 2 panel applet (not ready for GNOME 3)
8 #
9 Summary:        Suite of programs that can record and replay user actions under X11
10 Summary(pl.UTF-8):      Zestaw programów do nagrywania i odtwarzania akcji użytkownika pod X11
11 Name:           Xnee
12 Version:        3.19
13 Release:        1
14 License:        GPL v3+
15 Group:          X11/Applications
16 Source0:        http://ftp.gnu.org/gnu/xnee/xnee-%{version}.tar.gz
17 # Source0-md5:  560e8126950d8d4e7c30fc844d556482
18 Patch0:         %{name}-info.patch
19 Patch1:         %{name}-link.patch
20 Patch2:         %{name}-am.patch
21 URL:            http://www.gnu.org/software/xnee/www/index.html
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gtk+2-devel >= 1:2.0.0
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig >= 1:0.9.0
27 BuildRequires:  texinfo
28 BuildRequires:  xorg-proto-recordproto-devel
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xorg-lib-libXi-devel
31 BuildRequires:  xorg-lib-libXtst-devel
32 %if %{with gnome}
33 BuildRequires:  GConf2-devel >= 2.0
34 BuildRequires:  gnome-panel-devel >= 2.0
35 BuildRequires:  gnome-panel-devel < 3
36 %endif
37 %if %{with doc}
38 BuildRequires:  ImageMagick
39 BuildRequires:  ImageMagick-coder-jpeg
40 BuildRequires:  ImageMagick-coder-png
41 BuildRequires:  dia
42 BuildRequires:  ghostscript
43 BuildRequires:  tetex-dvips
44 BuildRequires:  tetex-format-plain
45 BuildRequires:  tetex-tex-misc
46 BuildRequires:  texinfo-texi2dvi
47 %endif
48 Provides:       xnee
49 Obsoletes:      xnee
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Xnee is a suite of programs that can record, replay and distribute
54 user actions under the X11 environment. Think of it as a robot that
55 can imitate the job you just did. Xnee can be used to: automate tests,
56 demonstrate programs, distribute actions, record and replay "macros",
57 retype a file etc.
58
59 %description -l pl.UTF-8
60 Xnee to zestaw programów do nagrywania, odtwarzania i powielania akcji
61 użytkownika w środowisku X11. Można je określić jako maszynę
62 powtarzającą pracę wykonaną przez nas. Xnee można użyć do:
63 automatyzowania testów, demonstrowania programów, powielania akcji (na
64 wielu komputerach), nagrywania i odtwarzania "makr", przepisywania
65 plików itp.
66
67 %package gtk
68 Summary:        gnee - GTK+ based graphical frontent to GNU Xnee
69 Summary(pl.UTF-8):      gnee - oparty na GTK+ graficzny interfejs do GNU Xnee
70 Group:          X11/Applications
71 Requires:       %{name} = %{version}-%{release}
72
73 %description gtk
74 gnee is the graphical frontend to GNU Xnee, based on GTK+ toolkit.
75
76 %description gtk -l pl.UTF-8
77 gnee to graficzny interfejs do GNU Xnee, oparty na GTK+.
78
79 %package gnome
80 Summary:        pnee - GNOME panel applet for GNU Xnee
81 Summary(pl.UTF-8):      pnee - aplet panelu GNOME dla GNU Xnee
82 Group:          X11/Applications
83 Requires:       %{name} = %{version}-%{release}
84
85 %description gnome
86 pnee is the GNOME panel applet for GNU Xnee.
87
88 %description gnome -l pl.UTF-8
89 pnee to aplet panelu GNOME dla GNU Xnee.
90
91 %prep
92 %setup -q -n xnee-%{version}
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96
97 %build
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 # disable static as no API is installed
104 %configure \
105         --disable-doc \
106         --disable-static \
107         --disable-static-programs \
108         %{?with_gnome:--enable-gnome-applet} \
109         --enable-gui \
110         --enable-lib \
111         --enable-xosd
112
113 %{__make} \
114         CNEE_INFO="cnee.info"
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT \
121         CNEE_INFO="cnee.info" \
122         PANEL_APPLET_DIR=$RPM_BUILD_ROOT%{_bindir} \
123         PANEL_SERVER_DIR=$RPM_BUILD_ROOT%{_libdir}/bonobo/servers
124
125 # API not installed
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxnee.{so,la}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/postshell
132 -/sbin/ldconfig
133 -/usr/sbin/fix-info-dir -c %{_infodir}
134
135 %postun -p /sbin/postshell
136 -/sbin/ldconfig
137 -/usr/sbin/fix-info-dir -c %{_infodir}
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
142 %attr(755,root,root) %{_bindir}/cnee
143 %attr(755,root,root) %{_libdir}/libxnee.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libxnee.so.0
145 %dir %{_datadir}/xnee
146 %{_datadir}/xnee/*.sh
147 %{_datadir}/xnee/*.xns
148 %{_pixmapsdir}/xnee.png
149 %{_pixmapsdir}/xnee.xpm
150 %{_mandir}/man1/cnee.1*
151 %{_mandir}/man1/xnee.1*
152 %{_infodir}/cnee.info*
153
154 %files gtk
155 %defattr(644,root,root,755)
156 %doc gnee/AUTHORS
157 %attr(755,root,root) %{_bindir}/gnee
158 %{_mandir}/man1/gnee.1*
159
160 %if %{with gnome}
161 %files gnome
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/pnee
164 %{_libdir}/bonobo/servers/pnee.server
165 %dir %{_datadir}/xnee/pixmaps
166 %{_datadir}/xnee/pixmaps/pnee-*.png
167 %{_mandir}/man1/pnee.1*
168 %endif
This page took 0.081505 seconds and 3 git commands to generate.