]> git.pld-linux.org Git - packages/XmHTML.git/blobdiff - XmHTML.spec
- rebuild without libjpeg.la
[packages/XmHTML.git] / XmHTML.spec
index 43291cd0f58f72865b86ffab99c720554d8a0524..eb5dac6c51c5b59e5bbc9f40b7a45d6f22bf4fb1 100644 (file)
@@ -1,96 +1,94 @@
+# Note: upstream automake stuff is outdated, imake stuff outdated even more,
+# plain Makefiles not outdated but messy.
+# Use automake with some patches.
+#
+# Conditional build:
+%bcond_without xft     # Xft support
+
 Summary:       Motif HTML widget
-Summary(pl):   Widget do HTML-a oparty o Motif
+Summary(pl.UTF-8):     Widget do HTML-a oparty o Motif
 Name:          XmHTML
-Version:       1.1.7
-Release:       4
-License:       LGPL
+Version:       1.1.10
+Release:       2
+License:       LGPL v2+
 Group:         X11/Libraries
-Source0:       http://www.xs4all.nl/~ripley/XmHTML/dist/%{name}-%{version}.tar.gz
-# Source0-md5: 6d079435fb954bb7878f4dd0d3f7b8d8
+Source0:       http://downloads.sourceforge.net/xmhtml/%{name}-%{version}.tgz
+# Source0-md5: fd339d59d020da2ccf6e92bf65b810e2
 Patch0:                %{name}-am.patch
-Patch1:                %{name}-macro.patch
-URL:           http://www.xs4all.nl/~ripley/XmHTML/
+Patch1:                %{name}-build.patch
+Patch2:                %{name}-xft.patch
+URL:           https://sourceforge.net/projects/xmhtml/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 BuildRequires: libtool
 BuildRequires: motif-devel >= 1.2
+%{?with_xft:BuildRequires:     xorg-lib-libXft-devel}
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXpm-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 XmHTML provides a widget capable of displaying HTML 3.2 conforming
 text.
 
-%description -l pl
-XmHTML zawiera widget wy¶wietlaj±cy HTML w wersji 3.2.
+%description -l pl.UTF-8
+XmHTML zawiera widget wyświetlający HTML w wersji 3.2.
 
 %package devel
 Summary:       Development package of XmHTML
-Summary(pl):   Pliki nag³ówkowe XmHTML
+Summary(pl.UTF-8):     Pliki nagłówkowe XmHTML
 Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      libjpeg-devel
 Requires:      libpng-devel
 Requires:      motif-devel >= 1.2
+%{?with_xft:Requires:  xorg-lib-libXft-devel}
 
 %description devel
 Headers needed to compile XmHTML programs.
 
-%description devel -l pl
-Pliki nag³ówkowe potrzebne do kompilowania programów korzystaj±cych z
+%description devel -l pl.UTF-8
+Pliki nagłówkowe potrzebne do kompilowania programów korzystających z
 XmHTML.
 
 %package static
 Summary:       Static version of XmHTML library
-Summary(pl):   Statyczna biblioteka XmHTML
+Summary(pl.UTF-8):     Statyczna biblioteka XmHTML
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static version of XmHTML library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna wersja biblioteki XmHTML.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
-# Argh! automake stuff outdated, imake stuff outdated even more,
-# makefiles not outdated but don't support shared libraries :/
-# Use automake with some patches/workarounds/etc
-cd lib
-mv -f common/*.c .
-mv -f Motif/*.c .
-cd ..
-
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
-CFLAGS="%{rpmcflags} \
-       -I`pwd`/include/XmHTML -I`pwd`/include/common \
-       %{!?debug:-DNDEBUG -Dproduction} -DVERSION=1107"
-%configure
+%{!?debug:CPPFLAGS="%{rpmcppflags} -DNDEBUG -Dproduction"}
+%configure \
+       %{?with_xft:--with-xft}
 
-cd lib
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_includedir}/XmHTML
 
-%{__make} install -C lib \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install include/XmHTML/{Balloon,HTML,HTMLStrings,XCC,XmHTML}.h \
-       include/common/LZWStream.h \
-       $RPM_BUILD_ROOT%{_includedir}/XmHTML
-
-rm -f html/man/man.{map,tmpl}
+%{__rm} html/man/man.{map,tmpl}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -100,17 +98,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc APPS BUG-REPORTING CHANGES DEBUGGING FEEDBACK FIXES
-%doc README THANKS TODO docs/{QUOTES,README.*,REASONS,progressive.txt}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc APPS BUG-REPORTING CHANGES Changelog.txt DEBUGGING FEEDBACK FIXES LICENSE README THANKS TODO docs/{QUOTES,README.*,REASONS,progressive.txt}
+%attr(755,root,root) %{_libdir}/libXmHTML.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libXmHTML.so.0
 
 %files devel
 %defattr(644,root,root,755)
 %doc html/*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%attr(755,root,root) %{_libdir}/libXmHTML.so
+%{_libdir}/libXmHTML.la
 %{_includedir}/XmHTML
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libXmHTML.a
This page took 0.465758 seconds and 4 git commands to generate.