]> git.pld-linux.org Git - packages/X11-driver-nvidia-legacy.git/commitdiff
- 2.6.14 kernel headers generate many warnings so don't use -Werror at all.
authorPaweł Sikora <pluto@pld-linux.org>
Thu, 26 Jan 2006 18:43:17 +0000 (18:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  we should care only for -Werror-implicit-functions-declarations
  for conftest.sh correctness.

Changed files:
    X11-driver-nvidia-gcc34.patch -> 1.3

X11-driver-nvidia-gcc34.patch

index ca78c21b93fbad24425d9f01c7ef8b27c2f1d09d..0b7c8237431b822a98511780b89b26a63d9f2223 100644 (file)
@@ -9,3 +9,25 @@ diff -uNr NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv/nv.c NVIDIA-Linux-x86-1.0-53
  };
  
  static nv_file_private_t *
+--- NVIDIA-Linux-x86_64-1.0-8178-pkg1/usr/src/nv/Makefile.kbuild.orig  2006-01-26 19:37:49.000000000 +0100
++++ NVIDIA-Linux-x86_64-1.0-8178-pkg1/usr/src/nv/Makefile.kbuild       2006-01-26 19:22:54.000000000 +0100
+@@ -73,7 +73,7 @@
+ #
+ EXTRA_CFLAGS += -I$(src)
+-EXTRA_CFLAGS += -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses   -Wno-multichar  -Werror -O -fno-common -mno-red-zone -minline-all-stringops -MD $(DEFINES) $(INCLUDES) -Wsign-compare -Wno-cast-qual -Wno-error
++EXTRA_CFLAGS += -Wall -Werror-implicit-function-declaration -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar -O -fno-common -mno-red-zone -minline-all-stringops -MD $(DEFINES) $(INCLUDES) -Wsign-compare -Wno-cast-qual
+ #
+ # We rely on these two definitions below; if they aren't set, we set them to
+--- NVIDIA-Linux-x86_64-1.0-8178-pkg1/usr/src/nv/conftest.sh.orig      2005-12-15 02:34:40.000000000 +0100
++++ NVIDIA-Linux-x86_64-1.0-8178-pkg1/usr/src/nv/conftest.sh   2006-01-26 19:21:46.000000000 +0100
+@@ -23,7 +23,7 @@
+ CFLAGS="-D__KERNEL__ \
+ -nostdinc -isystem $ISYSTEM \
+--Werror -Wimplicit-function-declaration"
++-Werror-implicit-function-declaration"
+ if [ "$OUTPUT" != "$SOURCES" ]; then
+     ARCH=`uname -m | sed -e 's/i.86/i386/'`
This page took 0.062691 seconds and 4 git commands to generate.