]> git.pld-linux.org Git - packages/WordZ.git/commitdiff
- flags, compiler
authorlisu <lisu@pld-linux.org>
Wed, 24 Dec 2008 09:14:20 +0000 (09:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    WordZ-Makefile.patch -> 1.1

WordZ-Makefile.patch [new file with mode: 0644]

diff --git a/WordZ-Makefile.patch b/WordZ-Makefile.patch
new file mode 100644 (file)
index 0000000..5ba05c9
--- /dev/null
@@ -0,0 +1,29 @@
+--- Wordz-src/Makefile~        2008-12-24 02:14:28.000000000 +0100
++++ Wordz-src/Makefile 2008-12-24 09:39:54.000000000 +0100
+@@ -9,19 +9,19 @@
+       @echo Type \"make linux\" or \"make windows\"
+ linux:
+-      g++ -DDATAPATH=\"$(DATAPATH)\" *.cpp -o wordz \
+-                     `sdl-config --cflags --libs` -lGL -lGLU
++      $(CXX) $(CFLAGS) $(LDFLAGS) -DDATAPATH=\"$(DATAPATH)\" *.cpp -o wordz `sdl-config --cflags --libs` -lGL -lGLU
+ windows:
+       g++ -mwindows *.cpp icon.res -o wordz.exe -lsdl -lopengl32 -lglu32
+       strip wordz.exe
+ install:
+-      cp wordz $(PREFIX)/bin
+-      mkdir -p $(DATAPATH)
+-      cp data/font.bmp $(DATAPATH)
+-      cp data/icon.bmp $(DATAPATH)
+-      cp data/words $(DATAPATH)
++      mkdir -p $(DESTDIR)$(PREFIX)/bin
++      cp wordz $(DESTDIR)$(PREFIX)/bin
++      mkdir -p $(DESTDIR)$(DATAPATH)
++      cp data/font.bmp $(DESTDIR)$(DATAPATH)
++      cp data/icon.bmp $(DESTDIR)$(DATAPATH)
++      cp data/words $(DESTDIR)$(DATAPATH)
+ uinstall:
+       rm $(PREFIX)/bin/wordz
This page took 0.075567 seconds and 4 git commands to generate.