]> git.pld-linux.org Git - packages/WordNet.git/commitdiff
- rel 4; fix build with tcl/tk 8.6 auto/th/WordNet-3.0-4
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 3 Jun 2014 10:18:21 +0000 (12:18 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 3 Jun 2014 10:18:21 +0000 (12:18 +0200)
WordNet-build.patch [new file with mode: 0644]
WordNet.spec

diff --git a/WordNet-build.patch b/WordNet-build.patch
new file mode 100644 (file)
index 0000000..4bec811
--- /dev/null
@@ -0,0 +1,40 @@
+--- WordNet-3.0/lib/binsrch.c~ 2006-11-29 22:02:21.000000000 +0100
++++ WordNet-3.0/lib/binsrch.c  2014-06-03 12:12:58.435884045 +0200
+@@ -187,7 +187,7 @@
+     copyfile(fp, tfp);
+     if (fseek(fp, offset, 0) == -1)
+       return(NULL);           /* could not seek to offset */
+-    fprintf(fp, new_line);    /* write line */
++    fprintf(fp, "%s", new_line);      /* write line */
+     rewind(tfp);
+     copyfile(tfp, fp);
+@@ -214,7 +214,7 @@
+     copyfile(fp, tfp);
+     if (fseek(fp, offset, 0) == -1)
+       return(NULL);           /* could not seek to offset */
+-    fprintf(fp, new_line);    /* write line */
++    fprintf(fp, "%s", new_line);      /* write line */
+     rewind(tfp);
+     copyfile(tfp, fp);
+--- WordNet-3.0/src/wn.c~      2006-11-30 22:40:26.000000000 +0100
++++ WordNet-3.0/src/wn.c       2014-06-03 12:16:04.205515240 +0200
+@@ -283,7 +283,7 @@
+           printf("\t");
+           printf(searchstr[j].template,
+                  partchars[dbase], partchars[dbase]);
+-          printf(searchstr[j].helpstr);
++          printf("%s", searchstr[j].helpstr);
+           printf("\n");
+       }
+ }
+@@ -344,7 +344,7 @@
+ static int error_message(char *msg)
+ {
+-    fprintf(stderr, msg);
++    fprintf(stderr, "%s", msg);
+     return(0);
+ }
index 7bb055577180ea62483db2514ba089cb66a3a3ec..0beff50478b53fb68714d58d3362038763a551b2 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Online lexical reference system, ie. smart dictionary
 Summary(pl.UTF-8):     System referencji słownikowych, czyli mądry słownik
 Name:          WordNet
 Version:       3.0
-Release:       3
+Release:       4
 License:       Free to use (see COPYING)
 Group:         Applications/Dictionaries
 Source0:       ftp://ftp.cogsci.princeton.edu/pub/wordnet/3.0/%{name}-%{version}.tar.bz2
@@ -10,6 +10,7 @@ Source0:      ftp://ftp.cogsci.princeton.edu/pub/wordnet/3.0/%{name}-%{version}.tar.b
 Patch0:                %{name}-FHS.patch
 Patch1:                %{name}-shared.patch
 Patch2:                %{name}-dictdir.patch
+Patch3:                %{name}-build.patch
 URL:           http://wordnet.princeton.edu/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -76,6 +77,7 @@ Graficzny interfejs do sieciowej bazy danych słownika WordNet.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
@@ -83,7 +85,8 @@ Graficzny interfejs do sieciowej bazy danych słownika WordNet.
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       CPPFLAGS="-DUSE_INTERP_RESULT %{rpmcppflags}"
 %{__make}
 
 %install
This page took 0.087646 seconds and 4 git commands to generate.