]> git.pld-linux.org Git - packages/WordNet.git/commitdiff
- updated to 2.1
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 18 Dec 2005 19:07:39 +0000 (19:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    WordNet-FHS.patch -> 1.1
    WordNet-shared.patch -> 1.2
    WordNet-typo.patch -> 1.1

WordNet-FHS.patch [new file with mode: 0644]
WordNet-shared.patch
WordNet-typo.patch [new file with mode: 0644]

diff --git a/WordNet-FHS.patch b/WordNet-FHS.patch
new file mode 100644 (file)
index 0000000..7822716
--- /dev/null
@@ -0,0 +1,35 @@
+--- WordNet-2.1/dict/Makefile.am~      2005-05-13 21:03:17.000000000 +0300
++++ WordNet-2.1/dict/Makefile.am       2005-12-17 22:29:53.000000000 +0200
+@@ -1,2 +1,2 @@
+-dictdir = $(prefix)/dict
++dictdir = $(datadir)/WordNet/dict
+ dict_DATA = adj.exc adv.exc cntlist cntlist.rev data.adj data.adv data.noun data.verb frames.vrb index.adj index.adv index.noun index.sense index.verb log.grind.2.1 noun.exc sentidx.vrb sents.vrb verb.Framestext verb.exc
+--- WordNet-2.1/include/wn.h~  2005-12-17 22:55:38.000000000 +0200
++++ WordNet-2.1/include/wn.h   2005-12-17 22:55:40.000000000 +0200
+@@ -30,7 +30,7 @@
+ #define CNTLISTFILE     "%s\\cntlist.rev"
+ #else
+ #define DICTDIR         "/dict"
+-#define DEFAULTPATH   "/usr/local/WordNet-2.1/dict"
++#define DEFAULTPATH   "/usr/share/WordNet/dict"
+ #define DATAFILE      "%s/data.%s"
+ #define INDEXFILE     "%s/index.%s"
+ #define SENSEIDXFILE  "%s/index.sense"
+--- WordNet-2.1/src/wnb~       2005-06-07 22:19:22.000000000 +0300
++++ WordNet-2.1/src/wnb        2005-12-17 23:06:27.000000000 +0200
+@@ -103,7 +103,7 @@
+ if {$tcl_platform(platform) == "unix"} {
+    if {[lsearch -exact [array names env] WNHOME] == -1} {
+-      set resourcedir "/usr/local/WordNet-2.1/lib/wnres"
++      set resourcedir "/usr/share/WordNet/wnres"
+    } else {
+       set resourcedir "$env(WNHOME)/lib/wnres"
+    }
+--- WordNet-2.1/lib/wnres/Makefile.am~ 2005-06-17 22:15:51.000000000 +0300
++++ WordNet-2.1/lib/wnres/Makefile.am  2005-12-17 23:10:36.000000000 +0200
+@@ -1,3 +1,3 @@
+ EXTRA_DIST = license.txt wn.xbm wnb.man wngloss.man
+-wnresdir = $(prefix)/lib/wnres
++wnresdir = $(datadir)/WordNet/wnres
+ wnres_DATA = license.txt wn.xbm wnb.man wngloss.man
index 7df35597a1fd96d06441e36e206f4512a99a702f..80f3b27c4b5741570ed659e5b2d82033d2dcb178 100644 (file)
@@ -1,30 +1,34 @@
-diff -Naur WordNet-1.7.1/src/lib/Makefile WordNet-1.7.1-p/src/lib/Makefile
---- WordNet-1.7.1/src/lib/Makefile     Thu Oct 30 12:17:43 2003
-+++ WordNet-1.7.1-p/src/lib/Makefile   Thu Oct 30 12:18:39 2003
-@@ -7,6 +7,7 @@
- WN_INCDIR = $(WN_ROOT)/include
+--- WordNet-2.1/lib/Makefile.am~       2005-12-17 22:38:12.000000000 +0200
++++ WordNet-2.1/lib/Makefile.am        2005-12-17 22:38:35.000000000 +0200
+@@ -1,5 +1,5 @@
+-lib_LIBRARIES = libWN.a
+-libWN_a_SOURCES = binsrch.c morph.c search.c wnglobal.c wnhelp.c wnrtl.c wnutil.c
+-libWN_a_CPPFLAGS = $(INCLUDES)
++lib_LTLIBRARIES = libWN.la
++libWN_la_SOURCES = binsrch.c morph.c search.c wnglobal.c wnhelp.c wnrtl.c wnutil.c
++libWN_la_CPPFLAGS = $(INCLUDES)
+ INCLUDES = -I$(top_srcdir)/include
+ SUBDIRS = wnres
+--- WordNet-2.1/configure.ac~  2005-07-08 21:19:09.000000000 +0300
++++ WordNet-2.1/configure.ac   2005-12-17 22:40:22.000000000 +0200
+@@ -12,6 +12,7 @@
+ AC_PROG_CC
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
++AC_PROG_LIBTOOL
  
- WN_FILES = libwn.a
-+WN_SHARED = libwn.so
- SRC = binsrch.c morph.c search.c setutil.c wnglobal.c wnhelp.c wnrtl.c wnutil.c
- OBJ = binsrch.o morph.o search.o setutil.o wnglobal.o wnhelp.o wnrtl.o wnutil.o
+ # Checks for header files.
+ AC_HEADER_STDC
+--- WordNet-2.1/configure.ac~  2005-12-17 22:40:37.000000000 +0200
++++ WordNet-2.1/configure.ac   2005-12-17 22:41:01.000000000 +0200
+@@ -10,9 +10,8 @@
  
-@@ -14,7 +15,7 @@
- LOCAL_CFLAGS = -O -DUNIX
- CFLAGS = -I$(WN_INCDIR) $(LOCAL_CFLAGS) -I../include
--all: $(WN_FILES) 
-+all: $(WN_FILES) $(WN_SHARED)
- install: $(WN_FILES)
-       @if [ ! -d $(WN_INSTALLDIR) ] ; then \
-@@ -53,6 +54,9 @@
- $(WN_FILES): $(OBJ)
-       ar rcv $(WN_FILES) $(OBJ); ranlib $(WN_FILES)
-+$(WN_SHARED): $(OBJ)
-+      $(CC) -shared -o $(WN_SHARED) $(OBJ)
-+
- clean:
-       @rm -f $(WN_FILES) $(OBJ) core *~ "#"*
+ # Checks for programs.
+ AC_PROG_CC
+-AC_PROG_RANLIB
+-AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
++AC_PROG_INSTALL
  
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/WordNet-typo.patch b/WordNet-typo.patch
new file mode 100644 (file)
index 0000000..f9f632f
--- /dev/null
@@ -0,0 +1,11 @@
+--- WordNet-2.1/src/stubs.c~   2005-07-06 21:49:05.000000000 +0300
++++ WordNet-2.1/src/stubs.c    2005-12-17 22:20:40.000000000 +0200
+@@ -14,7 +14,7 @@
+ #include <tk.h>
+ #include <wn.h>
+-static Id = "$Id$";
++static char *Id = "$Id$";
+ static char resultbuf[SEARCHBUF];
This page took 0.074341 seconds and 4 git commands to generate.