]> git.pld-linux.org Git - packages/WindowMaker.git/blobdiff - WindowMaker-shared.patch
- updated for 0.92.0 + cvs patch
[packages/WindowMaker.git] / WindowMaker-shared.patch
index 7c65c6695ce6319c729d840d256a8f6fd08b294b..6d292dd7a6192dffeff32049393197c0617f71c2 100644 (file)
@@ -1,47 +1,91 @@
-diff -Nru WindowMaker-0.64.0/WINGs/Examples/Makefile.am WindowMaker-0.64.0.new/WINGs/Examples/Makefile.am
---- WindowMaker-0.64.0/WINGs/Examples/Makefile.am      Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/WINGs/Examples/Makefile.am  Tue Feb 13 18:56:19 2001
-@@ -6,17 +6,17 @@
- noinst_PROGRAMS = connect server fontl puzzle
+--- WindowMaker-0.80.0/WINGs/Examples/Makefile.am.orig Thu Oct 11 11:59:54 2001
++++ WindowMaker-0.80.0/WINGs/Examples/Makefile.am      Thu Jan  3 06:09:41 2002
+@@ -2,31 +2,18 @@
  
+ AUTOMAKE_OPTIONS = no-dependencies
  
--LDADD= $(top_builddir)/WINGs/libWINGs.a $(top_builddir)/wrlib/libwraster.la \
-+LDADD= $(top_builddir)/WINGs/libWINGs.la $(top_builddir)/wrlib/libwraster.la \
-       @LIBPL@
+-
+ noinst_PROGRAMS = connect server fontl puzzle colorpick
  
++LDADD= $(top_builddir)/WINGs/libWINGs.la $(top_builddir)/wrlib/libwraster.la \
++      $(XFTLIBS) $(INTLIBS)
  
+-LDADD= $(top_builddir)/WINGs/libWINGs.a $(top_builddir)/wrlib/libwraster.la \
+-      @XFTLIBS@ @INTLIBS@
+-
+-colorpick_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.a
+-
 -fontl_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.a
-+fontl_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la
+-
 -puzzle_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.a
-+puzzle_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la
+-
 -connect_DEPENDENCIES = $(top_builddir)/WINGs/libWUtil.a
-+connect_DEPENDENCIES = $(top_builddir)/WINGs/libWUtil.la
+-
 -connect_LDADD = $(top_builddir)/WINGs/libWUtil.a @LIBRARY_SEARCH_PATH@ \
-+connect_LDADD = $(top_builddir)/WINGs/libWUtil.la @LIBRARY_SEARCH_PATH@ \
-       @NETLIBS@ @LIBPL@
- server_DEPENDENCIES = $(top_builddir)/WINGs/libWUtil.a
-diff -Nru WindowMaker-0.64.0/WINGs/Extras/Makefile.am WindowMaker-0.64.0.new/WINGs/Extras/Makefile.am
---- WindowMaker-0.64.0/WINGs/Extras/Makefile.am        Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/WINGs/Extras/Makefile.am    Tue Feb 13 18:56:19 2001
-@@ -26,7 +26,7 @@
+-      @NETLIBS@ @INTLIBS@
+-
+-server_DEPENDENCIES = $(top_builddir)/WINGs/libWUtil.a
+-
+-server_LDADD = $(top_builddir)/WINGs/libWUtil.a @LIBRARY_SEARCH_PATH@ \
+-      @NETLIBS@ @INTLIBS@
++connect_LDADD = $(top_builddir)/WINGs/libWUtil.la $(LIBRARY_SEARCH_PATH) \
++      $(NETLIBS) $(INTLIBS)
++server_LDADD = $(top_builddir)/WINGs/libWUtil.la $(LIBRARY_SEARCH_PATH) \
++      $(NETLIBS) $(INTLIBS)
+ INCLUDES = -I$(top_srcdir)/WINGs -I$(top_srcdir)/wrlib -I$(top_srcdir)/src \
+-      -DRESOURCE_PATH=\"$(datadir)/WINGs\" @HEADER_SEARCH_PATH@ -DDEBUG
++      -DRESOURCE_PATH=\"$(datadir)/WINGs\" $(HEADER_SEARCH_PATH) -DDEBUG
+--- WindowMaker-0.80.0/WINGs/Extras/Makefile.am.orig   Thu Oct 11 11:59:54 2001
++++ WindowMaker-0.80.0/WINGs/Extras/Makefile.am        Thu Jan  3 06:12:10 2002
+@@ -2,33 +2,28 @@
+ AUTOMAKE_OPTIONS = no-dependencies
+-
+-
+ # is this a kluge? if so, how should i do it?
+ includedir = @includedir@/WINGs
+ include_HEADERS = wtableview.h wtabledelegates.h 
+-
+-lib_LIBRARIES = libExtraWINGs.a 
++lib_LTLIBRARIES = libExtraWINGs.la
++libExtraWINGs_la_LIBADD = $(top_builddir)/WINGs/libWINGs.la
+ noinst_PROGRAMS = test
+-EXTRA_DIST = 
+-
+-libExtraWINGs_a_SOURCES =     \
++libExtraWINGs_la_SOURCES =    \
+       wtableview.c \
+       wtabledelegates.c \
+       wtableview.h \
+       wtabledelegates.h 
+ AM_CFLAGS = @NOSTRICTALIASING@
+
  INCLUDES = -I$(top_srcdir)/wrlib -I$(top_srcdir)/WINGs \
-       -DRESOURCE_PATH=\"$(datadir)/WINGs\" @HEADER_SEARCH_PATH@ -DDEBUG
+-      -DRESOURCE_PATH=\"$(datadir)/WINGs\" @HEADER_SEARCH_PATH@ -DDEBUG
++      -DRESOURCE_PATH=\"$(datadir)/WINGs\" $(HEADER_SEARCH_PATH)
  
 -LDADD= $(top_builddir)/WINGs/libWINGs.a $(top_builddir)/wrlib/libwraster.la \
+-      @XFTLIBS@ @INTLIBS@
 +LDADD= $(top_builddir)/WINGs/libWINGs.la $(top_builddir)/wrlib/libwraster.la \
-         @LIBPL@ 
++      $(XFTLIBS) $(INTLIBS)
  
  test_LDADD = wtableview.o wtabledelegates.o $(LDADD)
-diff -Nru WindowMaker-0.64.0/WINGs/Makefile.am WindowMaker-0.64.0.new/WINGs/Makefile.am
---- WindowMaker-0.64.0/WINGs/Makefile.am       Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/WINGs/Makefile.am   Tue Feb 13 19:00:21 2001
-@@ -4,22 +4,19 @@
+-
+--- WindowMaker-0.70.0.orig/WINGs/Makefile.am  Thu Oct  4 05:39:17 2001
++++ WindowMaker-0.70.0/WINGs/Makefile.am       Thu Oct 18 16:54:22 2001
+@@ -4,24 +4,21 @@
  
- SUBDIRS = WINGs . Documentation Resources Examples Extras Tests
+ SUBDIRS = WINGs . po Documentation Resources Examples Extras Tests
  
 -
 -
@@ -50,16 +94,17 @@ diff -Nru WindowMaker-0.64.0/WINGs/Makefile.am WindowMaker-0.64.0.new/WINGs/Make
  bin_SCRIPTS = get-wings-flags get-wutil-flags
  
 -lib_LIBRARIES = libWINGs.a libWUtil.a
--
++LDADD= libWINGs.la $(top_builddir)/wrlib/libwraster.la @INTLIBS@
 +lib_LTLIBRARIES = libWINGs.la libWUtil.la
++libWINGs_la_LIBADD = $(top_builddir)/wrlib/libwraster.la $(XFTLIBS)
+-LDADD= libWINGs.a $(top_builddir)/wrlib/libwraster.la @INTLIBS@
  
--LDADD= libWINGs.a $(top_builddir)/wrlib/libwraster.la @LIBPL@
-+libWINGs_la_LDFLAGS = -version-info 1:1:0
-+libWUtil_la_LDFLAGS = -version-info 1:1:0
  
-+LDADD= libWINGs.la $(top_builddir)/wrlib/libwraster.la @LIBPL@
+ EXTRA_DIST = BUGS python/Makefile python/README python/WINGs.i \
+       python/WINGs.py python/setup.py python/test.py
  
- EXTRA_DIST = BUGS
  
  # wbutton.c 
 -libWINGs_a_SOURCES =  \
@@ -67,7 +112,7 @@ diff -Nru WindowMaker-0.64.0/WINGs/Makefile.am WindowMaker-0.64.0.new/WINGs/Make
        array.c \
        bagtree.c \
        configuration.c \
-@@ -74,7 +71,7 @@
+@@ -80,7 +78,7 @@
        wwindow.c
  
  
@@ -76,28 +121,34 @@ diff -Nru WindowMaker-0.64.0/WINGs/Makefile.am WindowMaker-0.64.0.new/WINGs/Make
        array.c \
        bagtree.c \
        connection.c \
-diff -Nru WindowMaker-0.64.0/WINGs/Tests/Makefile.am WindowMaker-0.64.0.new/WINGs/Tests/Makefile.am
---- WindowMaker-0.64.0/WINGs/Tests/Makefile.am Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/WINGs/Tests/Makefile.am     Tue Feb 13 18:56:19 2001
-@@ -4,13 +4,13 @@
+diff -ur WindowMaker-CVS-20040723.orig/WINGs/Tests/Makefile.am WindowMaker-CVS-20040723/WINGs/Tests/Makefile.am
+--- WindowMaker-CVS-20040723.orig/WINGs/Tests/Makefile.am      2004-04-11 07:01:02.000000000 +0200
++++ WindowMaker-CVS-20040723/WINGs/Tests/Makefile.am   2004-09-05 03:55:39.906430016 +0200
+@@ -4,19 +4,16 @@
  
- noinst_PROGRAMS = wtest wmquery wmfile testmywidget testcolorpanel 
+ noinst_PROGRAMS = wtest wmquery wmfile testmywidget 
  
 -LDADD= $(top_builddir)/WINGs/libWINGs.a $(top_builddir)/wrlib/libwraster.la \
+-      @XFTLIBS@ @INTLIBS@
 +LDADD= $(top_builddir)/WINGs/libWINGs.la $(top_builddir)/wrlib/libwraster.la \
-       @LIBPL@
++      $(XFTLIBS) $(INTLIBS)
  
  
  testmywidget_SOURCES = testmywidget.c mywidget.c mywidget.h 
  
 -wtest_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.a
-+wtest_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la
+-
+-
+ EXTRA_DIST = logo.xpm upbtn.xpm wm.html wm.png
  
+ INCLUDES = -I$(top_srcdir)/WINGs -I$(top_srcdir)/wrlib -I$(top_srcdir)/src \
+-      -DRESOURCE_PATH=\"$(datadir)/WINGs\" @XFTFLAGS@ @HEADER_SEARCH_PATH@ \
++      -DRESOURCE_PATH=\"$(datadir)/WINGs\" $(XFTFLAGS) $(HEADER_SEARCH_PATH) \
+       -DDEBUG
  
- EXTRA_DIST = logo.xpm upbtn.xpm wm.html wm.png
-diff -Nru WindowMaker-0.64.0/WPrefs.app/Makefile.am WindowMaker-0.64.0.new/WPrefs.app/Makefile.am
---- WindowMaker-0.64.0/WPrefs.app/Makefile.am  Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/WPrefs.app/Makefile.am      Tue Feb 13 18:56:19 2001
+--- WindowMaker-0.70.0.orig/WPrefs.app/Makefile.am     Thu Oct  4 05:39:18 2001
++++ WindowMaker-0.70.0/WPrefs.app/Makefile.am  Thu Oct 18 16:54:22 2001
 @@ -46,10 +46,10 @@
  
  INCLUDES = -I$(top_srcdir)/wrlib -I$(top_srcdir)/WINGs @HEADER_SEARCH_PATH@ 
@@ -109,11 +160,11 @@ diff -Nru WindowMaker-0.64.0/WPrefs.app/Makefile.am WindowMaker-0.64.0.new/WPref
 -      $(top_builddir)/WINGs/libWINGs.a\
 +      $(top_builddir)/WINGs/libWINGs.la\
        $(top_builddir)/wrlib/libwraster.la \
-       @LIBPL@ \
+       @XFTLIBS@ \
        @INTLIBS@
-diff -Nru WindowMaker-0.64.0/src/Makefile.am WindowMaker-0.64.0.new/src/Makefile.am
---- WindowMaker-0.64.0/src/Makefile.am Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/src/Makefile.am     Tue Feb 13 18:56:19 2001
+diff -Nur WindowMaker-0.70.0.orig/src/Makefile.am WindowMaker-0.70.0/src/Makefile.am
+--- WindowMaker-0.70.0.orig/src/Makefile.am    Thu Oct  4 05:39:18 2001
++++ WindowMaker-0.70.0/src/Makefile.am Thu Oct 18 16:54:22 2001
 @@ -113,7 +113,7 @@
  
  
@@ -121,11 +172,11 @@ diff -Nru WindowMaker-0.64.0/src/Makefile.am WindowMaker-0.64.0.new/src/Makefile
 -      $(top_builddir)/WINGs/libWINGs.a\
 +      $(top_builddir)/WINGs/libWINGs.la\
        $(top_builddir)/wrlib/libwraster.la\
-       @LIBPL@ \
+       @XFTLIBS@ \
        @XLIBS@ \
-diff -Nru WindowMaker-0.64.0/test/Makefile.am WindowMaker-0.64.0.new/test/Makefile.am
---- WindowMaker-0.64.0/test/Makefile.am        Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/test/Makefile.am    Tue Feb 13 18:56:19 2001
+diff -Nur WindowMaker-0.70.0.orig/test/Makefile.am WindowMaker-0.70.0/test/Makefile.am
+--- WindowMaker-0.70.0.orig/test/Makefile.am   Sat Oct  2 23:16:11 1999
++++ WindowMaker-0.70.0/test/Makefile.am        Thu Oct 18 16:54:22 2001
 @@ -8,7 +8,7 @@
  
  wtest_SOURCES = wtest.c
@@ -135,41 +186,92 @@ diff -Nru WindowMaker-0.64.0/test/Makefile.am WindowMaker-0.64.0.new/test/Makefi
  
  
  INCLUDES = -g -D_BSD_SOURCE @XCFLAGS@ -I$(top_srcdir)/wmlib 
-diff -Nru WindowMaker-0.64.0/util/Makefile.am WindowMaker-0.64.0.new/util/Makefile.am
---- WindowMaker-0.64.0/util/Makefile.am        Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/util/Makefile.am    Tue Feb 13 18:56:19 2001
-@@ -36,19 +36,19 @@
- geticonset_LDADD= $(liblist)
+--- WindowMaker-0.80.0/util/Makefile.am~       Thu Oct 11 11:59:54 2001
++++ WindowMaker-0.80.0/util/Makefile.am        Thu Jan  3 07:12:53 2002
+@@ -1,8 +1,6 @@
+ AUTOMAKE_OPTIONS = no-dependencies
+-pkgdatadir  = $(datadir)/@PACKAGE@
+-
+ bin_PROGRAMS = wxcopy wxpaste wdwrite wdread getstyle setstyle convertfonts \
+       seticons geticonset wmsetbg wmsetup wmagnify
+@@ -12,49 +10,49 @@
+ EXTRA_DIST = wmaker.inst.in bughint wm-oldmenu2new directjpeg.c wkdemenu.pl
+ INCLUDES = $(DFLAGS) -I$(top_srcdir)/WINGs -I$(top_srcdir)/wrlib \
+-      @HEADER_SEARCH_PATH@ \
+-      -DETCDIR=\"sysconfdir\" -DDATADIR=\"pkgdatadir\"
++      $(HEADER_SEARCH_PATH) \
++      -DETCDIR=\"$(sysconfdir)\" -DDATADIR=\"$(pkgdatadir)\"
+-liblist= @LIBRARY_SEARCH_PATH@ @INTLIBS@
++liblist= $(LIBRARY_SEARCH_PATH) $(INTLIBS)
+-wdwrite_LDADD = $(top_builddir)/WINGs/libWUtil.a $(liblist)
++wdwrite_LDADD = $(top_builddir)/WINGs/libWUtil.la $(liblist)
+-wdread_LDADD = $(top_builddir)/WINGs/libWUtil.a $(liblist)
++wdread_LDADD = $(top_builddir)/WINGs/libWUtil.la $(liblist)
+-wxcopy_LDADD = @XLFLAGS@ @XLIBS@ 
++wxcopy_LDADD = $(XLFLAGS) $(XLIBS)
+-wxpaste_LDADD = @XLFLAGS@ @XLIBS@
++wxpaste_LDADD = $(XLFLAGS) $(XLIBS)
+-getstyle_LDADD = $(top_builddir)/WINGs/libWUtil.a $(liblist)
++getstyle_LDADD = $(top_builddir)/WINGs/libWUtil.la $(liblist)
+ getstyle_SOURCES = getstyle.c fontconv.c
+ setstyle_LDADD = \
+-      $(top_builddir)/WINGs/libWUtil.a \
+-      @XLFLAGS@ @XLIBS@ $(liblist)
++      $(top_builddir)/WINGs/libWUtil.la \
++      $(XLFLAGS) $(XLIBS) $(liblist)
+ setstyle_SOURCES = setstyle.c fontconv.c
+-convertfonts_LDADD = $(top_builddir)/WINGs/libWUtil.a $(liblist)
++convertfonts_LDADD = $(top_builddir)/WINGs/libWUtil.la $(liblist)
+ convertfonts_SOURCES = convertfonts.c fontconv.c
+-seticons_LDADD= $(top_builddir)/WINGs/libWUtil.a $(liblist)
++seticons_LDADD= $(top_builddir)/WINGs/libWUtil.la $(liblist)
+-geticonset_LDADD= $(top_builddir)/WINGs/libWUtil.a $(liblist)
++geticonset_LDADD= $(top_builddir)/WINGs/libWUtil.la $(liblist)
  
  wmagnify_LDADD = \
 -      $(top_builddir)/WINGs/libWINGs.a \
 +      $(top_builddir)/WINGs/libWINGs.la \
        $(top_builddir)/wrlib/libwraster.la \
-       @LIBPL@ \
-       @DLLIBS@
+       @XFTLIBS@ @INTLIBS@ @DLLIBS@
  
  wmsetup_LDADD = \
 -      $(top_builddir)/WINGs/libWINGs.a \
 +      $(top_builddir)/WINGs/libWINGs.la \
        $(top_builddir)/wrlib/libwraster.la \
-       @LIBPL@ \
-       @DLLIBS@
+       @XFTLIBS@ @INTLIBS@ @DLLIBS@
  
  wmsetbg_LDADD = \
 -      $(top_builddir)/WINGs/libWINGs.a \
 +      $(top_builddir)/WINGs/libWINGs.la \
        $(top_builddir)/wrlib/libwraster.la \
-       @LIBPL@ \
-       @DLLIBS@
-diff -Nru WindowMaker-0.64.0/wmlib/Makefile.am WindowMaker-0.64.0.new/wmlib/Makefile.am
---- WindowMaker-0.64.0/wmlib/Makefile.am       Tue Feb 13 18:58:56 2001
-+++ WindowMaker-0.64.0.new/wmlib/Makefile.am   Tue Feb 13 18:56:19 2001
-@@ -1,13 +1,13 @@
+       @XFTLIBS@ @INTLIBS@ @DLLIBS@
+--- WindowMaker-0.70.0.orig/wmlib/Makefile.am  Mon Apr 10 02:59:35 2000
++++ WindowMaker-0.70.0/wmlib/Makefile.am       Thu Oct 18 16:54:22 2001
+@@ -1,13 +1,14 @@
  
  AUTOMAKE_OPTIONS = no-dependencies
  
 -lib_LIBRARIES = libWMaker.a
 +lib_LTLIBRARIES = libWMaker.la
++libWMaker_la_LIBADD = $(X_LIBS) -lX11
  
  include_HEADERS = WMaker.h
  
@@ -180,8 +282,12 @@ diff -Nru WindowMaker-0.64.0/wmlib/Makefile.am WindowMaker-0.64.0.new/wmlib/Make
        menu.c          \
        app.c           \
        event.c         \
-@@ -15,3 +15,4 @@
+@@ -15,6 +15,8 @@
        app.h           \
        menu.h  
  
 +libWMaker_la_LDFLAGS = -version-info 1:1:1
++
+ DISTCLEANFILES = wmlib.pc
+ install-exec-local:
This page took 0.078655 seconds and 4 git commands to generate.